]> git.pld-linux.org Git - packages/widelands.git/blame - widelands.spec
- BR: ggz-client-libs-devel
[packages/widelands.git] / widelands.spec
CommitLineData
7764f64d 1#
2# TODO:
11907a39 3# - create bcond for ggz
abdefe8d 4# - check locales
7764f64d 5#
abdefe8d 6%define buildver 16
325beb53 7Summary: Game like Settlers II
bf6aa356 8Summary(pl.UTF-8): Remake gry Settlers II
325beb53 9Name: widelands
48449069 10Version: 0.build%{buildver}
6cd38e44 11Release: 4
11907a39 12License: GPL v2+
325beb53 13Group: X11/Applications/Games
509c89d9 14Source0: http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
abdefe8d 15# Source0-md5: 3d8c28e145b73c64d8ed1625319d25a2
325beb53
AG
16Source1: %{name}.desktop
17URL: http://widelands.sourceforge.net/
7764f64d 18BuildRequires: SDL-devel >= 1.2.11
68f512a6 19BuildRequires: SDL_gfx-devel
325beb53 20BuildRequires: SDL_image-devel
00129253 21BuildRequires: SDL_mixer-devel >= 1.2.7
325beb53 22BuildRequires: SDL_net-devel
7764f64d 23BuildRequires: SDL_ttf-devel >= 2.0.0
48449069 24BuildRequires: boost-devel >= 1.35
509c89d9 25BuildRequires: cmake
eaf6bd51 26BuildRequires: gettext-devel
abdefe8d 27BuildRequires: glew-devel
5cf69a76 28BuildRequires: ggz-client-libs-devel
509c89d9 29BuildRequires: libjpeg-devel
929f8735 30BuildRequires: libpng-devel
325beb53 31BuildRequires: libstdc++-devel
509c89d9 32BuildRequires: libtiff-devel
15cde85f 33BuildRequires: lua51-devel
34BuildRequires: python
35BuildRequires: python-modules
abdefe8d 36BuildRequires: rpmbuild(macros) >= 1.600
48449069 37Requires: SDL_image >= 1.2.10
325beb53
AG
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41In Widelands, you are the regent of a small tribe. You start out with
42nothing but your headquarters, a kind of castle in which all your
43resources are stored. Every member of your tribe will do his or her
44part to produce more resources - wood, food, iron, gold and more - to
45further this growth. But you are not alone in the world, and you will
46meet other tribes sooner or later. Some of them may be friendly and
47trade with you. However, if you want to rule the world, you will have
48to train soldiers and fight.
49
d71c4d09
JR
50%description -l pl.UTF-8
51W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
52grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
53przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
54wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
55żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
56nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
57spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
58nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
59światem, będziesz musiał wyszkolić żołnierzy i walczyć.
325beb53
AG
60
61%prep
509c89d9 62%setup -q -n %{name}-build%{buildver}-src
325beb53
AG
63
64%build
509c89d9 65install -d build
66cd build
67%cmake \
509c89d9 68 -DWL_INSTALL_BINDIR=%{_bindir} \
69 -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
70 -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
509c89d9 71 ..
72
73%{__make}
abdefe8d 74%{__make} lang
325beb53
AG
75
76%install
77rm -rf $RPM_BUILD_ROOT
325beb53 78
509c89d9 79%{__make} -C build install \
80 DESTDIR=$RPM_BUILD_ROOT
bb198b26 81
abdefe8d 82install -d $RPM_BUILD_ROOT{%{_datadir}/games/%{name},%{_desktopdir},%{_pixmapsdir}}
325beb53 83
abdefe8d 84# install data
85cp -a campaigns fonts global maps music pics scripting sound tribes txts worlds $RPM_BUILD_ROOT%{_datadir}/games/%{name}
86
87# locales
88cp -a build/locale $RPM_BUILD_ROOT%{_datadir}/games/%{name}
89
90# unsupported locales
91%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_AU
92%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_CA
93
94# desktop and icon
95cp -a pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
bb198b26 96cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
325beb53
AG
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(644,root,root,755)
48449069 103%doc ChangeLog CREDITS
bb198b26 104%attr(755,root,root) %{_bindir}/%{name}
48449069 105%dir %{_datadir}/games/%{name}
48449069 106%{_datadir}/games/%{name}/campaigns
107%{_datadir}/games/%{name}/fonts
108%{_datadir}/games/%{name}/global
109%{_datadir}/games/%{name}/maps
110%{_datadir}/games/%{name}/music
111%{_datadir}/games/%{name}/pics
abdefe8d 112%{_datadir}/games/%{name}/scripting
48449069 113%{_datadir}/games/%{name}/sound
114%{_datadir}/games/%{name}/tribes
115%{_datadir}/games/%{name}/txts
116%{_datadir}/games/%{name}/worlds
117%dir %{_datadir}/games/%{name}/locale
509c89d9 118%lang(ar) %{_datadir}/games/%{name}/locale/ar
abdefe8d 119%lang(ast) %{_datadir}/games/%{name}/locale/ast
509c89d9 120%lang(ca) %{_datadir}/games/%{name}/locale/ca
121%lang(cs) %{_datadir}/games/%{name}/locale/cs
122%lang(da) %{_datadir}/games/%{name}/locale/da
123%lang(de) %{_datadir}/games/%{name}/locale/de
124%lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
125%lang(eo) %{_datadir}/games/%{name}/locale/eo
126%lang(es) %{_datadir}/games/%{name}/locale/es
abdefe8d 127%lang(et) %{_datadir}/games/%{name}/locale/et
509c89d9 128%lang(eu) %{_datadir}/games/%{name}/locale/eu
abdefe8d 129%lang(fa) %{_datadir}/games/%{name}/locale/fa
509c89d9 130%lang(fi) %{_datadir}/games/%{name}/locale/fi
131%lang(fr) %{_datadir}/games/%{name}/locale/fr
132%lang(gl) %{_datadir}/games/%{name}/locale/gl
133%lang(he) %{_datadir}/games/%{name}/locale/he
134%lang(hu) %{_datadir}/games/%{name}/locale/hu
135%lang(ia) %{_datadir}/games/%{name}/locale/ia
136%lang(id) %{_datadir}/games/%{name}/locale/id
137%lang(it) %{_datadir}/games/%{name}/locale/it
138%lang(ja) %{_datadir}/games/%{name}/locale/ja
abdefe8d 139%lang(ko) %{_datadir}/games/%{name}/locale/ko
509c89d9 140%lang(la) %{_datadir}/games/%{name}/locale/la
abdefe8d 141%lang(ms) %{_datadir}/games/%{name}/locale/ms
142%lang(nb) %{_datadir}/games/%{name}/locale/nb
509c89d9 143%lang(nl) %{_datadir}/games/%{name}/locale/nl
144%lang(nn) %{_datadir}/games/%{name}/locale/nn
abdefe8d 145%lang(oc) %{_datadir}/games/%{name}/locale/oc
509c89d9 146%lang(pl) %{_datadir}/games/%{name}/locale/pl
abdefe8d 147%lang(pt) %{_datadir}/games/%{name}/locale/pt
509c89d9 148%lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
149%lang(ru) %{_datadir}/games/%{name}/locale/ru
150%lang(si) %{_datadir}/games/%{name}/locale/si
151%lang(sk) %{_datadir}/games/%{name}/locale/sk
152%lang(sl) %{_datadir}/games/%{name}/locale/sl
153%lang(sr) %{_datadir}/games/%{name}/locale/sr
154%lang(sv) %{_datadir}/games/%{name}/locale/sv
abdefe8d 155%lang(tr) %{_datadir}/games/%{name}/locale/tr
156%lang(uk) %{_datadir}/games/%{name}/locale/uk
157%lang(vi) %{_datadir}/games/%{name}/locale/vi
158%lang(zh_CN) %{_datadir}/games/%{name}/locale/zh_CN
bb198b26 159%{_desktopdir}/%{name}.desktop
160%{_pixmapsdir}/%{name}.png
This page took 0.133917 seconds and 4 git commands to generate.