]> git.pld-linux.org Git - packages/widelands.git/blame - widelands.spec
- pass %__cxx and %rpmcxxflags, but disable optimization (add -O0) becouse
[packages/widelands.git] / widelands.spec
CommitLineData
7764f64d 1#
2# TODO:
11907a39 3# - create bcond for ggz
7764f64d 4#
48449069 5%define buildver 14
325beb53 6Summary: Game like Settlers II
bf6aa356 7Summary(pl.UTF-8): Remake gry Settlers II
325beb53 8Name: widelands
48449069 9Version: 0.build%{buildver}
10Release: 0.6
11907a39 11License: GPL v2+
325beb53 12Group: X11/Applications/Games
48449069 13Source0: http://dl.sourceforge.net/widelands/Widelands-Build%{buildver}-src.7z
11907a39 14# Source0-md5: 06d63783b82b68af7af26198bc0a5afa
325beb53 15Source1: %{name}.desktop
48449069 16#Patch0: %{name}-syntax.patch
325beb53 17URL: http://widelands.sourceforge.net/
7764f64d 18BuildRequires: SDL-devel >= 1.2.11
68f512a6 19BuildRequires: SDL_gfx-devel
325beb53 20BuildRequires: SDL_image-devel
00129253 21BuildRequires: SDL_mixer-devel >= 1.2.7
325beb53 22BuildRequires: SDL_net-devel
7764f64d 23BuildRequires: SDL_ttf-devel >= 2.0.0
48449069 24BuildRequires: boost-devel >= 1.35
929f8735 25BuildRequires: libpng-devel
325beb53 26BuildRequires: libstdc++-devel
11907a39 27BuildRequires: p7zip
bb198b26 28BuildRequires: scons
11907a39 29BuildRequires: sed >= 4.0
48449069 30Requires: SDL_image >= 1.2.10
325beb53
AG
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34In Widelands, you are the regent of a small tribe. You start out with
35nothing but your headquarters, a kind of castle in which all your
36resources are stored. Every member of your tribe will do his or her
37part to produce more resources - wood, food, iron, gold and more - to
38further this growth. But you are not alone in the world, and you will
39meet other tribes sooner or later. Some of them may be friendly and
40trade with you. However, if you want to rule the world, you will have
41to train soldiers and fight.
42
d71c4d09
JR
43%description -l pl.UTF-8
44W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
45grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
46przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
47wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
48żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
49nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
50spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
51nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
52światem, będziesz musiał wyszkolić żołnierzy i walczyć.
325beb53
AG
53
54%prep
11907a39 55%setup -q -c -T -n %{name}
567z x -o.. %{SOURCE0}
48449069 57#%%patch0 -p1
58#%{__sed} -i 's/framework-mt/framework/' SConstruct
59
60%{__sed} -i '/env.strip=1/d' build/scons-tools/scons_configure.py
325beb53
AG
61
62%build
48449069 63%scons \
64 cxx="%{__cxx}" \
65 cc="%{__cc}" \
66 extra_compile_flags="%{rpmcxxflags} -O0" \
67 extra_link_flags="%{rpmcxxflags} %{rpmldflags}" \
11907a39 68 build="release" \
48449069 69 pretty_compile_output="false" \
70 install_prefix="" \
11907a39 71 bindir="%{_bindir}" \
48449069 72 datadir="%{_datadir}/games/%{name}" \
73 localedir="%{_datadir}/games/%{name}/locale" \
11907a39 74 enable_ggz="false"
325beb53
AG
75
76%install
77rm -rf $RPM_BUILD_ROOT
325beb53 78
48449069 79%{__scons} install \
80 build="release" \
81 install_prefix="$RPM_BUILD_ROOT%{_prefix}" \
82 bindir="$RPM_BUILD_ROOT%{_bindir}" \
83 datadir="$RPM_BUILD_ROOT%{_datadir}/games/%{name}" \
84 localedir="$RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale" \
bb198b26 85
86install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
325beb53 87
bb198b26 88install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
89cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
325beb53
AG
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
48449069 96%doc ChangeLog CREDITS
bb198b26 97%attr(755,root,root) %{_bindir}/%{name}
48449069 98%dir %{_datadir}/games/%{name}
99%{_datadir}/games/%{name}/VERSION
100%{_datadir}/games/%{name}/campaigns
101%{_datadir}/games/%{name}/fonts
102%{_datadir}/games/%{name}/global
103%{_datadir}/games/%{name}/maps
104%{_datadir}/games/%{name}/music
105%{_datadir}/games/%{name}/pics
106%{_datadir}/games/%{name}/sound
107%{_datadir}/games/%{name}/tribes
108%{_datadir}/games/%{name}/txts
109%{_datadir}/games/%{name}/worlds
110%dir %{_datadir}/games/%{name}/locale
111%lang(cs) %{_datadir}/games/%{name}/locale/cs_CZ
112%lang(da) %{_datadir}/games/%{name}/locale/da_DK
113%lang(de) %{_datadir}/games/%{name}/locale/de_DE
114%lang(es) %{_datadir}/games/%{name}/locale/es_ES
115%lang(fi) %{_datadir}/games/%{name}/locale/fi_FI
116%lang(fr) %{_datadir}/games/%{name}/locale/fr_FR
117%lang(gl) %{_datadir}/games/%{name}/locale/gl_ES
118%lang(he) %{_datadir}/games/%{name}/locale/he_HE
119%lang(hu) %{_datadir}/games/%{name}/locale/hu_HU
120%lang(it) %{_datadir}/games/%{name}/locale/it_IT
121%lang(nl) %{_datadir}/games/%{name}/locale/nl_NL
122%lang(pl) %{_datadir}/games/%{name}/locale/pl_PL
123%lang(ru) %{_datadir}/games/%{name}/locale/ru_RU
124%lang(sk) %{_datadir}/games/%{name}/locale/sk_SK
125%lang(sv) %{_datadir}/games/%{name}/locale/sv_SE
bb198b26 126%{_desktopdir}/%{name}.desktop
127%{_pixmapsdir}/%{name}.png
This page took 0.338805 seconds and 4 git commands to generate.