]> git.pld-linux.org Git - packages/widelands.git/blame - widelands.spec
- fix build with gcc-4.5
[packages/widelands.git] / widelands.spec
CommitLineData
7764f64d 1#
2# TODO:
11907a39 3# - create bcond for ggz
7764f64d 4#
509c89d9 5%define buildver 15
325beb53 6Summary: Game like Settlers II
bf6aa356 7Summary(pl.UTF-8): Remake gry Settlers II
325beb53 8Name: widelands
48449069 9Version: 0.build%{buildver}
509c89d9 10Release: 1
11907a39 11License: GPL v2+
325beb53 12Group: X11/Applications/Games
509c89d9 13Source0: http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
14# Source0-md5: 5b2e2d0913272f66055e424f91360b1d
325beb53 15Source1: %{name}.desktop
509c89d9 16Patch0: %{name}-locale.patch
98664f7f 17Patch1: %{name}-gcc-4.5.patch
325beb53 18URL: http://widelands.sourceforge.net/
eaf6bd51 19BuildRequires: OpenGL-GLU-devel
20BuildRequires: OpenGL-devel
7764f64d 21BuildRequires: SDL-devel >= 1.2.11
68f512a6 22BuildRequires: SDL_gfx-devel
325beb53 23BuildRequires: SDL_image-devel
00129253 24BuildRequires: SDL_mixer-devel >= 1.2.7
325beb53 25BuildRequires: SDL_net-devel
7764f64d 26BuildRequires: SDL_ttf-devel >= 2.0.0
48449069 27BuildRequires: boost-devel >= 1.35
509c89d9 28BuildRequires: cmake
eaf6bd51 29BuildRequires: gettext-devel
509c89d9 30BuildRequires: libjpeg-devel
929f8735 31BuildRequires: libpng-devel
325beb53 32BuildRequires: libstdc++-devel
509c89d9 33BuildRequires: libtiff-devel
48449069 34Requires: SDL_image >= 1.2.10
325beb53
AG
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38In Widelands, you are the regent of a small tribe. You start out with
39nothing but your headquarters, a kind of castle in which all your
40resources are stored. Every member of your tribe will do his or her
41part to produce more resources - wood, food, iron, gold and more - to
42further this growth. But you are not alone in the world, and you will
43meet other tribes sooner or later. Some of them may be friendly and
44trade with you. However, if you want to rule the world, you will have
45to train soldiers and fight.
46
d71c4d09
JR
47%description -l pl.UTF-8
48W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
49grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
50przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
51wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
52żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
53nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
54spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
55nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
56światem, będziesz musiał wyszkolić żołnierzy i walczyć.
325beb53
AG
57
58%prep
509c89d9 59%setup -q -n %{name}-build%{buildver}-src
60%patch0 -p1
98664f7f 61%patch1 -p1
325beb53
AG
62
63%build
509c89d9 64install -d build
65cd build
66%cmake \
67 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
68 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
69 -DWL_INSTALL_BINDIR=%{_bindir} \
70 -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
71 -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
72%if "%{_lib}" == "lib64"
73 -DLIB_SUFFIX=64 \
74%endif
75 ..
76
77%{__make}
325beb53
AG
78
79%install
80rm -rf $RPM_BUILD_ROOT
325beb53 81
509c89d9 82%{__make} -C build install \
83 DESTDIR=$RPM_BUILD_ROOT
bb198b26 84
85install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
325beb53 86
bb198b26 87install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
88cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
325beb53
AG
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(644,root,root,755)
48449069 95%doc ChangeLog CREDITS
bb198b26 96%attr(755,root,root) %{_bindir}/%{name}
48449069 97%dir %{_datadir}/games/%{name}
98%{_datadir}/games/%{name}/VERSION
99%{_datadir}/games/%{name}/campaigns
100%{_datadir}/games/%{name}/fonts
101%{_datadir}/games/%{name}/global
102%{_datadir}/games/%{name}/maps
103%{_datadir}/games/%{name}/music
104%{_datadir}/games/%{name}/pics
105%{_datadir}/games/%{name}/sound
106%{_datadir}/games/%{name}/tribes
107%{_datadir}/games/%{name}/txts
108%{_datadir}/games/%{name}/worlds
109%dir %{_datadir}/games/%{name}/locale
509c89d9 110%lang(ar) %{_datadir}/games/%{name}/locale/ar
111%lang(ca) %{_datadir}/games/%{name}/locale/ca
112%lang(cs) %{_datadir}/games/%{name}/locale/cs
113%lang(da) %{_datadir}/games/%{name}/locale/da
114%lang(de) %{_datadir}/games/%{name}/locale/de
115%lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
116%lang(eo) %{_datadir}/games/%{name}/locale/eo
117%lang(es) %{_datadir}/games/%{name}/locale/es
118%lang(eu) %{_datadir}/games/%{name}/locale/eu
119%lang(fi) %{_datadir}/games/%{name}/locale/fi
120%lang(fr) %{_datadir}/games/%{name}/locale/fr
121%lang(gl) %{_datadir}/games/%{name}/locale/gl
122%lang(he) %{_datadir}/games/%{name}/locale/he
123%lang(hu) %{_datadir}/games/%{name}/locale/hu
124%lang(ia) %{_datadir}/games/%{name}/locale/ia
125%lang(id) %{_datadir}/games/%{name}/locale/id
126%lang(it) %{_datadir}/games/%{name}/locale/it
127%lang(ja) %{_datadir}/games/%{name}/locale/ja
128%lang(la) %{_datadir}/games/%{name}/locale/la
129%lang(nl) %{_datadir}/games/%{name}/locale/nl
130%lang(nn) %{_datadir}/games/%{name}/locale/nn
131%lang(pl) %{_datadir}/games/%{name}/locale/pl
132%lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
133%lang(ru) %{_datadir}/games/%{name}/locale/ru
134%lang(si) %{_datadir}/games/%{name}/locale/si
135%lang(sk) %{_datadir}/games/%{name}/locale/sk
136%lang(sl) %{_datadir}/games/%{name}/locale/sl
137%lang(sr) %{_datadir}/games/%{name}/locale/sr
138%lang(sv) %{_datadir}/games/%{name}/locale/sv
bb198b26 139%{_desktopdir}/%{name}.desktop
140%{_pixmapsdir}/%{name}.png
This page took 0.116894 seconds and 4 git commands to generate.