]> git.pld-linux.org Git - packages/whois.git/commitdiff
- enhanced mkpwdhash patch to cover also bash completion; package bash completions auto/th/whois-5.5.18-2
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 5 Oct 2023 19:52:12 +0000 (21:52 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 5 Oct 2023 19:52:12 +0000 (21:52 +0200)
- updated pl.po-update patch
- release 2

whois-mkpwdhash.patch
whois-pl.po-update.patch
whois.spec

index 8322af66cb00a204d27bf723d7aee7b659b2fcb7..2999ce3bedb418108f2804a99ab99935827c156b 100644 (file)
@@ -1,7 +1,6 @@
-diff -ur whois-5.3.0.orig/Makefile whois-5.3.0/Makefile
---- whois-5.3.0.orig/Makefile  2018-01-21 00:23:45.000000000 +0000
-+++ whois-5.3.0/Makefile       2018-04-16 16:50:58.932233643 +0000
-@@ -127,8 +127,8 @@
+--- whois-5.5.18/Makefile.orig 2023-07-22 17:56:56.000000000 +0200
++++ whois-5.5.18/Makefile      2023-10-05 21:31:00.451699851 +0200
+@@ -137,15 +137,15 @@ install-whois: whois
  install-mkpasswd: mkpasswd
        $(INSTALL) -d $(BASEDIR)$(prefix)/bin/
        $(INSTALL) -d $(BASEDIR)$(prefix)/share/man/man1/
@@ -12,6 +11,14 @@ diff -ur whois-5.3.0.orig/Makefile whois-5.3.0/Makefile
  
  install-pos:
        cd po && $(MAKE) install
+ install-bashcomp:
+       $(INSTALL) -d $(BASEDIR)$(BASHCOMPDIR)
+-      $(INSTALL) -m 0644 mkpasswd.bash $(BASEDIR)$(BASHCOMPDIR)/mkpasswd
++      $(INSTALL) -m 0644 mkpasswd.bash $(BASEDIR)$(BASHCOMPDIR)/mkpwdhash
+       $(INSTALL) -m 0644 whois.bash $(BASEDIR)$(BASHCOMPDIR)/whois
+ distclean: clean
 diff -ur whois-5.3.0.orig/mkpasswd.1 whois-5.3.0/mkpasswd.1
 --- whois-5.3.0.orig/mkpasswd.1        2013-03-30 01:31:39.000000000 +0000
 +++ whois-5.3.0/mkpasswd.1     2018-04-16 16:51:17.853233430 +0000
@@ -41,3 +48,17 @@ diff -ur whois-5.3.0.orig/mkpasswd.1 whois-5.3.0/mkpasswd.1
  .RI < md@linux.it >
  and are licensed under the terms of the GNU General Public License,
 
+--- whois-5.5.18/mkpasswd.bash.orig    2023-02-28 01:11:47.000000000 +0100
++++ whois-5.5.18/mkpasswd.bash 2023-10-05 21:30:19.288589517 +0200
+@@ -1,4 +1,4 @@
+-_mkpasswd() {
++_mkpwdhash() {
+       case $3 in
+       --help | --version | --salt | --rounds | --password-fd | -[hVSRP])
+@@ -30,4 +30,4 @@ _mkpasswd() {
+               return 0
+       fi
+-} && complete -F _mkpasswd mkpasswd
++} && complete -F _mkpwdhash mkpwdhash
index b04d91e81b0bf5ed29fa61c5a99af638d5f5ff5f..d9da35bb5d1e95d9a541be9d88e2e181f2a6a41a 100644 (file)
---- whois-5.4.0/po/pl.po.orig  2018-11-30 19:33:40.581987436 +0100
-+++ whois-5.4.0/po/pl.po       2018-11-30 21:01:24.761927327 +0100
-@@ -7,7 +7,7 @@
+--- whois-5.5.18/po/pl.po.orig 2023-10-05 21:33:46.034136147 +0200
++++ whois-5.5.18/po/pl.po      2023-10-05 21:33:50.570778236 +0200
+@@ -1,14 +1,14 @@
+ # Polish translation for whois.
+ # Michał 'CeFeK' Nazarewicz <cefek@career.pl>, 1999
+ # Przemysław Knycz <djrzulf@pld.org.pl>, 2003
+-# Jakub Bogusz <qboosh@pld-linux.org>, 2003-2019
++# Jakub Bogusz <qboosh@pld-linux.org>, 2003-2023
+ #
+ msgid ""
  msgstr ""
- "Project-Id-Version: whois 5.0.24\n"
+-"Project-Id-Version: whois 5.5.1\n"
++"Project-Id-Version: whois 5.5.18\n"
  "Report-Msgid-Bugs-To: \n"
--"POT-Creation-Date: 2013-04-10 04:23+0200\n"
-+"POT-Creation-Date: 2018-11-30 20:58+0100\n"
- "PO-Revision-Date: 2013-04-11 17:48+0200\n"
+ "POT-Creation-Date: 2022-01-03 17:52+0100\n"
+-"PO-Revision-Date: 2019-08-28 18:02+0200\n"
++"PO-Revision-Date: 2023-10-05 21:30+0200\n"
  "Last-Translator: Jakub Bogusz <qboosh@pld-linux.org>\n"
  "Language-Team: Polish <translation-team-pl@lists.sourceforge.net>\n"
-@@ -15,10 +15,9 @@
- "MIME-Version: 1.0\n"
- "Content-Type: text/plain; charset=iso-8859-2\n"
- "Content-Transfer-Encoding: 8bit\n"
--"Plural-Forms: nplurals=3; plural=n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 "
--"|| n%100>=20) ? 1 : 2;\n"
-+"Plural-Forms: nplurals=3; plural=n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
--#: ../whois.c:148
-+#: ../whois.c:233
- #, c-format
- msgid ""
- "Version %s.\n"
-@@ -29,29 +28,28 @@
- "\n"
- "B³êdy proszê zg³aszaæ na adres %s.\n"
--#: ../whois.c:202 ../whois.c:255 ../whois.c:261 ../whois.c:291
-+#: ../whois.c:287 ../whois.c:340 ../whois.c:347 ../whois.c:390
- #, c-format
- msgid "Using server %s.\n"
- msgstr "U¿ycie serwera %s.\n"
--#: ../whois.c:240
-+#: ../whois.c:325
- msgid "This TLD has no whois server, but you can access the whois database at"
--msgstr ""
--"Ta g³ówna domena nie ma serwera whois, ale mo¿na u¿yæ bazy danych whois pod"
-+msgstr "Ta g³ówna domena nie ma serwera whois, ale mo¿na u¿yæ bazy danych whois pod"
--#: ../whois.c:245
-+#: ../whois.c:330
- msgid "This TLD has no whois server."
- msgstr "Ta g³ówna domena nie ma serwera whois."
--#: ../whois.c:248
-+#: ../whois.c:333
- msgid "No whois server is known for this kind of object."
- msgstr "Dla tego rodzaju obiektu nie jest znany ¿aden serwer whois."
--#: ../whois.c:251
-+#: ../whois.c:336
- msgid "Unknown AS number or IP network. Please upgrade this program."
- msgstr "Nieznany numer AS lub sieæ IP. Proszê uaktualniæ ten program."
--#: ../whois.c:267
-+#: ../whois.c:354
- #, c-format
- msgid ""
- "\n"
-@@ -62,7 +60,7 @@
- "Pytanie o zakoñczenie IPv4 %s adresu IPv6 typu 6to4.\n"
- "\n"
+ "Language: pl\n"
+@@ -149,7 +149,7 @@ msgstr ""
+ "-H                     ukrycie oświadczeń prawnych\n"
  
--#: ../whois.c:273
-+#: ../whois.c:361
- #, c-format
+ #: ../whois.c:1506
+-#, fuzzy, c-format
++#, c-format
  msgid ""
+ "      --verbose        explain what is being done\n"
+ "      --no-recursion   disable recursion from registry to registrar servers\n"
+@@ -158,6 +158,7 @@ msgid ""
  "\n"
-@@ -73,7 +71,7 @@
- "Pytanie o zakoñczenie IPv4 %s adresu IPv6 Teredo.\n"
- "\n"
--#: ../whois.c:292
-+#: ../whois.c:391
- #, c-format
- msgid ""
- "Query string: \"%s\"\n"
-@@ -82,7 +80,7 @@
- "Zapytanie: \"%s\"\n"
- "\n"
--#: ../whois.c:302
-+#: ../whois.c:401
- #, c-format
- msgid ""
- "\n"
-@@ -95,16 +93,16 @@
- "Znaleziono odniesienie do %s.\n"
- "\n"
--#: ../whois.c:344 ../whois.c:347
-+#: ../whois.c:443 ../whois.c:446
- #, c-format
- msgid "Cannot parse this line: %s"
- msgstr "Nie mo¿na przeanalizowaæ tej linii: %s"
--#: ../whois.c:516
-+#: ../whois.c:635
- msgid "Warning: RIPE flags used with a traditional server."
- msgstr "Uwaga: u¿yto flag RIPE ze starszym serwerem."
--#: ../whois.c:675 ../whois.c:773
-+#: ../whois.c:805 ../whois.c:921
- msgid ""
- "Catastrophic error: disclaimer text has been changed.\n"
- "Please upgrade this program.\n"
-@@ -112,26 +110,26 @@
- "Katastrofa! Tekst o¶wiadczenia zosta³ zmieniony.\n"
- "Proszê uaktualniæ ten program.\n"
--#: ../whois.c:828
-+#: ../whois.c:985
- #, c-format
- msgid "Host %s not found."
- msgstr "Serwer %s nie zosta³ znaleziony."
--#: ../whois.c:838
-+#: ../whois.c:995
- #, c-format
- msgid "%s/tcp: unknown service"
- msgstr "%s/tcp: us³uga nieznana"
--#: ../whois.c:913
-+#: ../whois.c:1070
- msgid "Timeout."
- msgstr "Up³yn±³ limit czasu."
--#: ../whois.c:919
-+#: ../whois.c:1076
- #, c-format
- msgid "Interrupted by signal %d..."
- msgstr "Przerwano sygna³em %d..."
--#: ../whois.c:1189
-+#: ../whois.c:1444
- #, c-format
- msgid ""
- "Usage: whois [OPTION]... OBJECT...\n"
-@@ -148,8 +146,7 @@
- "-L                     find all levels less specific matches\n"
- "-m                     find all one level more specific matches\n"
- "-M                     find all levels of more specific matches\n"
--"-c                     find the smallest match containing a mnt-irt "
--"attribute\n"
-+"-c                     find the smallest match containing a mnt-irt attribute\n"
- "-x                     exact match\n"
- "-b                     return brief IP address ranges with abuse contact\n"
- "-B                     turn off object filtering (show email addresses)\n"
-@@ -201,27 +198,31 @@
- "-v TYP                 ¿±danie szczegó³owego szablonu dla obiektu podanego TYPU\n"
- "-q [version|sources|types]  zapytanie serwera o podane informacje\n"
--#: ../mkpasswd.c:84
-+#: ../mkpasswd.c:125
-+msgid "BSDI extended DES-based crypt(3)"
-+msgstr "oparta o DES rozszerzona funkcja crypt(3) BSDI"
-+
-+#: ../mkpasswd.c:128
- msgid "standard 56 bit DES-based crypt(3)"
- msgstr "standardowa 56-bitowa, oparta o DES funkcja crypt(3)"
--#: ../mkpasswd.c:165
-+#: ../mkpasswd.c:204
- #, c-format
- msgid "Invalid method '%s'.\n"
- msgstr "Nieprawid³owa metoda '%s'.\n"
--#: ../mkpasswd.c:174 ../mkpasswd.c:184
-+#: ../mkpasswd.c:213 ../mkpasswd.c:225
- #, c-format
- msgid "Invalid number '%s'.\n"
- msgstr "Nieprawid³owa liczba '%s'.\n"
--#: ../mkpasswd.c:201
-+#: ../mkpasswd.c:243
- #, c-format
- msgid "Try '%s --help' for more information.\n"
- msgstr "'%s --help' poda wiêcej informacji.\n"
- # : ../mkpasswd.c:152
--#: ../mkpasswd.c:242
-+#: ../mkpasswd.c:287
- #, c-format
- msgid "Wrong salt length: %d byte when %d expected.\n"
- msgid_plural "Wrong salt length: %d bytes when %d expected.\n"
-@@ -230,7 +231,7 @@
- msgstr[2] "B³êdna d³ugo¶æ zarodka: %d bajtów kiedy oczekiwano %d.\n"
- # : ../mkpasswd.c:152
--#: ../mkpasswd.c:247
-+#: ../mkpasswd.c:292
- #, c-format
- msgid "Wrong salt length: %d byte when %d <= n <= %d expected.\n"
- msgid_plural "Wrong salt length: %d bytes when %d <= n <= %d expected.\n"
-@@ -238,22 +239,22 @@
- msgstr[1] "B³êdna d³ugo¶æ zarodka: %d bajty kiedy oczekiwano %d <= n <= %d.\n"
- msgstr[2] "B³êdna d³ugo¶æ zarodka: %d bajtów kiedy oczekiwano %d <= n <= %d.\n"
--#: ../mkpasswd.c:256
-+#: ../mkpasswd.c:301
- #, c-format
- msgid "Illegal salt character '%c'.\n"
- msgstr "B³êdny znak zarodka '%c'.\n"
--#: ../mkpasswd.c:306 ../mkpasswd.c:322
-+#: ../mkpasswd.c:352 ../mkpasswd.c:365
- #, c-format
- msgid "Password: "
- msgstr "Has³o: "
--#: ../mkpasswd.c:340
-+#: ../mkpasswd.c:384
- #, c-format
- msgid "Method not supported by crypt(3).\n"
- msgstr "Metoda nie obs³ugiwana przez crypt(3).\n"
--#: ../mkpasswd.c:419
-+#: ../mkpasswd.c:492
- #, c-format
- msgid ""
- "Usage: mkpasswd [OPTIONS]... [PASSWORD [SALT]]\n"
-@@ -264,7 +265,7 @@
- "Koduje HAS£O przy u¿yciu funkcji crypt(3).\n"
- "\n"
--#: ../mkpasswd.c:422
-+#: ../mkpasswd.c:495
- #, c-format
- msgid ""
- "      -m, --method=TYPE     select method TYPE\n"
-@@ -291,8 +292,7 @@
- "                            z /dev/tty\n"
- "      -s, --stdin           to samo co --password-fd=0\n"
- "      -h, --help            wy¶wietlenie tego opisu i zakoñczenie dzia³ania\n"
--"      -V, --version         wy¶wietlenie informacji o wersji i zakoñczenie "
--"dzia³ania\n"
-+"      -V, --version         wy¶wietlenie informacji o wersji i zakoñczenie dzia³ania\n"
- "\n"
- "Je¶li nie podano HAS£A, pobierane jest interaktywnie.\n"
- "Je¶li nie podano ZARODKA, generowany jest losowy.\n"
-@@ -300,7 +300,7 @@
- "\n"
- "B³êdy proszê zg³aszaæ na adres %s.\n"
--#: ../mkpasswd.c:452
-+#: ../mkpasswd.c:525
- #, c-format
- msgid "Available methods:\n"
- msgstr "Dostêpne metody:\n"
+ msgstr ""
+ "      --verbose        wyjaśnianie, co się dzieje\n"
++"      --no-recursion   wyłączenie rekurencji z serwerów rejestru do rejestratorów\n"
+ "      --help           wyświetlenie tego opisu i zakończenie działania\n"
+ "      --version        wyświetlenie informacji o wersji i zakończenie "
+ "działania\n"
index f07d412186ccb3cb638f58d3e653b76d765c1949..a3646311509a6db690093250bb223382ec76bc94 100644 (file)
@@ -4,7 +4,7 @@ Summary(ru.UTF-8):      Улучшенный клиент WHOIS
 Summary(uk.UTF-8):     Покращений клієнт WHOIS
 Name:          whois
 Version:       5.5.18
-Release:       1
+Release:       2
 License:       GPL v1+
 Group:         Networking/Utilities
 Source0:       http://ftp.debian.org/debian/pool/main/w/whois/%{name}_%{version}.tar.xz
@@ -52,7 +52,7 @@ większosci zapytań.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-#%patch3 -p1
+%patch3 -p1
 
 # Makefile vs po/Makefile mismatch
 echo 'install-pos: install' >> po/Makefile
@@ -68,6 +68,7 @@ echo 'install-pos: install' >> po/Makefile
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_mandir}/man1}
+
 %{__make} install install-pos \
        BASEDIR=$RPM_BUILD_ROOT \
        prefix=%{_prefix}
@@ -85,6 +86,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/mkpwdhash
 %attr(755,root,root) %{_bindir}/whois
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/whois.conf
+%{bash_compdir}/mkpwdhash
+%{bash_compdir}/whois
 %{_mandir}/man1/mkpwdhash.1*
 %{_mandir}/man1/whois.1*
 %{_mandir}/man5/whois.conf.5*
This page took 0.124202 seconds and 4 git commands to generate.