]> git.pld-linux.org Git - packages/wget.git/commitdiff
xdg patch: Ignore 'Operation not permitted' when writing to /dev/null auto/th/wget-1.16.3-4
authorElan Ruusamäe <glen@delfi.ee>
Tue, 30 Jun 2015 12:11:28 +0000 (15:11 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 30 Jun 2015 12:11:28 +0000 (15:11 +0300)
14:54:38 grawity> I think I ended up just ignoring all errors from it
14:54:57 grawity> since xattrs are also not available on /tmp and other tmpfsen

user.xdg.origin.url.patch
wget.spec

index 4d1296afa61e1e2e8396bcd61c7dee44f8de7765..18020c4b8b7212c83a82a8d9d7fbe0cb116c4c52 100644 (file)
@@ -91,3 +91,23 @@ index b1c46c1..72234e9 100644
 2.3.3
 
 
+commit 8a15b84d4be480514c650db1a34cbb2122d6590d
+Author: Mantas Mikulėnas <grawity@gmail.com>
+Date:   Tue Jun 30 14:56:59 2015 +0300
+
+    Ignore 'Operation not permitted' when writing to /dev/null
+
+diff --git a/src/url.c b/src/url.c
+index 30cb86f..cff8683 100644
+--- a/src/url.c
++++ b/src/url.c
+@@ -2242,7 +2242,7 @@ set_xa (const struct url *origin, int fd)
+   res = fsetxattr(fd, XA_ORIGIN, url, strlen(url), 0);
+   if (res != 0)
+     {
+-      if (errno == ENOTSUP)
++      if (errno == ENOTSUP || errno == EPERM)
+         res = 0;
+       else
+         logprintf (LOG_NOTQUIET, "fsetxattr: %s\n", strerror (errno));
+
index 48b44a41ec41b6789476e1a74327bb2ccd704f43..26e289171a839e915f325b77f1cd257ddc4ae7a9 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -7,7 +7,7 @@
 # Conditional build:
 %bcond_without tests
 %bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
-#
+
 Summary:       A utility for retrieving files using the HTTP or FTP protocols
 Summary(es.UTF-8):     Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
 Summary(fr.UTF-8):     Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
@@ -18,7 +18,7 @@ Summary(uk.UTF-8):    Утиліта для отримання файлів по п
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
 Version:       1.16.3
-Release:       3
+Release:       4
 License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
 Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
This page took 0.066773 seconds and 4 git commands to generate.