]> git.pld-linux.org Git - packages/wget.git/commitdiff
- up to 1.12 auto/aidath/wget-1_12-1 auto/th/wget-1_12-1 auto/ti/wget-1_12-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 23 Sep 2009 08:36:55 +0000 (08:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    wget-ac.patch -> 1.15
    wget-home_etc.patch -> 1.2
    wget-noabort.patch -> 1.3
    wget-ssl-certs.patch -> 1.3
    wget-wgetrc_path.patch -> 1.3
    wget.spec -> 1.147

wget-ac.patch [deleted file]
wget-home_etc.patch
wget-noabort.patch [deleted file]
wget-ssl-certs.patch
wget-wgetrc_path.patch
wget.spec

diff --git a/wget-ac.patch b/wget-ac.patch
deleted file mode 100644 (file)
index 41d639d..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
---- wget-1.10.1/configure.in.orig      2005-08-11 23:35:27.000000000 +0200
-+++ wget-1.10.1/configure.in   2005-08-28 13:42:34.625493608 +0200
-@@ -437,6 +437,7 @@
- ALL_LINGUAS=`(cd ${srcdir}/po && ls *.po | sed -e 's/\.po$//' | tr '\012' ' ')`
- dnl internationalization macros
-+AM_GNU_GETTEXT
- WGET_WITH_NLS
- dnl
-@@ -473,5 +474,4 @@
- #include "config-post.h"
- ])
- AC_CONFIG_FILES([stamp-h], [echo timestamp > stamp-h])
--AC_CONFIG_COMMANDS([default], [WGET_PROCESS_PO])
- AC_OUTPUT
-diff -urN wget-1.9-b5.org/Makefile.in wget-1.9-b5/Makefile.in
---- wget-1.9-b5.org/Makefile.in        2003-10-12 23:55:54.000000000 +0200
-+++ wget-1.9-b5/Makefile.in    2003-10-13 00:29:14.000000000 +0200
-@@ -82,7 +82,7 @@
- manext='$(manext)'
- # subdirectories in the distribution
--SUBDIRS = src doc po tests util windows
-+SUBDIRS = src doc intl po tests util windows
- # default target
- all: libtool src/config.h Makefile $(SUBDIRS)
-@@ -106,7 +106,7 @@
- # Install `.mo' files
- install.mo:
--      cd po && $(MAKE) $(MAKEDEFS) $@
-+      cd po && $(MAKE) $(MAKEDEFS) install
- # create tag files for Emacs
- TAGS:
---- wget-1.10/src/main.c.orig  2005-06-22 03:25:18.000000000 +0200
-+++ wget-1.10/src/main.c       2005-06-22 03:25:48.000000000 +0200
-@@ -43,7 +43,7 @@
- #endif /* HAVE_UNISTD_H */
- #include <string.h>
- #include <signal.h>
--#ifdef HAVE_NLS
-+#ifdef ENABLE_NLS
- # include <locale.h>
- #endif
- #include <assert.h>
-@@ -90,13 +90,13 @@
- static void
- i18n_initialize (void)
- {
--  /* HAVE_NLS implies existence of functions invoked here.  */
--#ifdef HAVE_NLS
-+  /* ENABLE_NLS implies existence of functions invoked here.  */
-+#ifdef ENABLE_NLS
-   /* Set the current locale.  */
-   setlocale (LC_ALL, "");
-   /* Set the text message domain.  */
-   bindtextdomain ("wget", LOCALEDIR);
-   textdomain ("wget");
--#endif /* HAVE_NLS */
-+#endif /* ENABLE_NLS */
- }
\f
- /* Definition of command-line options. */
---- wget-1.10/src/wget.h.orig  2005-06-22 03:26:51.000000000 +0200
-+++ wget-1.10/src/wget.h       2005-06-22 03:27:04.000000000 +0200
-@@ -50,20 +50,20 @@
- /* `gettext (FOO)' is long to write, so we use `_(FOO)'.  If NLS is
-    unavailable, _(STRING) simply returns STRING.  */
--#ifdef HAVE_NLS
-+#ifdef ENABLE_NLS
- # define _(string) gettext (string)
- # ifdef HAVE_LIBINTL_H
- #  include <libintl.h>
- # else  /* not HAVE_LIBINTL_H */
-    const char *gettext ();
- # endif /* not HAVE_LIBINTL_H */
--#else  /* not HAVE_NLS */
-+#else  /* not ENABLE_NLS */
- # define _(string) (string)
- # define ngettext(sing, plur, num)  ((num) == 1 ? (sing) : (plur))
- # undef HAVE_WCHAR_H
- # undef HAVE_WCWIDTH
- # undef HAVE_MBTOWC
--#endif /* not HAVE_NLS */
-+#endif /* not ENABLE_NLS */
-
- #if HAVE_WCWIDTH && HAVE_MBTOWC
- # define USE_NLS_PROGRESS_BAR 1
index 1e85159d160005243a6701198e0bc222a3fb0bb3..9e459034d60c8464edd459e85949df4f1e2f4c0d 100644 (file)
@@ -1,13 +1,12 @@
 diff -Nru wget-1.8.2.orig/src/init.c wget-1.8.2/src/init.c
 --- wget-1.8.2.orig/src/init.c Sat Mar  1 12:06:06 2003
 +++ wget-1.8.2/src/init.c      Mon Nov  3 10:31:43 2003
-@@ -325,6 +325,9 @@
+@@ -354,6 +354,7 @@
+   static char buf[PATH_MAX];
+   static char *home;
  
- #ifndef WINDOWS
-   /* If that failed, try $HOME/.wgetrc.  */
-+      home = getenv("HOME_ETC");
-+      home = home ? xstrdup(home) : NULL;
-+      if (!home)
-   home = home_dir ();
-   if (home)
++  home = getenv("HOME_ETC");
+   if (!home)
      {
+       home = getenv ("HOME");
+
diff --git a/wget-noabort.patch b/wget-noabort.patch
deleted file mode 100644 (file)
index ee0b127..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-err was uninitialized here (FTPOK in most cases), causing later
-confusion in ftp_loop_internal() and abort()
---- wget-1.10.2/src/ftp.c.orig 2005-08-09 00:23:09.000000000 +0200
-+++ wget-1.10.2/src/ftp.c      2005-11-17 00:29:22.510795976 +0100
-@@ -908,7 +908,7 @@
-       if (dtsock < 0)
-         {
-           logprintf (LOG_NOTQUIET, "accept: %s\n", strerror (errno));
--          return err;
-+          return CONERROR;
-         }
-     }
index 15c7557a16e389d2154cca5d368e88344082daa8..d3d3e2d2ebdc8f6ba0d7bbfc20c786a28b96f2ea 100644 (file)
@@ -1,9 +1,9 @@
 --- wget-1.11.4/doc/sample.wgetrc~     2008-11-03 18:47:16.000000000 +0200
 +++ wget-1.11.4/doc/sample.wgetrc      2008-11-03 18:51:32.512671690 +0200
 @@ -110,3 +110,8 @@
- # To have Wget follow FTP links from HTML files by default, set this
- # to on:
- #follow_ftp = off
+ # Force the default remote server encoding
+ #remoteencoding = UTF-8
 +
 +# file with the bundle of CA's.
 +ca_certificate = /etc/certs/ca-certificates.crt
index 2550499beaa1415cc1c1871d31bc0ce8467fff84..a325cb1f9417e98a61a7c589a2179f3400642e1b 100644 (file)
@@ -28,7 +28,7 @@ diff -Nur wget-1.10/doc.orig/sample.wgetrc wget-1.10/doc/sample.wgetrc
 @@ -7,7 +7,7 @@
  ## not contain a comprehensive list of commands -- look at the manual
  ## to find out what you can put into this file.
- ## 
+ ##
 -## Wget initialization file can reside in /usr/local/etc/wgetrc
 +## Wget initialization file can reside in /etc/wgetrc
  ## (global, for all users) or $HOME/.wgetrc (for a single user).
index 93fc549d11e9e9127cd4f312cafd4bd066470b9b..27b671a9d00ab6861c89ddfde99142a3ff790e43 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -12,19 +12,17 @@ Summary(ru.UTF-8):  Утилита для получения файлов по п
 Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
-Version:       1.11.4
-Release:       2
+Version:       1.12
+Release:       1
 License:       GPL v3+
 Group:         Networking/Utilities
 Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.bz2
-# Source0-md5: f5076a8c2ec2b7f334cb6e3059820f9c
+# Source0-md5: 308a5476fc096a8a525d07279a6f6aa3
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-ac.patch
 Patch2:                %{name}-wgetrc_path.patch
 Patch3:                %{name}-home_etc.patch
-Patch4:                %{name}-noabort.patch
 Patch5:                wget-ssl-certs.patch
 URL:           http://www.gnu.org/software/wget/
 BuildRequires: autoconf >= 2.59
@@ -112,10 +110,8 @@ Proxy серверів, настроюваність.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 rm -f doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion
 
This page took 0.076381 seconds and 4 git commands to generate.