]> git.pld-linux.org Git - packages/wget.git/blob - wget.spec
- s-/usr/share-%{_datadir}-
[packages/wget.git] / wget.spec
1 Summary:        Command-line HTTP and FTP client
2 Summary(pl):    Wsadowy klient HTTP/FTP 
3 Name:           wget
4 Version:        1.5.3
5 Release:        7
6 Copyright:      GPL
7 Group:          Networking/Utilities
8 Group(pl):      Sieciowe/Narzêdzia
9 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
10 Patch0:         wget-man.patch
11 Patch1:         wget-pl.po.patch
12 Patch2:         wget-info.patch
13 BuildPrereq:    autoconf >= 2.13-8
14 Prereq:         /sbin/install-info
15 URL:            http://sunsite.auc.dk/ftp/pub/infosystems/wget/
16 BuildRoot:      /tmp/%{name}-%{version}-root
17
18 %description
19 wget is a command-line program to fetch files via HTTP or FTP.  It
20 supports recursive retrieval and mirroring options, and it automatically
21 retries several times before giving up, so it is well-suited to running
22 from cron jobs.
23
24 %description -l pl
25 Wget jest klientem FTP/HTTP przeznaczonym do ¶ci±gania zasobów wsadowo. 
26 Umo¿liwia ¶ci±ganie zasobów z podkatalogami, a tak¿e ma opcje umo¿liwiaj±ce 
27 wykonanie lokalnej kopii zasobów (mirror). W razie niemo¿no¶ci dostania siê 
28 do zasobów lub gdy po³±czenie z serwerem FTP/HTTP zostanie zerwane, mo¿e 
29 automatycznie ponawiaæ próby kopiowania. Jest tak¿e dobrze przystosowany do 
30 tego, ¿eby uruchamiaæ go jako zadanie z cron'a.
31
32 %prep
33 %setup -q
34 %patch0 -p1
35 %patch1 -p1
36 %patch2 -p1
37
38 %build
39 autoconf
40 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
41 ./configure %{_target} \
42         --prefix=/usr \
43         --sysconfdir=/etc
44 make
45 tail -6 util/README >rmold.README
46
47 (cd doc; makeinfo --force wget.texi; touch *)
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 make prefix=$RPM_BUILD_ROOT/usr sysconfdir=$RPM_BUILD_ROOT/etc install
53 install -c util/rmold.pl $RPM_BUILD_ROOT/usr/bin/rmold
54
55 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/{info/wget.info*,man/man1/*} \
56     AUTHORS ChangeLog NEWS TODO README MAILING-LIST rmold.README
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 /sbin/install-info %{_infodir}/wget.info.gz /etc/info-dir
63
64 %postun
65 if [ "$1" = "0" ]; then
66         /sbin/install-info --delete %{_infodir}/wget.info.gz /etc/info-dir
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc {AUTHORS,ChangeLog,MAILING-LIST,NEWS,TODO,README,rmold.README}.gz
72
73 %attr(755,root,root) /usr/bin/*
74
75 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/wget.mo
76 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/wget.mo
77 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/wget.mo
78 %lang(it) %{_datadir}/locale/it/LC_MESSAGES/wget.mo
79 %lang(no) %{_datadir}/locale/no/LC_MESSAGES/wget.mo
80 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/wget.mo
81 %lang(pt) %{_datadir}/locale/pt*/LC_MESSAGES/wget.mo
82
83 %{_mandir}/man1/*
84 %{_infodir}/wget.info*
85
86 %verify(not md5 size mtime) %config(noreplace) /etc/wgetrc
87
88 %changelog
89 * Thu May 13 1999 Piotr Czerwiñski <pius@pld.org.pl>
90   [1.5.3-7]
91 - package is now FHS 2.0 compliant.
92
93 * Wed Apr 21 1999 Piotr Czerwiñski <pius@pld.org.pl>
94   [1.5.3-6]
95 - replacements in %files,
96 - recompiled on rpm 3,
97 - force making info pages (new makeinfo don't accept @xfer{} without "." or
98   "," after this markup) by Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>.
99
100 * Fri Apr  2 1999 Piotr Czerwiñski <pius@pld.org.pl>
101   [1.5.2-5]
102 - removed man group from man pages,
103 - few typos corrected,
104 - cosmetic changes for common l&f.
105
106 * Thu Feb 10 1999 Micha³ Kuratczyk <kurkens@polbox.com>
107   [1.5.2-4]
108 - added Group(pl)
109 - added gzipping documentation
110
111 * Mon Dec 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
112   [1.5.2-3]
113 - standarized {un}registering info pages (added wget-info.patch),
114 - added URL,
115 - added gzipping man pages.
116
117 * Tue Sep 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
118   [1.5.2-2]
119 - fixed pl translation.
120
121 * Mon Sep  7 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
122   [1.5.2-2]
123 - added wget-pl.po.patch patch with polish translation 
124   (Adam Kozubowicz <tapir@interdata.com.pl>,
125 - added wget-man.patch patch with wget man page.
126
127 * Sat Aug  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
128   [1.5.2-1]
129 - added pl translation.
130
131 * Sun May 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
132   [1.5.1-2]
133 - %%{version} macro instead %%{PACKAGE_VERSION},
134 - added -q %setup parameter,
135 - added using %%{name} macro in Buildroot and Source,
136 - added %verify(not md5 size mtime) and noreplace parameter for %config,
137 - removed COPYING from %doc (copyright statment is in Copyright
138   field),
139 - added %postun, %post sections with {de}instaling wget info pages,
140 - spec file rewrited for using Buildroot,
141 - added %clean section,
142 - added URL,
143 - removed Packager field from spec (if you want recompile package and
144   redistribute this package later put this in your private .rpmrc). 
145 - Buildroot changed to /tmp/wget-%%{PACKAGE_VERSION}-root,
146 - added %%{PACKAGE_VERSION} to Source url,
147 - replaced "mkdir -p" with "install -d" in %install,
148 - base datadir changed to %{_datadir},
149 - added %lang macros for %{_datadir}/locale/*/LC_MESSAGES/wget.mo files,
150 - added %defattr and %attr macros in %files (allows building package from
151   non-root account).
152
153 * Thu May  7 1998 ??? <root@ricketts.stannes.ox.ac.uk>
154   [1.5.1-1]
155 - previous release in rpm package.
This page took 0.040219 seconds and 3 git commands to generate.