]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- s/png12/png
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - use desktop file included with project (consider which one are better)
3 # - unpackaged language files
4 # - fix lacales (seems broken)
5 # Conditional build
6 %bcond_without  server  # without server
7 %bcond_without  tools   # without tools
8 %bcond_without  fribidi # without Bidirectional language support
9 #
10 Summary:        Strategy game with a fantasy theme
11 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
12 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
13 Name:           wesnoth
14 Version:        1.8
15 Release:        0.1
16 Epoch:          1
17 License:        GPL v2+
18 Group:          X11/Applications/Games/Strategy
19 Source0:        http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
20 # Source0-md5:  07e4b97512e307c54dcfd86659a61e41
21 Source1:        %{name}d.init
22 Patch0:         %{name}-libpng.patch
23 Patch1:         %{name}-desktop.patch
24 URL:            http://www.wesnoth.org/
25 BuildRequires:  SDL-devel >= 1.2.7
26 BuildRequires:  SDL_image-devel >= 1.2
27 BuildRequires:  SDL_mixer-devel >= 1.2
28 BuildRequires:  SDL_net-devel >= 1.2
29 BuildRequires:  SDL_ttf-devel >= 2.0.8
30 BuildRequires:  asciidoc
31 BuildRequires:  boost-devel >= 1.33
32 BuildRequires:  cmake >= 2.4
33 %{?with_fribidi:BuildRequires:  fribidi-devel}
34 BuildRequires:  gettext-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libvorbis-devel
38 BuildRequires:  lua51-devel
39 BuildRequires:  pango-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpmbuild(macros) >= 1.268
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  zlib-devel
44 # sr@Latn vs. sr@latin
45 Conflicts:      glibc-misc < 6:2.7
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Battle for Wesnoth is a fantasy strategy game. Battle for control of
50 villages, using variety of units which have advantages and
51 disadvantages in different types of terrains and against different
52 types of attacks. Units gain experience and advance levels, and are
53 carried over from one scenario to the next campaign.
54
55 %description -l hu.UTF-8
56 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
57 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
58 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
59 különféle terepeken és a különböző támadási stílusok ellen. Az
60 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
61 következő pályára.
62
63 %description -l pl.UTF-8
64 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
65 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
66 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
67 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
68 przenoszone z jednej scenerii do następnej kampanii.
69
70 %package server
71 Summary:        Network server for Wesnoth
72 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
73 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
74 Group:          X11/Applications/Games/Strategy
75 Requires(post,preun):   /sbin/chkconfig
76 Requires(postun):       /usr/sbin/groupdel
77 Requires(postun):       /usr/sbin/userdel
78 Requires(pre):  /usr/sbin/groupadd
79 Requires(pre):  /usr/sbin/useradd
80 Requires:       rc-scripts >= 0.4.0.17
81 # sr@Latn vs. sr@latin
82 Conflicts:      glibc-misc < 6:2.7
83
84 %description server
85 Server for playing networked games of Wesnoth.
86
87 %description server -l hu.UTF-8
88 Szerver a Wesnoth hálózati játékához.
89
90 %description server -l pl.UTF-8
91 Serwer do prowadzenia sieciowych gier Wesnoth.
92
93 %package tools
94 Summary:        Tools for Wesnoth
95 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
96 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
97 Group:          X11/Applications/Games/Strategy
98 Requires:       %{name} = %{epoch}:%{version}-%{release}
99
100 %description tools
101 Map editor and translations tools.
102
103 %description tools -l hu.UTF-8
104 Pályaszerkesztők és fordítási eszközök.
105
106 %description tools -l pl.UTF-8
107 Edytor map i narzędzia do tłumaczeń.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113
114 # don't install locales in %{_datadir}/%{name}
115 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
116
117 # link using libpng instead of libpng12
118 %{__sed} -i 's,png12,png,' src/CMakeLists.txt
119
120 %build
121 install -d build
122 cd build
123 %cmake .. \
124         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
125         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
126         -DENABLE_STRICT_COMPILATION="off" \
127         -DBINDIR="%{_bindir}" \
128         -DMANDIR="%{_mandir}" \
129         -DLOCALEDIR="%{_datadir}/locale" \
130         %{!?with_server:-DENABLE_SERVER="off"} \
131         %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
132         %{!?with_tools:-DENABLE_EDITOR="off"} \
133         %{?with_tools:-DENABLE_TOOLS="on"} \
134         %{!?with_fribidi:-DENABLE_FRIBIDI="off"} \
135 %if "%{_lib}" == "lib64"
136         -DLIB_SUFFIX=64
137 %endif
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
144
145 %{__make} -C build install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 # install additional docs
149 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
150 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
151
152 %if %{with server}
153 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
154 %endif
155
156 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
157 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
158
159 # unsupported(?)
160 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
161 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
162 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
163 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
164 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
165 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
166
167 # the same as manuals from %{_mandir}/man?
168 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
169
170 %find_lang %{name} --all-name
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %pre server
176 %groupadd -P %{name}-server -g 178  wesnothd
177 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
178
179 %post server
180 /sbin/chkconfig --add wesnothd
181 %service wesnothd restart
182
183 %preun server
184 if [ "$1" = "0" ]; then
185         %service wesnothd stop
186         /sbin/chkconfig --del wesnothd
187         %userremove wesnothd
188         %groupremove wesnothd
189 fi
190
191 %files -f %{name}.lang
192 %defattr(644,root,root,755)
193 %doc %{_docdir}/%{name}-%{version}
194 %attr(755,root,root) %{_bindir}/wesnoth
195 %{_mandir}/man6/wesnoth.6*
196 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
197 %lang(de) %{_mandir}/de/man6/wesnoth.6*
198 %lang(es) %{_mandir}/es/man6/wesnoth.6*
199 %lang(et) %{_mandir}/et/man6/wesnoth.6*
200 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
201 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
202 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
203 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
204 %lang(it) %{_mandir}/it/man6/wesnoth.6*
205 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
206 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
207 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
208 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
209 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
210 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
211 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
212 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
213 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
214 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
215 %{_datadir}/%{name}
216 %{_desktopdir}/*.desktop
217 %{_pixmapsdir}/*-icon.png
218
219 %if %{with server}
220 %files server
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/campaignd
223 %attr(755,root,root) %{_bindir}/wesnothd
224 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
225 %{_mandir}/man6/wesnothd.6*
226 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
227 %lang(de) %{_mandir}/de/man6/wesnothd.6*
228 %lang(es) %{_mandir}/es/man6/wesnothd.6*
229 %lang(et) %{_mandir}/et/man6/wesnothd.6*
230 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
231 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
232 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
233 %lang(it) %{_mandir}/it/man6/wesnothd.6*
234 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
235 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
236 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
237 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
238 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
239 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
240 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
241 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
242 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
243 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
244 %endif
245
246 %if %{with tools}
247 %files tools
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_bindir}/cutter
250 %attr(755,root,root) %{_bindir}/exploder
251 %endif
This page took 0.067023 seconds and 3 git commands to generate.