]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- BR: rpm-pythonprov
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - unpackaged language files
3 # Conditional build
4 %bcond_without  server  # without server
5 %bcond_without  tools   # without tools
6 %bcond_without  fribidi # without Bidirectional language support
7 #
8 Summary:        Strategy game with a fantasy theme
9 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
10 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
11 Name:           wesnoth
12 Version:        1.8
13 Release:        1
14 Epoch:          1
15 License:        GPL v2+
16 Group:          X11/Applications/Games/Strategy
17 Source0:        http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
18 # Source0-md5:  07e4b97512e307c54dcfd86659a61e41
19 Source1:        %{name}d.init
20 Patch0:         %{name}-libpng.patch
21 Patch1:         %{name}-desktop.patch
22 Patch2:         %{name}-locale_dir.patch
23 URL:            http://www.wesnoth.org/
24 BuildRequires:  SDL-devel >= 1.2.7
25 BuildRequires:  SDL_image-devel >= 1.2
26 BuildRequires:  SDL_mixer-devel >= 1.2
27 BuildRequires:  SDL_net-devel >= 1.2
28 BuildRequires:  SDL_ttf-devel >= 2.0.8
29 BuildRequires:  asciidoc
30 BuildRequires:  boost-devel >= 1.33
31 BuildRequires:  cmake >= 2.4
32 %{?with_fribidi:BuildRequires:  fribidi-devel}
33 BuildRequires:  gettext-devel
34 BuildRequires:  libpng-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libvorbis-devel
37 BuildRequires:  lua51-devel
38 BuildRequires:  pango-devel
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.268
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  zlib-devel
44 # sr@Latn vs. sr@latin
45 Conflicts:      glibc-misc < 6:2.7
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Battle for Wesnoth is a fantasy strategy game. Battle for control of
50 villages, using variety of units which have advantages and
51 disadvantages in different types of terrains and against different
52 types of attacks. Units gain experience and advance levels, and are
53 carried over from one scenario to the next campaign.
54
55 %description -l hu.UTF-8
56 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
57 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
58 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
59 különféle terepeken és a különböző támadási stílusok ellen. Az
60 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
61 következő pályára.
62
63 %description -l pl.UTF-8
64 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
65 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
66 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
67 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
68 przenoszone z jednej scenerii do następnej kampanii.
69
70 %package server
71 Summary:        Network server for Wesnoth
72 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
73 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
74 Group:          X11/Applications/Games/Strategy
75 Requires(post,preun):   /sbin/chkconfig
76 Requires(postun):       /usr/sbin/groupdel
77 Requires(postun):       /usr/sbin/userdel
78 Requires(pre):  /usr/sbin/groupadd
79 Requires(pre):  /usr/sbin/useradd
80 Requires:       rc-scripts >= 0.4.0.17
81 # sr@Latn vs. sr@latin
82 Conflicts:      glibc-misc < 6:2.7
83
84 %description server
85 Server for playing networked games of Wesnoth.
86
87 %description server -l hu.UTF-8
88 Szerver a Wesnoth hálózati játékához.
89
90 %description server -l pl.UTF-8
91 Serwer do prowadzenia sieciowych gier Wesnoth.
92
93 %package tools
94 Summary:        Tools for Wesnoth
95 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
96 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
97 Group:          X11/Applications/Games/Strategy
98 Requires:       %{name} = %{epoch}:%{version}-%{release}
99
100 %description tools
101 Map editor and translations tools.
102
103 %description tools -l hu.UTF-8
104 Pályaszerkesztők és fordítási eszközök.
105
106 %description tools -l pl.UTF-8
107 Edytor map i narzędzia do tłumaczeń.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114
115 # don't install locales in %{_datadir}/%{name}
116 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
117
118 # link using libpng instead of libpng12
119 %{__sed} -i 's,png12,png,' src/CMakeLists.txt
120
121 %build
122 install -d build
123 cd build
124 %cmake .. \
125         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
126         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
127         -DENABLE_STRICT_COMPILATION="off" \
128         -DBINDIR="%{_bindir}" \
129         -DMANDIR="%{_mandir}" \
130         -DLOCALEDIR="%{_datadir}/locale" \
131         %{!?with_server:-DENABLE_SERVER="off"} \
132         %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
133         %{!?with_tools:-DENABLE_EDITOR="off"} \
134         %{?with_tools:-DENABLE_TOOLS="on"} \
135         %{!?with_fribidi:-DENABLE_FRIBIDI="off"} \
136 %if "%{_lib}" == "lib64"
137         -DLIB_SUFFIX=64
138 %endif
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
145
146 %{__make} -C build install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 # install additional docs
150 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
151 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
152
153 %if %{with server}
154 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
155 %endif
156
157 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
158 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
159
160 # unsupported(?)
161 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
162 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
163 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
164 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
165 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
166 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
167 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
168
169 # the same as manuals from %{_mandir}/man?
170 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
171
172 %find_lang %{name} --all-name
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %pre server
178 %groupadd -P %{name}-server -g 178  wesnothd
179 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
180
181 %post server
182 /sbin/chkconfig --add wesnothd
183 %service wesnothd restart
184
185 %preun server
186 if [ "$1" = "0" ]; then
187         %service wesnothd stop
188         /sbin/chkconfig --del wesnothd
189         %userremove wesnothd
190         %groupremove wesnothd
191 fi
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc %{_docdir}/%{name}-%{version}
196 %attr(755,root,root) %{_bindir}/wesnoth
197 %{_mandir}/man6/wesnoth.6*
198 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
199 %lang(de) %{_mandir}/de/man6/wesnoth.6*
200 %lang(es) %{_mandir}/es/man6/wesnoth.6*
201 %lang(et) %{_mandir}/et/man6/wesnoth.6*
202 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
203 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
204 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
205 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
206 %lang(it) %{_mandir}/it/man6/wesnoth.6*
207 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
208 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
209 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
210 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
211 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
212 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
213 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
214 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
215 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
216 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
217 %{_datadir}/%{name}
218 %{_desktopdir}/*.desktop
219 %{_pixmapsdir}/*-icon.png
220
221 %if %{with server}
222 %files server
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_bindir}/campaignd
225 %attr(755,root,root) %{_bindir}/wesnothd
226 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
227 %{_mandir}/man6/wesnothd.6*
228 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
229 %lang(de) %{_mandir}/de/man6/wesnothd.6*
230 %lang(es) %{_mandir}/es/man6/wesnothd.6*
231 %lang(et) %{_mandir}/et/man6/wesnothd.6*
232 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
233 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
234 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
235 %lang(it) %{_mandir}/it/man6/wesnothd.6*
236 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
237 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
238 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
239 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
240 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
241 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
242 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
243 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
244 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
245 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
246 %endif
247
248 %if %{with tools}
249 %files tools
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_bindir}/cutter
252 %attr(755,root,root) %{_bindir}/exploder
253 %endif
This page took 0.074035 seconds and 3 git commands to generate.