]> git.pld-linux.org Git - packages/waybar.git/commitdiff
up to 0.9.21 auto/th/waybar-0.9.21-1
authorJan Palus <atler@pld-linux.org>
Tue, 15 Aug 2023 19:36:18 +0000 (21:36 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 15 Aug 2023 19:36:18 +0000 (21:36 +0200)
fix build failure with fmt 10.1.0 (from
https://github.com/Alexays/Waybar/pull/2409)

fmt-10.1.0.patch [new file with mode: 0644]
waybar.spec

diff --git a/fmt-10.1.0.patch b/fmt-10.1.0.patch
new file mode 100644 (file)
index 0000000..b66460c
--- /dev/null
@@ -0,0 +1,43 @@
+From c8237437d27fa255f4d8a380dec6db872d139e7d Mon Sep 17 00:00:00 2001
+From: Jan Palus <jpalus@fastmail.com>
+Date: Tue, 15 Aug 2023 20:57:07 +0200
+Subject: [PATCH] Explicitly cast ustring to string when passing to fmt
+
+don't rely on implicit conversion which is no longer present in fmt
+10.1.0
+
+Fixes #2403
+---
+ include/util/format.hpp  | 2 +-
+ src/modules/sni/item.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/util/format.hpp b/include/util/format.hpp
+index 00b6a31..069d889 100644
+--- a/include/util/format.hpp
++++ b/include/util/format.hpp
+@@ -93,7 +93,7 @@ template <>
+ struct formatter<Glib::ustring> : formatter<std::string> {
+   template <typename FormatContext>
+   auto format(const Glib::ustring& value, FormatContext& ctx) {
+-    return formatter<std::string>::format(value, ctx);
++    return formatter<std::string>::format(static_cast<std::string>(value), ctx);
+   }
+ };
+ }  // namespace fmt
+diff --git a/src/modules/sni/item.cpp b/src/modules/sni/item.cpp
+index 9d3fc4b..871621f 100644
+--- a/src/modules/sni/item.cpp
++++ b/src/modules/sni/item.cpp
+@@ -22,7 +22,7 @@ struct fmt::formatter<Glib::VariantBase> : formatter<std::string> {
+   template <typename FormatContext>
+   auto format(const Glib::VariantBase& value, FormatContext& ctx) {
+     if (is_printable(value)) {
+-      return formatter<std::string>::format(value.print(), ctx);
++      return formatter<std::string>::format(static_cast<std::string>(value.print()), ctx);
+     } else {
+       return formatter<std::string>::format(value.get_type_string(), ctx);
+     }
+-- 
+2.41.0
+
index 4876958f7f02735d7434f0480e047042239874c8..99d4cac9e79423ad72498dd9b27f7e3290f17603 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       Highly customizable Wayland bar for Sway and Wlroots based compositors
 Summary(pl.UTF-8):     Bardzo konfigurowalny pasek Waylanda do kompozytorów opartych na Sway i Wlroots
 Name:          waybar
-Version:       0.9.20
-Release:       2
+Version:       0.9.21
+Release:       1
 License:       MIT
 Group:         Applications
 Source0:       https://github.com/Alexays/Waybar/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 3c736fb5a28b14ed327e72e93f193cdf
+# Source0-md5: e274ae334ef8f1790989add8412717a2
+Patch0:                fmt-10.1.0.patch
 URL:           https://github.com/Alexays/Waybar/
 BuildRequires: date-devel
 BuildRequires: glib2-devel
@@ -55,6 +56,7 @@ i Wlroots.
 
 %prep
 %setup -q -n Waybar-%{version}
+%patch0 -p1
 
 %build
 %meson build
This page took 0.292403 seconds and 4 git commands to generate.