]> git.pld-linux.org Git - packages/waf.git/blob - waf.spec
- rel 1
[packages/waf.git] / waf.spec
1 Summary:        The Waf build system
2 Summary(pl):    System budowania Waf
3 Name:           waf
4 Version:        1.0.1
5 Release:        1
6 License:        BSD
7 Group:          Development/Building
8 Source0:        http://freehackers.org/~tnagy/%{name}-%{version}.tar.bz2
9 # Source0-md5:  bc33d144ee927caec6279e0bf4b174ab
10 URL:            http://freehackers.org/~tnagy/bksys.html
11 Patch0:         %{name}-path.patch
12 BuildRequires:  python
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _libdir %{_prefix}/lib
17
18 %description
19 Waf is a general-purpose build system which was modelled from Scons.
20 Though it comes last in the arena of the build systems, we believe
21 that Waf is a vastly superior alternative to its competitors
22 (Autotools, Scons, Cmake, Ant, etc) for building software,
23
24 %description -l pl
25 Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
26 Scons. Mimo ¿e pojawi³ siê jako ostatni na arenie systemów budowania,
27 autorzy wierz±, ¿e przewy¿sza alternatywne narzêdzia (Autotools,
28 Scons, Cmake, Ant itp.).
29
30 %prep
31 %setup -q
32 %patch0 -p1
33
34 %build
35 ./waf-light --make-waf
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 ./waf \
40         --prefix $RPM_BUILD_ROOT%{_prefix} \
41         --destdir $RPM_BUILD_ROOT \
42         --install
43
44 %py_comp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
45 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
46 %py_postclean %{_libdir}/%{name}-%{version}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README TODO
54 %attr(755,root,root) %{_bindir}/waf
55 %dir %{_libdir}/%{name}-%{version}
56 %dir %{_libdir}/%{name}-%{version}/wafadmin
57 %{_libdir}/%{name}-%{version}/wafadmin/*.py[co]
58 %dir %{_libdir}/%{name}-%{version}/wafadmin/Tools
59 %{_libdir}/%{name}-%{version}/wafadmin/Tools/*.py[co]
This page took 0.044844 seconds and 3 git commands to generate.