]> git.pld-linux.org Git - packages/w3m.git/blob - w3m.spec
use imlib2 as imagelib
[packages/w3m.git] / w3m.spec
1 # Conditional build:
2 %bcond_without  image   # build without image support
3
4 Summary:        Text based browser for the world wide web
5 Summary(de.UTF-8):      Text-Browser für das WWW
6 Summary(es.UTF-8):      w3m es un paginador, pero puede usarse también como un navegador WWW
7 Summary(fr.UTF-8):      Navigateur en mode texte pour le world wide web
8 Summary(pl.UTF-8):      Przeglądarka WWW pracująca w trybie tekstowym
9 Summary(pt_BR.UTF-8):   O w3m é um paginador, mas pode ser usado também como um navegador WWW
10 Summary(tr.UTF-8):      Metin ekranda WWW tarayıcı
11 Name:           w3m
12 Version:        0.5.3
13 Release:        8
14 Epoch:          1
15 License:        MIT-like
16 Group:          Applications/Networking
17 Source0:        http://downloads.sourceforge.net/w3m/%{name}-%{version}.tar.gz
18 # Source0-md5:  1b845a983a50b8dec0169ac48479eacc
19 Patch0:         %{name}-gzip_fallback.patch
20 Patch1:         %{name}-nolibs.patch
21 Patch2:         %{name}-0.5.3-parallel-make.patch
22 Patch3:         %{name}-0.5.2-fix_gcc_error.patch
23 Patch4:         %{name}-gc.patch
24 Patch5:         format-security.patch
25 Patch6:         ac-gettext.patch
26 Patch7:         openssl.patch
27 Patch8:         %{name}-configure.patch
28 URL:            http://w3m.sourceforge.net/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  gc-devel
32 BuildRequires:  gettext-tools
33 BuildRequires:  gpm-devel
34 %if %{with image}
35 BuildRequires:  imlib2-devel >= 1.0.5
36 %endif
37 BuildRequires:  ncurses-devel >= 5.0
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  pkgconfig
40 BuildRequires:  sed >= 4.0
41 Provides:       webclient
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 This a terminal based WWW browser. While it does not make any attempt
46 at displaying graphics, it has good support for HTML text formatting,
47 forms, and tables.
48
49 %description -l de.UTF-8
50 Dies ist ein WWW-Browser auf Terminal-Basis. Während kein Versuch
51 unternommen wird, Grafiken darzustellen, so bietet er doch guten
52 Support für HTML-Textformatierung, Formulare und Tabellen.
53
54 %description -l es.UTF-8
55 w3m es un paginador similar a las órdenes more y less. Este paquete
56 también puede utilizarse como un visualizador de páginas WWW en modo
57 texto.
58
59 %description -l fr.UTF-8
60 Navigateur WWW en mode texte. Bien qu'il n'affiche aucun graphique, il
61 sait bien gérer le formatage HTML du texte, les formulaires et les
62 tableaux.
63
64 %description -l pl.UTF-8
65 Przeglądarka WWW działającą w trybie tekstowym. Dobrze formatuje tekst
66 w HTML, ale nie pozwala na wyświetlanie grafiki.
67
68 %description -l pt_BR.UTF-8
69 O w3m é um paginador similar aos comandos more e less. Este pacote
70 pode ser ainda utilizado como um visualizador de páginas WWW em modo
71 texto.
72
73 %description -l tr.UTF-8
74 Metin ekranda çalışan bir WWW tarayıcıdır. Şekil gösteremese de,
75 formlar ve tablolar için desteği vardır.
76
77 %package imgdisplay
78 Summary:        Image display support for w3m
79 Summary(pl.UTF-8):      Wyświetlanie obrazków dla w3m
80 Group:          Applications/Networking
81 Requires:       %{name} = %{epoch}:%{version}-%{release}
82 Requires:       imlib2 >= 1.0.5
83
84 %description imgdisplay
85 Install this package if you want to display images in w3m run on xterm
86 or Linux framebuffer.
87
88 %description imgdisplay -l pl.UTF-8
89 Ten pakiet pozwala przeglądarce w3m wyświetlać obrazki w xtermie lub
90 na linuksowym framebufferze.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98 %patch4 -p1
99 %patch5 -p1
100 %patch6 -p1
101 %patch7 -p1
102 %patch8 -p1
103
104 %{__sed} '/^AC_PROG_CXX$/d' -i configure.ac
105
106 %build
107 cp -f /usr/share/automake/config.sub .
108 %{__gettextize}
109 %{__aclocal}
110 %{__autoconf}
111 %configure \
112         mkdir_p="mkdir -p" \
113         --enable-gopher \
114 %if %{with image}
115         --enable-image="x11,fb,fb+s" \
116         --with-imagelib="imlib2" \
117 %else
118         --disable-image \
119 %endif
120         --enable-keymap=lynx \
121         --with-editor=/bin/vi \
122         --with-mailer=/bin/mail \
123         --with-browser=%{_bindir}/mozilla \
124         --with-termlib=ncurses
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT%{_mandir}/man1
131
132 %{__make} install install-helpfile \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 # symlink instead of duplicated file
136 ln -sf w3mhelp-lynx_en.html $RPM_BUILD_ROOT%{_datadir}/w3m/w3mhelp.html
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc doc/*.html doc/{README,keymap,menu}.* NEWS
146 %attr(755,root,root) %{_bindir}/w3m
147 %attr(755,root,root) %{_bindir}/w3mman
148 %dir %{_libexecdir}/w3m
149 %attr(755,root,root) %{_libexecdir}/w3m/inflate
150 %attr(755,root,root) %{_libexecdir}/w3m/xface2xpm
151 %dir %{_libexecdir}/w3m/cgi-bin
152 %attr(755,root,root) %{_libexecdir}/w3m/cgi-bin/*.cgi
153 %attr(755,root,root) %{_libexecdir}/w3m/cgi-bin/w3mbookmark
154 %attr(755,root,root) %{_libexecdir}/w3m/cgi-bin/w3mhelperpanel
155 %dir %{_datadir}/w3m
156 %{_datadir}/w3m/w3mhelp.html
157 %{_datadir}/w3m/w3mhelp*en.*
158 %lang(ja) %{_datadir}/w3m/w3mhelp*ja.*
159 %{_datadir}/w3m/w3mhelp-funcname.pl
160 %{_mandir}/man1/w3m.1*
161 %{_mandir}/man1/w3mman.1*
162 %lang(ja) %{_mandir}/ja/man1/w3m.1*
163
164 %if %{with image}
165 %files imgdisplay
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libexecdir}/w3m/w3mimgdisplay
168 %endif
This page took 0.086522 seconds and 3 git commands to generate.