]> git.pld-linux.org Git - packages/w3c-libwww.git/commitdiff
- rel 5; fix openssl 1.1.1 build auto/th/w3c-libwww-5.4.2-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 19 Sep 2018 08:15:03 +0000 (10:15 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 19 Sep 2018 08:15:03 +0000 (10:15 +0200)
openssl.patch [new file with mode: 0644]
w3c-libwww.spec

diff --git a/openssl.patch b/openssl.patch
new file mode 100644 (file)
index 0000000..f1dd846
--- /dev/null
@@ -0,0 +1,51 @@
+--- w3c-libwww-5.4.2/configure.ac~     2018-09-19 09:56:26.000000000 +0200
++++ w3c-libwww-5.4.2/configure.ac      2018-09-19 09:57:49.538058686 +0200
+@@ -748,7 +748,7 @@ AC_ARG_WITH(ssl,
+       SSLINC=$sslinc
+     fi
+     LIBS="$LIBS $withval"
+-    AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ SSL_library_init(); ]])],[],[ AC_MSG_ERROR(Could not find the $withval libraries.  You must first install openSSL.) ])
++    AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ SSL_accept(); ]])],[],[ AC_MSG_ERROR(Could not find the $withval libraries.  You must first install openSSL.) ])
+     AC_MSG_RESULT(yes)
+     WWWSSL="libwwwssl.la"
+     LWWWSSL="-lwwwssl" 
+--- w3c-libwww-5.4.2/Library/src/SSL/HTSSL.c~  2018-09-19 10:02:47.000000000 +0200
++++ w3c-libwww-5.4.2/Library/src/SSL/HTSSL.c   2018-09-19 10:05:45.208749659 +0200
+@@ -214,6 +214,7 @@ PUBLIC BOOL HTSSL_init (void)
+       /* select the protocol method */
+       switch (ssl_prot_method) {
++#if 0
+ #ifndef OPENSSL_NO_SSL2
+       case HTSSL_V2:
+         meth = SSLv2_client_method();
+@@ -222,6 +223,7 @@ PUBLIC BOOL HTSSL_init (void)
+       case HTSSL_V3:
+         meth = SSLv3_client_method();
+         break;
++#endif
+       case HTSSL_V23:
+         meth = SSLv23_client_method();
+         break;
+--- w3c-libwww-5.4.2/Library/src/SSL/HTSSL.c~  2018-09-19 10:06:14.000000000 +0200
++++ w3c-libwww-5.4.2/Library/src/SSL/HTSSL.c   2018-09-19 10:08:36.147130194 +0200
+@@ -115,7 +115,7 @@ PRIVATE int verify_callback (int ok, X50
+           verify_error=X509_V_ERR_CERT_CHAIN_TOO_LONG;
+       }
+     }
+-    switch (ctx->error) {
++    switch (X509_STORE_CTX_get_error(ctx)) {
+     case X509_V_ERR_UNABLE_TO_GET_ISSUER_CERT:
+       X509_NAME_oneline(X509_get_issuer_name(ctx->current_cert), buf, 256);
+--- w3c-libwww-5.4.2/Library/src/SSL/HTSSL.c~  2018-09-19 10:08:46.000000000 +0200
++++ w3c-libwww-5.4.2/Library/src/SSL/HTSSL.c   2018-09-19 10:10:52.584492036 +0200
+@@ -118,7 +118,7 @@ PRIVATE int verify_callback (int ok, X50
+     switch (X509_STORE_CTX_get_error(ctx)) {
+     case X509_V_ERR_UNABLE_TO_GET_ISSUER_CERT:
+-      X509_NAME_oneline(X509_get_issuer_name(ctx->current_cert), buf, 256);
++      X509_NAME_oneline(X509_get_issuer_name(X509_STORE_CTX_get_current_cert(ctx)), buf, 256);
+       HTTRACE(PROT_TRACE, "issuer= %s\n" _ buf);
+       break;
index 45b89fd47deaf28ff4a0e1181b15836b81db299b..597e7f1358c678431740364ed0849bcc470a0140 100644 (file)
@@ -9,7 +9,7 @@ Summary(ru.UTF-8):      HTTP-библиотека общеупотребительн
 Summary(uk.UTF-8):     HTTP-бібліотека загальновживаного коду
 Name:          w3c-libwww
 Version:       5.4.2
-Release:       4
+Release:       5
 License:       W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html)
 Group:         Libraries
 Source0:       http://www.w3.org/Library/Distribution/%{name}-%{version}.tgz
@@ -19,6 +19,7 @@ Patch1:               %{name}-link.patch
 Patch2:                %{name}-system-libmd5.patch
 Patch3:                %{name}-ssl.patch
 Patch4:                %{name}-nooldssl.patch
+Patch5:                openssl.patch
 URL:           http://www.w3.org/Library/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
@@ -188,6 +189,7 @@ POST, etc.).
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
This page took 0.087297 seconds and 4 git commands to generate.