]> git.pld-linux.org Git - packages/w3c-libwww.git/blob - w3c-libwww.spec
almost raw
[packages/w3c-libwww.git] / w3c-libwww.spec
1 # Note that this is NOT a relocatable package
2
3 %define ver     5.2.8
4 %define rel     3
5 %define prefix  /usr/
6
7 Summary: HTTP library of common code
8 Name: w3c-libwww
9 Version: %ver
10 Release: %rel
11 Copyright: W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html)
12 Group: System Environment/Libraries
13 Source: http://www.w3.org/Library/Distribution/w3c-libwww-%{ver}.tar.gz
14 URL: http://www.w3.org/Library
15 BuildRoot: /var/tmp/%{name}-root
16 Icon: Lib48x.gif
17
18 %description
19 Libwww is a general-purpose Web API written in C for Unix and Windows (Win32).
20 With a highly extensible and layered API, it can accommodate many different
21 types of applications including clients, robots, etc. The purpose of libwww
22 is to provide a highly optimized HTTP sample implementation as well as other
23 Internet protocols and to serve as a testbed for protocol experiments.
24
25 %package devel
26 Summary: Libraries and header files for programs that use libwww.
27 Group: Development/Libraries
28 Requires: w3c-libwww
29
30 %description devel
31 Static libraries and header files for libwww, which are available as public
32 libraries.
33
34 %package apps
35 Summary: Applications built using Libwww web library: e.g. Robot, command line tool, etc.
36 Group: Applications/Internet
37 Requires: w3c-libwww
38 Icon: robot48x.gif
39
40 %description apps
41
42 Web applications built using Libwww: Robot, Command line tool, 
43 line mode browser.  The Robot can crawl web sites faster, and
44 with lower load, than any other web walker that we know of, 
45 due to its extensive pipelining and use of HTTP/1.1.
46
47 The command line tool (w3c) is very useful for manipulation of 
48 Web sites that implement more than just HTTP GET (e.g. PUT, 
49  POST, etc.).
50
51 The line mode browser is a minimal line mode web browser; 
52 often useful to convert to ascii text.  Currently unavailable
53 until someone updates it to some new interfaces. (hint, hint...)
54
55 %prep
56 %setup -q
57
58 %build
59 #CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr --with-regex --with-zlib
60 #make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
61
62 %configure --enable-shared --with-gnu-ld --with-regex --with-zlib
63 make
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 make prefix=$RPM_BUILD_ROOT%{prefix} install
69
70 ( cd $RPM_BUILD_ROOT
71   chmod +x ./usr/lib/lib{www*,xml*,md5}.so.0.*
72   strip ./usr/bin/* || :
73 )
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post -p /sbin/ldconfig
79
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(-,root,root)
84 %{prefix}/lib/libwww*.so.*
85 %{prefix}/lib/libxml*.so.*
86 %{prefix}/lib/libmd5.so.*
87 %{prefix}/share/w3c-libwww
88
89 %doc *.html */*.html */*/*.html Icons/*/*.gif
90
91 %files apps
92 %defattr(-,root,root)
93 %{prefix}/bin/webbot
94 %{prefix}/bin/w3c
95
96 %files devel
97 %defattr(-,root,root)
98 %{prefix}/bin/libwww-config
99 %{prefix}/lib/lib*.a
100 %{prefix}/lib/lib*.la
101 %{prefix}/lib/lib*.so
102
103 %{prefix}/include/xmlparse.h
104 %{prefix}/include/w3c-libwww
This page took 0.033593 seconds and 4 git commands to generate.