]> git.pld-linux.org Git - packages/vtk.git/commitdiff
- fix building with current gcc auto/th/vtk-6.1.0-7
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Feb 2015 19:08:16 +0000 (20:08 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Feb 2015 19:08:16 +0000 (20:08 +0100)
- update netcdf BRs
- rel 7

conflicting-types.patch [new file with mode: 0644]
vtk.spec

diff --git a/conflicting-types.patch b/conflicting-types.patch
new file mode 100644 (file)
index 0000000..050f711
--- /dev/null
@@ -0,0 +1,22 @@
+--- VTK-6.1.0/Rendering/FreeType/vtkFreeTypeTools.cxx.orig     2015-02-18 19:39:39.428358188 +0100
++++ VTK-6.1.0/Rendering/FreeType/vtkFreeTypeTools.cxx  2015-02-18 19:40:48.241691988 +0100
+@@ -1186,7 +1186,7 @@
+     if (bitmap)
+       {
+       metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+-      metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++      metaData.descent = std::min(-((int)bitmap->rows - ((int)bitmapGlyph->top - 1)),
+                                   metaData.descent);
+       }
+     ++heightString;
+@@ -1951,8 +1951,8 @@
+     if (bitmap)
+       {
+       bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+-      bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+-      bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++      bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + (int)bitmap->width);
++      bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - (int)bitmap->rows);
+       bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
+       }
+     else
index 87344be342b3c4ff6ebe733c8b9cec22912ad2fa..8c38d3706cef8de14d7bd85e1e79f210a95fdc42 100644 (file)
--- a/vtk.spec
+++ b/vtk.spec
@@ -16,7 +16,7 @@ Summary:      Toolkit for 3D computer graphics, image processing, and visualization
 Summary(pl.UTF-8):     Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
 Name:          vtk
 Version:       6.1.0
-Release:       6
+Release:       7
 License:       BSD
 Group:         Libraries
 Source0:       http://www.vtk.org/files/release/6.1/VTK-%{version}.tar.gz
@@ -26,6 +26,7 @@ Source1:      http://www.vtk.org/files/release/6.1/VTKData-%{version}.tar.gz
 Patch0:                %{name}-system-libs.patch
 Patch1:                %{name}-install.patch
 Patch2:                %{name}-chemistry.patch
+Patch3:                conflicting-types.patch
 URL:           http://www.vtk.org/
 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
 BuildRequires: OpenGL-GLX-devel
@@ -64,7 +65,7 @@ BuildRequires:        libtiff-devel
 BuildRequires: libxml2-devel >= 2
 BuildRequires: motif-devel
 BuildRequires: mysql-devel
-BuildRequires: netcdf-devel >= 4
+BuildRequires: netcdf-cxx-devel >= 4
 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
 #BuildRequires:        openqube-devel
 BuildRequires: perl-base
@@ -314,6 +315,7 @@ potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # Replace relative path ../../../VTKData with destination filesystem path
 grep -Erl '(\.\./)+VTKData' Examples | xargs \
@@ -333,7 +335,7 @@ export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
 export JAVA_HOME=%{java_home}
 %endif
 
-mkdir build
+mkdir -p build
 cd build
 %cmake .. \
        -DBUILD_DOCUMENTATION:BOOL=ON \
This page took 0.076562 seconds and 4 git commands to generate.