]> git.pld-linux.org Git - packages/vtk.git/commitdiff
- allow using system libs
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 15 Nov 2012 16:03:35 +0000 (17:03 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 15 Nov 2012 16:03:35 +0000 (17:03 +0100)
vtk-system-libs.patch [new file with mode: 0644]

diff --git a/vtk-system-libs.patch b/vtk-system-libs.patch
new file mode 100644 (file)
index 0000000..5d44c35
--- /dev/null
@@ -0,0 +1,26 @@
+diff -up VTK/CMakeLists.txt.system VTK/CMakeLists.txt
+--- VTK/CMakeLists.txt.system  2010-09-27 14:40:00.000000000 -0600
++++ VTK/CMakeLists.txt 2011-02-08 14:08:29.367122550 -0700
+@@ -106,6 +106,11 @@ IF(CMAKE_CONFIGURATION_TYPES)
+ ENDIF(CMAKE_CONFIGURATION_TYPES)
+ #-----------------------------------------------------------------------------
++# Do we try to use system libraries by default?
++OPTION(VTK_USE_SYSTEM_LIBRARIES "Use the system's libraries by default." OFF)
++MARK_AS_ADVANCED(VTK_USE_SYSTEM_LIBRARIES)
++
++#-----------------------------------------------------------------------------
+ # Load some macros.
+ INCLUDE(vtkDependentOption)
+ INCLUDE(vtkThirdParty)
+diff -up VTK/CMake/vtkThirdParty.cmake.system VTK/CMake/vtkThirdParty.cmake
+--- VTK/CMake/vtkThirdParty.cmake.system       2010-09-27 14:40:00.000000000 -0600
++++ VTK/CMake/vtkThirdParty.cmake      2011-02-08 14:07:46.424662568 -0700
+@@ -1,6 +1,6 @@
+ #-----------------------------------------------------------------------------
+ MACRO(VTK_THIRD_PARTY_OPTION upper lower)
+-  OPTION(VTK_USE_SYSTEM_${upper} "Use the system's ${lower} library." OFF)
++  OPTION(VTK_USE_SYSTEM_${upper} "Use the system's ${lower} library." ${VTK_USE_SYSTEM_LIBRARIES})
+   MARK_AS_ADVANCED(VTK_USE_SYSTEM_${upper})
+   IF(VTK_USE_SYSTEM_${upper})
+     IF(EXISTS ${CMAKE_ROOT}/Modules/Find${upper}.cmake)
This page took 0.035045 seconds and 4 git commands to generate.