]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- updated to 6.0.0
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 #
6 # Conditional build
7 %bcond_without  java            # Java wrappers
8 %bcond_without  ffmpeg          # FFMPEG .avi saving support
9 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
10 %bcond_with     system_proj     # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
11 #
12 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
13 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
14 Name:           vtk
15 Version:        6.0.0
16 Release:        1
17 License:        BSD
18 Group:          Libraries
19 Source0:        http://www.vtk.org/files/release/6.0/%{name}-%{version}.tar.gz
20 # Source0-md5:  72ede4812c90bdc55172702f0cad02bb
21 Source1:        http://www.vtk.org/files/release/6.0/%{name}data-%{version}.tar.gz
22 # Source1-md5:  f40bcfe92439575ae56aa3f2fcd30149
23 Patch0:         %{name}-system-libs.patch
24 Patch1:         %{name}-install.patch
25 Patch2:         %{name}-chemistry.patch
26 URL:            http://www.vtk.org/
27 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
28 BuildRequires:  OpenGL-GLX-devel
29 BuildRequires:  OpenGL-devel
30 BuildRequires:  QtCore-devel >= 4.5.0
31 BuildRequires:  QtGui-devel >= 4.5.0
32 BuildRequires:  QtNetwork-devel >= 4.5.0
33 BuildRequires:  QtSql-devel >= 4.5.0
34 BuildRequires:  QtWebKit-devel >= 4.5.0
35 BuildRequires:  QtXmlPatterns-devel >= 4.5.0
36 BuildRequires:  boost-devel >= 1.39
37 BuildRequires:  cmake >= 2.6.3
38 BuildRequires:  doxygen
39 BuildRequires:  eigen >= 2
40 BuildRequires:  expat-devel
41 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
42 BuildRequires:  fontconfig-devel
43 BuildRequires:  freetype-devel >= 2
44 BuildRequires:  gl2ps-devel >= 1.3.8
45 BuildRequires:  gnuplot
46 BuildRequires:  graphviz
47 BuildRequires:  hdf5-devel
48 %if %{with java}
49 BuildRequires:  jdk >= 1.5
50 BuildRequires:  jpackage-utils
51 %endif
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libogg-devel
54 BuildRequires:  libpng-devel
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  libtheora-devel
57 BuildRequires:  libtiff-devel
58 BuildRequires:  libxml2-devel >= 2
59 BuildRequires:  mysql-devel
60 BuildRequires:  openmotif-devel
61 BuildRequires:  openqube-devel
62 BuildRequires:  postgresql-devel
63 %{?with_system_proj:BuildRequires:      proj-devel >= 4.3, proj-devel < 4.4}
64 BuildRequires:  python-devel
65 BuildRequires:  python-sip-devel
66 BuildRequires:  python-PyQt4-devel
67 BuildRequires:  qt4-build >= 4.5.0
68 BuildRequires:  rpmbuild(macros) >= 1.605
69 BuildRequires:  sip
70 BuildRequires:  tcl-devel
71 BuildRequires:  tk-devel
72 BuildRequires:  wget
73 BuildRequires:  xorg-lib-libICE-devel
74 BuildRequires:  xorg-lib-libSM-devel
75 BuildRequires:  xorg-lib-libX11-devel
76 BuildRequires:  xorg-lib-libXScrnSaver-devel
77 BuildRequires:  xorg-lib-libXext-devel
78 BuildRequires:  xorg-lib-libXft-devel
79 BuildRequires:  xorg-lib-libXt-devel
80 BuildRequires:  zlib-devel
81 Requires:       QtXmlPatterns >= 4.5.0
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         skip_post_check_so      lib.*Python.*\.so.*
85
86 %description
87 The Visualization ToolKit (VTK) is an object oriented software system
88 for 3D computer graphics, image processing, and visualization. VTK
89 includes a textbook, a C++ class library, and several interpreted
90 interface layers including Tcl/Tk, Java, and Python. VTK supports a
91 wide variety of visualization algorithms including scalar, vector,
92 tensor, texture, and volumetric methods. It also supports advanced
93 modeling techniques like implicit modeling, polygon reduction, mesh
94 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
95 dozens of imaging algorithms have been integrated into the system.
96 This allows mixing 2D imaging / 3D graphics algorithms and data.
97
98 %description -l pl.UTF-8
99 Visualization TookKit (VTK) to obiektowo zorientowany system
100 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
101 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
102 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
103 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
104 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
105 Obsługuje także zaawansowane techniki modelowania, takie jak
106 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
107 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
108 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
109 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
110
111 %package devel
112 Summary:        VTK header files for building C++ code
113 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
114 Group:          Development
115 Requires:       %{name} = %{version}-%{release}
116 Requires:       libstdc++-devel
117 Obsoletes:      vtk-qt-devel < 6.0.0-1
118
119 %description devel
120 This provides the VTK header files required to compile C++ programs
121 that use VTK to do 3D visualisation.
122
123 %description devel -l pl.UTF-8
124 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
125 C++ używających VTK do wizualizacji 3D.
126
127 %package qt
128 Summary:        Qt designer plugin for VTK
129 Summary(pl.UTF-8):      Wtyczka Qt designer-a do VTK
130 Group:          X11/Libraries
131 Requires:       %{name} = %{version}-%{release}
132
133 %description qt
134 Qt designer plugin for VTK.
135
136 %description qt -l pl.UTF-8
137 Wtyczka Qt designer-a do VTK.
138
139 %package java
140 Summary:        Java bindings for VTK
141 Summary(pl.UTF-8):      Wiązania Javy do VTK
142 Group:          Development/Languages/Java
143 Requires:       %{name} = %{version}-%{release}
144
145 %description java
146 This package contains Java bindings for VTK.
147
148 %description java -l pl.UTF-8
149 Ten pakiet zawiera wiązania Javy do VTK.
150
151 %package java-devel
152 Summary:        Header files for Java VTK binding
153 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156 Requires:       %{name}-java = %{version}-%{release}
157 # <jni.h>
158 Requires:       jdk
159
160 %description java-devel
161 Header files for Java VTK binding.
162
163 %description java-devel -l pl.UTF-8
164 Pliki nagłówkowe wiązania Javy do VTK.
165
166 %package python
167 Summary:        Python bindings for VTK
168 Summary(pl.UTF-8):      Wiązania Pythona do VTK
169 Group:          Libraries
170 Requires:       %{name} = %{version}-%{release}
171 Obsoletes:      vtk-python-qt < 6.0.0-1
172 Obsoletes:      vtk-python-sip < 6.0.0-1
173
174 %description python
175 This package contains Python bindings for VTK.
176
177 %description python -l pl.UTF-8
178 Ten pakiet zawiera wiązania Pythona do VTK.
179
180 %package python-devel
181 Summary:        Header files for Python VTK binding
182 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona do VTK
183 Group:          Development/Libraries
184 Requires:       %{name}-devel = %{version}-%{release}
185 Requires:       %{name}-python = %{version}-%{release}
186 Requires:       python-devel
187
188 %description python-devel
189 Header files for Python VTK binding.
190
191 %description python-devel -l pl.UTF-8
192 Pliki nagłówkowe wiązania Pythona do VTK.
193
194 %package tcl
195 Summary:        Tcl bindings for VTK
196 Summary(pl.UTF-8):      Wiązania języka Tcl do VTK
197 Group:          Libraries
198 Requires:       %{name} = %{version}-%{release}
199
200 %description tcl
201 This package contains Tcl bindings for VTK.
202
203 %description tcl -l pl.UTF-8
204 Ten pakiet zawiera wiązania języka Tcl do VTK.
205
206 %package tcl-devel
207 Summary:        Header files for Tcl VTK bindings
208 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania języka Tcl do VTK
209 Group:          Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       %{name}-tcl = %{version}-%{release}
212 Requires:       tcl-devel
213 Requires:       tk-devel
214
215 %description tcl-devel
216 Header files for Tcl VTK bindings.
217
218 %description tcl-devel -l pl.UTF-8
219 Pliki nagłówkowe wiązania języka Tcl do VTK.
220
221 %package examples
222 Summary:        C++, Tcl and Python example programs/scripts for VTK
223 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
224 Group:          Development/Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       %{name}-data = %{version}-%{release}
227
228 %description examples
229 This package contains all the examples from the VTK source. To compile
230 the C++ examples you will need to install the vtk-devel package as
231 well. The Python and Tcl examples can be run with the corresponding
232 packages (vtk-python, vtk-tcl).
233
234 %description examples -l pl.UTF-8
235 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
236 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
237 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
238 (vtk-python, vtk-tcl).
239
240 %package test-suite
241 Summary:        Test programs for VTK
242 Summary(pl.UTF-8):      Programy testowe dla VTK
243 Group:          Development/Libraries
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       %{name}-data = %{version}-%{release}
246
247 %description test-suite
248 This package contains all testing programs from the VTK source. The
249 source code of these programs can be found in the vtk-examples
250 package.
251
252 %description test-suite -l pl.UTF-8
253 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
254 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
255
256 %package data
257 Summary:        Data files for VTK
258 Summary(pl.UTF-8):      Pliki danych dla VTK
259 Group:          Development/Libraries
260 %if "%{_rpmversion}" >= "5"
261 BuildArch:      noarch
262 %endif
263
264 %description data
265 This package contains all the data from the VTKData repository. These
266 data are required to run various examples from the vtk-examples
267 package.
268
269 %description data -l pl.UTF-8
270 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
271 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
272
273 %prep
274 %setup -q -n VTK%{version} -a 1
275 %patch0 -p1
276 %patch1 -p1
277 %patch2 -p1
278
279 # Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
280 # otherwise it will break on symlinks.
281 grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs \
282   perl -pi -e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata-%{version},g'
283
284 # Save an unbuilt copy of the Example's sources for %doc
285 mkdir vtk-examples
286 cp -a Examples vtk-examples
287 # Don't ship Win32 examples
288 %{__rm} -r vtk-examples/Examples/GUI/Win32
289 find vtk-examples -type f | xargs chmod -R a-x
290
291 %build
292 export CFLAGS="%{rpmcflags} -D_UNICODE"
293 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
294 %if %{with java}
295 export JAVA_HOME=%{java_home}
296 %endif
297
298 mkdir build
299 cd build
300 %cmake .. \
301         -DBUILD_DOCUMENTATION:BOOL=ON \
302         -DBUILD_EXAMPLES:BOOL=ON \
303         -DBUILD_SHARED_LIBS:BOOL=ON \
304         -DBUILD_TESTING:BOOL=ON \
305         -DCMAKE_C_COMPILER:PATH="%{__cc}" \
306         -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
307         -DCMAKE_SKIP_RPATH:BOOL=ON \
308         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
309         -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
310         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
311         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
312         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
313         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
314         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
315         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
316         -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk \
317         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
318         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
319         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
320         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
321         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
322         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
323         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
324         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
325         -DVTK_WRAP_PYTHON:BOOL=ON \
326         -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
327         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
328         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
329         -DVTK_USE_RENDERING:BOOL=ON \
330         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
331         %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
332 %if %{with java}
333         -DVTK_WRAP_JAVA:BOOL=ON \
334         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
335         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
336         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
337 %else
338         -DVTK_WRAP_JAVA:BOOL=OFF \
339 %endif
340         -DVTK_WRAP_PYTHON:BOOL=ON \
341         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
342         -DVTK_WRAP_TCL:BOOL=ON \
343         -DVTK_Group_Imaging:BOOL=ON \
344         -DVTK_Group_Qt:BOOL=ON \
345         -DVTK_Group_Rendering:BOOL=ON \
346         -DVTK_Group_StandAlone:BOOL=ON \
347         -DVTK_Group_Tk:BOOL=ON \
348         -DVTK_Group_Views:BOOL=ON \
349         -DModule_vtkFiltersStatisticsGnuR:BOOL=ON
350
351 %{__make}
352
353 %install
354 rm -rf $RPM_BUILD_ROOT
355 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version},%{_datadir}/vtk-data} \
356         $RPM_BUILD_ROOT%{py_sitedir}
357
358 %{__make} -C build install \
359         DESTDIR=$RPM_BUILD_ROOT
360
361 # ld config
362 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
363
364 # fix python install path
365 mv $RPM_BUILD_ROOT%{py_sitescriptdir}/* $RPM_BUILD_ROOT%{py_sitedir}
366
367 cp -a VTKDATA%{version}/* $RPM_BUILD_ROOT%{_datadir}/vtk-data
368 cp -a vtk-examples/Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
369
370 # Install utilities
371 install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
372
373 # Install examples
374 for f in \
375 AmbientSpheres \
376 Arrays \
377 BalloonWidget \
378 BandedContours \
379 Cone \
380 Cone2 \
381 Cone3 \
382 Cone4 \
383 Cone5 \
384 Cone6 \
385 Cube \
386 Cylinder \
387 Delaunay3D \
388 Delaunay3DAlpha \
389 DiffuseSpheres \
390 DumpXMLFile \
391 FilledContours \
392 FixedPointVolumeRayCastMapperCT \
393 GPURenderDemo \
394 Generate2DAMRDataSetWithPulse \
395 Generate3DAMRDataSetWithPulse \
396 GenerateCubesFromLabels \
397 GenerateModelsFromLabels \
398 HierarchicalBoxPipeline \
399 ImageDataLIC2DDemo \
400 ImageSlicing \
401 LabeledMesh \
402 MaterialObjects \
403 Medical1 \
404 Medical2 \
405 Medical3 \
406 MultiBlock \
407 ParticleReader \
408 RGrid \
409 SGrid \
410 Slider \
411 Slider2D \
412 SpecularSpheres \
413 StructuredGridLIC2DDemo \
414 SurfaceLICDemo \
415 TimeRenderer \
416 TimeRenderer2 \
417 TubesWithVaryingRadiusAndColors \
418 finance ; do
419         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
420 done
421
422 # Install test binaries
423 for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark ; do
424         install $f $RPM_BUILD_ROOT%{_bindir}
425 done
426
427 install build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
428 install build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
429
430 # Verdict places the docs in the false folder
431 #%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.0
432
433 %py_postclean
434
435 %clean
436 rm -rf $RPM_BUILD_ROOT
437
438 %post   -p /sbin/ldconfig
439 %postun -p /sbin/ldconfig
440
441 %post   java -p /sbin/ldconfig
442 %postun java -p /sbin/ldconfig
443
444 %post   python -p /sbin/ldconfig
445 %postun python -p /sbin/ldconfig
446
447 %post   tcl -p /sbin/ldconfig
448 %postun tcl -p /sbin/ldconfig
449
450 %files
451 %defattr(644,root,root,755)
452 %doc README.html vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
453 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
454 %dir %{_libdir}/vtk
455 %attr(755,root,root) %{_libdir}/vtk/libvtk*.so.1
456 %exclude %{_libdir}/vtk/libvtk*Java.so.1
457 %exclude %{_libdir}/vtk/libvtk*Python27D.so.1
458 %exclude %{_libdir}/vtk/libvtkWrappingPython27Core.so.1
459 %exclude %{_libdir}/vtk/libvtk*TCL.so.1
460
461 %files devel
462 %defattr(644,root,root,755)
463 %doc Utilities/Upgrading/*
464 %attr(755,root,root) %{_bindir}/lproj
465 %attr(755,root,root) %{_bindir}/vtkEncodeString
466 %attr(755,root,root) %{_bindir}/vtkHashSource
467 %attr(755,root,root) %{_bindir}/vtkParseOGLExt
468 %attr(755,root,root) %{_bindir}/vtkProcessShader
469 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
470 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingTools.a
471 %attr(755,root,root) %{_libdir}/vtk/libvtk*.so
472 %exclude %{_libdir}/vtk/libvtk*Java.so
473 %exclude %{_libdir}/vtk/libvtk*Python27D.so
474 %exclude %{_libdir}/vtk/libvtkWrappingPython27Core.so
475 %exclude %{_libdir}/vtk/libvtk*TCL.so
476 %dir %{_includedir}/vtk
477 %{_includedir}/vtk/DICOM*.h
478 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
479 %{_includedir}/vtk/JSONCPP
480 %{_includedir}/vtk/LSDyna*.h
481 %{_includedir}/vtk/Q*.h
482 %{_includedir}/vtk/alglib
483 %{_includedir}/vtk/vtklibproj4
484 %{_includedir}/vtk/vtkmetaio
485 %{_includedir}/vtk/vtknetcdf
486 %{_includedir}/vtk/vtksqlite
487 %{_includedir}/vtk/vtksys
488 %{_includedir}/vtk/vtk*.h
489 %{_includedir}/vtk/vtk*.txx
490 %exclude %{_includedir}/vtk/vtkJavaUtil.h
491 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
492 %exclude %{_includedir}/vtk/vtkPython*.h
493 %exclude %{_includedir}/vtk/vtkTcl*.h
494 %exclude %{_includedir}/vtk/vtkTk*.h
495 %{_libdir}/cmake/vtk
496
497 %files qt
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
500
501 %if %{with java}
502 %files java
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
505 %attr(755,root,root) %{_bindir}/vtkParseJava
506 %attr(755,root,root) %{_bindir}/vtkWrapJava
507 %attr(755,root,root) %{_libdir}/vtk/libvtk*Java.so.1
508 %{_libdir}/vtk/vtk.jar
509
510 %files java-devel
511 %defattr(644,root,root,755)
512 %{_includedir}/vtk/vtkJavaUtil.h
513 %{_includedir}/vtk/vtkWrappingJavaModule.h
514 %attr(755,root,root) %{_libdir}/vtk/libvtk*Java.so
515 %endif
516
517 %files python
518 %defattr(644,root,root,755)
519 %doc Wrapping/Python/README*
520 %attr(755,root,root) %{_bindir}/vtkWrapPython
521 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
522 %attr(755,root,root) %{_bindir}/vtkpython
523 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python27D.so.1
524 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython27Core.so.1
525 %dir %{py_sitedir}/vtk
526 %{py_sitedir}/vtk/*.py[co]
527 %dir %{py_sitedir}/vtk/gtk
528 %{py_sitedir}/vtk/gtk/*.py[co]
529 %dir %{py_sitedir}/vtk/qt4
530 %{py_sitedir}/vtk/qt4/*.py[co]
531 %dir %{py_sitedir}/vtk/test
532 %{py_sitedir}/vtk/test/*.py[co]
533 %dir %{py_sitedir}/vtk/tk
534 %{py_sitedir}/vtk/tk/*.py[co]
535 %dir %{py_sitedir}/vtk/util
536 %{py_sitedir}/vtk/util/*.py[co]
537 %dir %{py_sitedir}/vtk/wx
538 %{py_sitedir}/vtk/wx/*.py[co]
539 %attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
540 %{py_sitedir}/VTK-*-py*.egg-info
541
542 %files python-devel
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python27D.so
545 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython27Core.so
546 %{_includedir}/vtk/PyVTK*.h
547 %{_includedir}/vtk/vtkPython*.h
548
549 %files tcl
550 %defattr(644,root,root,755)
551 %doc Wrapping/Tcl/README*
552 %attr(755,root,root) %{_bindir}/vtkWrapTcl
553 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
554 %attr(755,root,root) %{_bindir}/vtk
555 %{_datadir}/tcl8.5/vtk
556 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
557
558 %files tcl-devel
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
561 %{_includedir}/vtk/vtkTcl*.h
562 %{_includedir}/vtk/vtkTk*.h
563
564 %files test-suite
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_bindir}/*Tests
567 %attr(755,root,root) %{_bindir}/Test*
568 %attr(755,root,root) %{_bindir}/VTKBenchMark
569
570 %files examples
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_bindir}/AmbientSpheres
573 %attr(755,root,root) %{_bindir}/Arrays
574 %attr(755,root,root) %{_bindir}/Cone
575 %attr(755,root,root) %{_bindir}/Cone2
576 %attr(755,root,root) %{_bindir}/Cone3
577 %attr(755,root,root) %{_bindir}/Cone4
578 %attr(755,root,root) %{_bindir}/Cone5
579 %attr(755,root,root) %{_bindir}/Cone6
580 %attr(755,root,root) %{_bindir}/Cube
581 %attr(755,root,root) %{_bindir}/Cylinder
582 %attr(755,root,root) %{_bindir}/DiffuseSpheres
583 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
584 %attr(755,root,root) %{_bindir}/Medical1
585 %attr(755,root,root) %{_bindir}/Medical2
586 %attr(755,root,root) %{_bindir}/Medical3
587 %attr(755,root,root) %{_bindir}/MultiBlock
588 %attr(755,root,root) %{_bindir}/RGrid
589 %attr(755,root,root) %{_bindir}/SGrid
590 %attr(755,root,root) %{_bindir}/SpecularSpheres
591 %attr(755,root,root) %{_bindir}/finance
592 %attr(755,root,root) %{_bindir}/BalloonWidget
593 %attr(755,root,root) %{_bindir}/BandedContours
594 %attr(755,root,root) %{_bindir}/Delaunay3D
595 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
596 %attr(755,root,root) %{_bindir}/DumpXMLFile
597 %attr(755,root,root) %{_bindir}/FilledContours
598 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
599 %attr(755,root,root) %{_bindir}/GPURenderDemo
600 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
601 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
602 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
603 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
604 %attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
605 %attr(755,root,root) %{_bindir}/ImageSlicing
606 %attr(755,root,root) %{_bindir}/LabeledMesh
607 %attr(755,root,root) %{_bindir}/MaterialObjects
608 %attr(755,root,root) %{_bindir}/ParticleReader
609 %attr(755,root,root) %{_bindir}/Slider
610 %attr(755,root,root) %{_bindir}/Slider2D
611 %attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
612 %attr(755,root,root) %{_bindir}/SurfaceLICDemo
613 %attr(755,root,root) %{_bindir}/TimeRenderer
614 %attr(755,root,root) %{_bindir}/TimeRenderer2
615 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
616 %{_examplesdir}/%{name}-%{version}
617
618 %files data
619 %defattr(644,root,root,755)
620 %dir %{_datadir}/vtk-data
621 %{_datadir}/vtk-data/Baseline
622 %{_datadir}/vtk-data/Data
623 %{_datadir}/vtk-data/VERSION
624 %{_datadir}/vtk-data/VTKData.readme
This page took 0.069649 seconds and 4 git commands to generate.