]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- rel 1 with a bit of TODO
[packages/vtk.git] / vtk.spec
1 #
2 # TODO: package lib*(Python|Tk|Java|TCL).so somewhere?
3 #
4
5 # Conditional build
6 %bcond_without  java    # build without Java support
7 %bcond_with     OSMesa  # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
8 #
9 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
10 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
11 Name:           vtk
12 Version:        5.10.1
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 Source0:        http://www.vtk.org/files/release/5.10/%{name}-%{version}.tar.gz
17 # Source0-md5:  264b0052e65bd6571a84727113508789
18 Source1:        http://www.vtk.org/files/release/5.10/%{name}data-%{version}.tar.gz
19 # Source1-md5:  b6355063264cd56bcd1396c92f6ca59a
20 Patch0:         vtk-system-libs.patch
21 Patch1:         vtk-vtkNetCDF_cxx-soname.patch
22 Patch2:         vtk-vtknetcdf-lm.patch
23 URL:            http://www.vtk.org/
24 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  QtWebKit-devel
27 BuildRequires:  boost-devel
28 BuildRequires:  cmake
29 BuildRequires:  doxygen
30 BuildRequires:  expat-devel
31 BuildRequires:  freetype-devel
32 BuildRequires:  gl2ps-devel
33 BuildRequires:  gnuplot
34 BuildRequires:  graphviz
35 BuildRequires:  hdf5-devel
36 %if %{with java}
37 BuildRequires:  jdk
38 BuildRequires:  jpackage-utils
39 %endif
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libtheora-devel
43 BuildRequires:  libtiff-devel
44 BuildRequires:  libxml2-devel
45 BuildRequires:  mysql-devel
46 BuildRequires:  openmotif-devel
47 BuildRequires:  postgresql-devel
48 BuildRequires:  python-devel
49 BuildRequires:  qt4-build
50 BuildRequires:  tcl-devel
51 BuildRequires:  tk-devel
52 BuildRequires:  wget
53 BuildRequires:  xorg-lib-libICE-devel
54 BuildRequires:  xorg-lib-libX11-devel
55 BuildRequires:  xorg-lib-libXext-devel
56 BuildRequires:  xorg-lib-libXt-devel
57 BuildRequires:  zlib-devel
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         skip_post_check_so      lib.*Python.*\.so.*
61
62 %description
63 The Visualization ToolKit (VTK) is an object oriented software system
64 for 3D computer graphics, image processing, and visualization. VTK
65 includes a textbook, a C++ class library, and several interpreted
66 interface layers including Tcl/Tk, Java, and Python. VTK supports a
67 wide variety of visualization algorithms including scalar, vector,
68 tensor, texture, and volumetric methods. It also supports advanced
69 modeling techniques like implicit modeling, polygon reduction, mesh
70 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
71 dozens of imaging algorithms have been integrated into the system.
72 This allows mixing 2D imaging / 3D graphics algorithms and data.
73
74 NOTE: The Java wrapper is not included by default. You may rebuild
75       the srpm using "--with java" with JDK installed.
76
77 NOTE: All patented routines which are part of the package have been
78       removed in this version.
79
80 %description -l pl.UTF-8
81 Visualization TookKit (VTK) to obiektowo zorientowany system
82 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
83 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
84 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
85 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
86 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
87 Obsługuje także zaawansowane techniki modelowania, takie jak
88 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
89 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
90 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
91 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
92
93 UWAGA: wrapper Javy nie został włączony domyślnie. Można przebudować
94        srpm-a z opcją "--with java" przy zainstalowanym JDK.
95
96 UWAGA: wszystkie opatentowane procedury będące częścią tego pakietu
97        zostały usunięte w tej wersji.
98
99 %package devel
100 Summary:        VTK header files for building C++ code
101 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
102 Group:          Development
103 Requires:       %{name} = %{version}-%{release}
104
105 %description devel
106 This provides the VTK header files required to compile C++ programs
107 that use VTK to do 3D visualisation.
108
109 %description devel -l pl.UTF-8
110 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
111 C++ używających VTK do wizualizacji 3D.
112
113 %package tcl
114 Summary:        Tcl bindings for VTK
115 Summary(pl.UTF-8):      Dowiązania Tcl do VTK
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description tcl
120 This package contains Tcl bindings for VTK.
121
122 %description tcl -l pl.UTF-8
123 Ten pakiet zawiera dowiązania Tcl dla VTK.
124
125 %package python
126 Summary:        Python bindings for VTK
127 Summary(pl.UTF-8):      Dowiązania Pythona do VTK
128 Group:          Libraries
129 Requires:       %{name} = %{version}-%{release}
130
131 %description python
132 This package contains Python bindings for VTK.
133
134 %description python -l pl.UTF-8
135 Ten pakiet zawiera dowiązania Pythona dla VTK.
136
137 %package java
138 Summary:        Java bindings for VTK
139 Summary(pl.UTF-8):      Dowiązania Javy do VTK
140 Group:          Development/Languages/Java
141 Requires:       %{name} = %{version}-%{release}
142
143 %description java
144 This package contains Java bindings for VTK.
145
146 %description java -l pl.UTF-8
147 Ten pakiet zawiera dowiązania Javy dla VTK.
148
149 %package qt
150 Summary:        Qt bindings for VTK
151 Requires:       vtk = %{version}-%{release}
152 Group:          System Environment/Libraries
153
154 %description qt
155 Qt bindings for VTK
156
157 %package examples
158 Summary:        C++, Tcl and Python example programs/scripts for VTK
159 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
160 Group:          Development/Libraries
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       %{name}-data = %{version}-%{release}
163
164 %description examples
165 This package contains all the examples from the VTK source. To compile
166 the C++ examples you will need to install the vtk-devel package as
167 well. The Python and Tcl examples can be run with the corresponding
168 packages (vtk-python, vtk-tcl).
169
170 %description examples -l pl.UTF-8
171 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
172 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
173 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
174 (vtk-python, vtk-tcl).
175
176 %package test-suite
177 Summary:        Test programs for VTK
178 Summary(pl.UTF-8):      Programy testowe dla VTK
179 Group:          Development/Libraries
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       %{name}-data = %{version}-%{release}
182
183 %description test-suite
184 This package contains all testing programs from the VTK source. The
185 source code of these programs can be found in the vtk-examples
186 package.
187
188 %description test-suite -l pl.UTF-8
189 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
190 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
191
192 %package data
193 Summary:        Data files for VTK
194 Summary(pl.UTF-8):      Pliki danych dla VTK
195 Group:          Development/Libraries
196 %if "%{_rpmversion}" >= "5"
197 BuildArch:      noarch
198 %endif
199
200 %description data
201 This package contains all the data from the VTKData repository. These
202 data are required to run various examples from the vtk-examples
203 package.
204
205 %description data -l pl.UTF-8
206 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
207 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
208
209 %prep
210 %setup -q -n VTK%{version} -a 1
211 %patch0 -p1
212 %patch1 -p1
213 %patch2 -p1
214
215 # Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
216 # otherwise it will break on symlinks.
217 grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs \
218   perl -pi -e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata-%{version},g'
219
220 # Save an unbuilt copy of the Example's sources for %doc
221 mkdir vtk-examples
222 cp -a Examples vtk-examples
223 # Don't ship Win32 examples
224 %{__rm} -r vtk-examples/Examples/GUI/Win32
225 find vtk-examples -type f | xargs chmod -R a-x
226
227 %build
228 export CFLAGS="%{optflags} -D_UNICODE"
229 export CXXFLAGS="%{optflags} -D_UNICODE"
230 %if %{with java}
231 export JAVA_HOME=%{java_home}
232 %endif
233
234 mkdir build
235 cd build
236 %{cmake} .. \
237         -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
238         -DVTK_INSTALL_INCLUDE_DIR:PATH=/include/vtk \
239         -DVTK_INSTALL_LIB_DIR:PATH=/%{_lib}/vtk \
240         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
241         -DCMAKE_SKIP_RPATH:BOOL=ON \
242         -DBUILD_EXAMPLES:BOOL=ON \
243         -DBUILD_SHARED_LIBS:BOOL=ON \
244         -DBUILD_DOCUMENTATION:BOOL=ON \
245         -DBUILD_TESTING:BOOL=ON \
246 %if %{with OSMesa}
247         -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
248 %endif
249 %if %{with java}
250         -DVTK_WRAP_JAVA:BOOL=ON \
251         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
252         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
253         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
254 %else
255         -DVTK_WRAP_JAVA:BOOL=OFF \
256 %endif
257         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
258         -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
259         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
260         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
261         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
262         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
263         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
264         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
265         -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk \
266         -DVTK_USE_SYSTEM_LIBRARIES=ON \
267         -DVTK_USE_BOOST:BOOL=ON \
268         -DVTK_USE_GL2PS:BOOL=ON \
269         -DVTK_USE_GUISUPPORT:BOOL=ON \
270         -DVTK_USE_MYSQL=ON \
271         -DVTK_USE_OGGTHEORA_ENCODER=ON \
272         -DVTK_USE_POSTGRES=ON \
273         -DVTK_USE_SYSTEM_LIBPROJ4=OFF \
274         -DVTK_USE_QVTK=ON \
275         -DVTK_USE_QT=ON \
276         -DVTK_USE_HYBRID:BOOL=ON \
277         -DVTK_USE_PARALLEL:BOOL=ON \
278         -DVTK_USE_PATENTED:BOOL=off \
279         -DVTK_USE_RENDERING:BOOL=ON \
280         -DVTK_WRAP_JAVA:BOOL=%{?with_java:ON}%{!?with_java:OFF} \
281         -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
282         -DVTK_WRAP_PYTHON:BOOL=ON \
283         -DVTK_WRAP_TCL:BOOL=ON \
284         -DBUILD_SHARED_LIBS:BOOL=ON \
285         -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
286         -DCMAKE_C_COMPILER:PATH="%{__cc}" \
287         -DCMAKE_LINKER_FLAGS:STRING="%{rpmldflags}" \
288         -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
289
290 %{__make}
291
292 %install
293 rm -rf $RPM_BUILD_ROOT
294 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version},%{_datadir}/vtk-data} \
295         $RPM_BUILD_ROOT%{py_sitedir}
296
297 %{__make} -C build install \
298         DESTDIR=$RPM_BUILD_ROOT
299
300 # ld config
301 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
302
303 # fix python install path
304 mv $RPM_BUILD_ROOT%{py_sitescriptdir}/* $RPM_BUILD_ROOT%{py_sitedir}
305
306 cp -a VTKData%{version}/* $RPM_BUILD_ROOT%{_datadir}/vtk-data
307 cp -a vtk-examples/Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
308
309 # Install utilities
310 install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
311
312 # Install examples
313 for f in \
314 HierarchicalBoxPipeline \
315 MultiBlock \
316 Arrays \
317 Cube \
318 RGrid \
319 SGrid \
320 Medical1 \
321 Medical2 \
322 Medical3 \
323 finance \
324 AmbientSpheres \
325 Cylinder \
326 DiffuseSpheres \
327 SpecularSpheres \
328 Cone \
329 Cone2 \
330 Cone3 \
331 Cone4 \
332 Cone5 \
333 Cone6 ; do
334         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
335 done
336
337 # Install test binaries
338 for f in \
339 CommonCxxTests \
340 TestCxxFeatures \
341 TestInstantiator \
342 FilteringCxxTests \
343 GraphicsCxxTests \
344 GenericFilteringCxxTests \
345 ImagingCxxTests \
346 IOCxxTests \
347 RenderingCxxTests \
348 VTKBenchMark \
349 VolumeRenderingCxxTests \
350 WidgetsCxxTests \
351 SocketClient \
352 SocketServer ; do
353         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
354 done
355
356 # Add exec bits to shared libs ...
357 #chmod 0755 %{buildroot}%{_libdir}/python*/site-packages/vtk/*.so
358
359 # Verdict places the docs in the false folder
360 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/vtk/doc
361
362 %clean
363 rm -rf $RPM_BUILD_ROOT
364
365 %post   -p /sbin/ldconfig
366 %postun -p /sbin/ldconfig
367
368 %post   tcl -p /sbin/ldconfig
369 %postun tcl -p /sbin/ldconfig
370
371 %post   python -p /sbin/ldconfig
372 %postun python -p /sbin/ldconfig
373
374 %post   java -p /sbin/ldconfig
375 %postun java -p /sbin/ldconfig
376
377 %post   qt -p /sbin/ldconfig
378 %postun qt -p /sbin/ldconfig
379
380 %files
381 %defattr(644,root,root,755)
382 %doc README.html vtkLogo.jpg vtkBanner.gif Wrapping/*/README*
383 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
384 %dir %{_libdir}/vtk
385 %attr(755,root,root) %ghost %{_libdir}/vtk/libCosmo.so.5.10
386 %attr(755,root,root) %{_libdir}/vtk/libCosmo.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/vtk/libLSDyna.so.5.10
388 %attr(755,root,root) %{_libdir}/vtk/libLSDyna.so.*.*.*
389 %attr(755,root,root) %ghost %{_libdir}/vtk/libMapReduceMPI.so.5.10
390 %attr(755,root,root) %{_libdir}/vtk/libMapReduceMPI.so.*.*.*
391 %attr(755,root,root) %ghost %{_libdir}/vtk/libmpistubs.so.5.10
392 %attr(755,root,root) %{_libdir}/vtk/libmpistubs.so.*.*.*
393 %attr(755,root,root) %ghost %{_libdir}/vtk/libVPIC.so.5.10
394 %attr(755,root,root) %{_libdir}/vtk/libVPIC.so.*.*.*
395 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkalglib.so.5.10
396 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.*.*.*
397 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkCharts.so.5.10
398 %attr(755,root,root) %{_libdir}/vtk/libvtkCharts.so.*.*.*
399 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkCommon.so.5.10
400 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon.so.*.*.*
401 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkDICOMParser.so.5.10
402 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.*.*.*
403 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkexoIIc.so.5.10
404 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.*.*.*
405 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkFiltering.so.5.10
406 %attr(755,root,root) %{_libdir}/vtk/libvtkFiltering.so.*.*.*
407 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkftgl.so.5.10
408 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.*.*.*
409 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkGenericFiltering.so.5.10
410 %attr(755,root,root) %{_libdir}/vtk/libvtkGenericFiltering.so.*.*.*
411 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkGeovis.so.5.10
412 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovis.so.*.*.*
413 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkGraphics.so.5.10
414 %attr(755,root,root) %{_libdir}/vtk/libvtkGraphics.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkHybrid.so.5.10
416 %attr(755,root,root) %{_libdir}/vtk/libvtkHybrid.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkImaging.so.5.10
418 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkInfovis.so.5.10
420 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkIO.so.5.10
422 %attr(755,root,root) %{_libdir}/vtk/libvtkIO.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkmetaio.so.5.10
424 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.*.*.*
425 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkNetCDF_cxx.so.5.10
426 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF_cxx.so.*.*.*
427 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkNetCDF.so.5.10
428 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkParallel.so.5.10
430 %attr(755,root,root) %{_libdir}/vtk/libvtkParallel.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkproj4.so.5.10
432 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkRendering.so.5.10
434 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtksqlite.so.5.10
436 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.*.*.*
437 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtksys.so.5.10
438 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.*.*.*
439 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkverdict.so.5.10
440 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.*.*.*
441 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkViews.so.5.10
442 %attr(755,root,root) %{_libdir}/vtk/libvtkViews.so.*.*.*
443 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkVolumeRendering.so.5.10
444 %attr(755,root,root) %{_libdir}/vtk/libvtkVolumeRendering.so.*.*.*
445 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtkWidgets.so.5.10
446 %attr(755,root,root) %{_libdir}/vtk/libvtkWidgets.so.*.*.*
447
448 %files devel
449 %defattr(644,root,root,755)
450 %doc %{_libdir}/vtk/doxygen
451 %doc Utilities/Upgrading/*
452 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
453 %attr(755,root,root) %{_bindir}/lproj
454 %attr(755,root,root) %{_bindir}/vtkEncodeString
455 %{_includedir}/vtk
456 %{_libdir}/vtk/CMake
457 %{_libdir}/vtk/*.cmake
458 %{_libdir}/vtk/hints
459 %attr(755,root,root) %{_libdir}/vtk/libCosmo.so
460 %attr(755,root,root) %{_libdir}/vtk/libLSDyna.so
461 %attr(755,root,root) %{_libdir}/vtk/libMapReduceMPI.so
462 %attr(755,root,root) %{_libdir}/vtk/libmpistubs.so
463 %attr(755,root,root) %{_libdir}/vtk/libVPIC.so
464 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
465 %attr(755,root,root) %{_libdir}/vtk/libvtkCharts.so
466 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon.so
467 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
468 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
469 %attr(755,root,root) %{_libdir}/vtk/libvtkFiltering.so
470 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
471 %attr(755,root,root) %{_libdir}/vtk/libvtkGenericFiltering.so
472 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovis.so
473 %attr(755,root,root) %{_libdir}/vtk/libvtkGraphics.so
474 %attr(755,root,root) %{_libdir}/vtk/libvtkHybrid.so
475 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging.so
476 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis.so
477 %attr(755,root,root) %{_libdir}/vtk/libvtkIO.so
478 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
479 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF_cxx.so
480 %attr(755,root,root) %{_libdir}/vtk/libvtkNetCDF.so
481 %attr(755,root,root) %{_libdir}/vtk/libvtkParallel.so
482 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
483 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering.so
484 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
485 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
486 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
487 %attr(755,root,root) %{_libdir}/vtk/libvtkViews.so
488 %attr(755,root,root) %{_libdir}/vtk/libvtkVolumeRendering.so
489 %attr(755,root,root) %{_libdir}/vtk/libvtkWidgets.so
490
491 %files tcl
492 %defattr(644,root,root,755)
493 %doc README.html vtkLogo.jpg
494 %attr(755,root,root) %{_bindir}/vtkWrapTcl
495 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
496 %attr(755,root,root) %{_bindir}/vtk
497 %{_libdir}/vtk/tcl
498 %{_libdir}/vtk/pkgIndex.tcl
499 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtk*TCL.so.5.10
500 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.*.*.*
501
502 %files python
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_bindir}/vtkWrapPython
505 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
506 %attr(755,root,root) %{_bindir}/vtkpython
507 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtk*Python*.so.5.10
508 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python*.so.*.*.*
509
510 %dir %{py_sitedir}/vtk
511 %{py_sitedir}/vtk/*.py*
512 %dir %{py_sitedir}/vtk/gtk
513 %{py_sitedir}/vtk/gtk/*.py*
514 %dir %{py_sitedir}/vtk/qt
515 %dir %{py_sitedir}/vtk/qt4
516 %{py_sitedir}/vtk/qt*/*.py*
517 %dir %{py_sitedir}/vtk/test
518 %{py_sitedir}/vtk/test/*.py*
519 %dir %{py_sitedir}/vtk/tk
520 %{py_sitedir}/vtk/tk/*.py*
521 %dir %{py_sitedir}/vtk/util
522 %{py_sitedir}/vtk/util/*.py*
523 %dir %{py_sitedir}/vtk/wx
524 %{py_sitedir}/vtk/wx/*.py*
525 %attr(755,root,root) %{py_sitedir}/vtk/vtk*.so
526 %{py_sitedir}/VTK-%{version}-*.egg-info
527
528 %if %{with java}
529 %files java
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_bindir}/vtkParseJava
532 %attr(755,root,root) %{_bindir}/vtkWrapJava
533 %attr(755,root,root) %ghost %{_libdir}/vtk/libvtk*Java.so.5.10
534 %attr(755,root,root) %{_libdir}/vtk/libvtk*Java.so.*.*.*
535 %{_libdir}/vtk/java
536 %endif
537
538 %files qt
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %ghost %{_libdir}/vtk/libQVTK.so.5.10
541 %attr(755,root,root) %{_libdir}/vtk/libQVTK.so.*.*.*
542 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
543
544 %files test-suite
545 %defattr(644,root,root,755)
546 %{_libdir}/vtk/testing
547 %attr(755,root,root) %{_bindir}/CommonCxxTests
548 %attr(755,root,root) %{_bindir}/TestCxxFeatures
549 %attr(755,root,root) %{_bindir}/TestInstantiator
550 %attr(755,root,root) %{_bindir}/FilteringCxxTests
551 %attr(755,root,root) %{_bindir}/GraphicsCxxTests
552 %attr(755,root,root) %{_bindir}/GenericFilteringCxxTests
553 %attr(755,root,root) %{_bindir}/ImagingCxxTests
554 %attr(755,root,root) %{_bindir}/IOCxxTests
555 %attr(755,root,root) %{_bindir}/RenderingCxxTests
556 %attr(755,root,root) %{_bindir}/VTKBenchMark
557 %attr(755,root,root) %{_bindir}/VolumeRenderingCxxTests
558 %attr(755,root,root) %{_bindir}/WidgetsCxxTests
559 %attr(755,root,root) %{_bindir}/SocketClient
560 %attr(755,root,root) %{_bindir}/SocketServer
561
562 %files examples
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
565 %attr(755,root,root) %{_bindir}/MultiBlock
566 %attr(755,root,root) %{_bindir}/Arrays
567 %attr(755,root,root) %{_bindir}/Cube
568 %attr(755,root,root) %{_bindir}/RGrid
569 %attr(755,root,root) %{_bindir}/SGrid
570 %attr(755,root,root) %{_bindir}/Medical1
571 %attr(755,root,root) %{_bindir}/Medical2
572 %attr(755,root,root) %{_bindir}/Medical3
573 %attr(755,root,root) %{_bindir}/finance
574 %attr(755,root,root) %{_bindir}/AmbientSpheres
575 %attr(755,root,root) %{_bindir}/Cylinder
576 %attr(755,root,root) %{_bindir}/DiffuseSpheres
577 %attr(755,root,root) %{_bindir}/SpecularSpheres
578 %attr(755,root,root) %{_bindir}/Cone
579 %attr(755,root,root) %{_bindir}/Cone2
580 %attr(755,root,root) %{_bindir}/Cone3
581 %attr(755,root,root) %{_bindir}/Cone4
582 %attr(755,root,root) %{_bindir}/Cone5
583 %attr(755,root,root) %{_bindir}/Cone6
584 %{_examplesdir}/%{name}-%{version}
585
586 %files data
587 %defattr(644,root,root,755)
588 %dir %{_datadir}/vtk-data
589 %{_datadir}/vtk-data/Baseline
590 %{_datadir}/vtk-data/Data
591 %{_datadir}/vtk-data/VTKData.readme
This page took 0.176328 seconds and 4 git commands to generate.