]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- fix python install path
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8 # - python bcond?
9 #
10 # Conditional build
11 %bcond_without  java            # Java wrappers
12 %bcond_without  ffmpeg          # FFMPEG .avi saving support
13 %bcond_with     doc             # do not build and package doxygen documentation
14 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
15 %bcond_with     system_gl2ps    # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
18 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19 Name:           vtk
20 Version:        8.2.0
21 Release:        0.1
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://www.vtk.org/files/release/8.2/VTK-%{version}.tar.gz
25 # Source0-md5:  8af3307da0fc2ef8cafe4a312b821111
26 Source1:        http://www.vtk.org/files/release/8.2/VTKData-%{version}.tar.gz
27 # Source1-md5:  a6eab7bc02cee1376ee69243dde373ce
28 Patch0:         vtk-abi.patch
29 Patch1:         gcc10.patch
30 Patch2:         proj6_compat.patch
31 Patch3:         qt-5.15.patch
32 Patch4:         python-3.8.patch
33 Patch5:         link.patch
34 URL:            http://www.vtk.org/
35 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  Qt5Core-devel
39 BuildRequires:  Qt5Designer-devel
40 BuildRequires:  Qt5Gui-devel
41 BuildRequires:  Qt5Network-devel
42 BuildRequires:  Qt5OpenGL-devel
43 BuildRequires:  Qt5Sql-devel
44 BuildRequires:  Qt5WebKit-devel
45 BuildRequires:  Qt5X11Extras-devel
46 BuildRequires:  Qt5XmlPatterns-devel
47 BuildRequires:  Qt5UiTools-devel
48 BuildRequires:  R
49 BuildRequires:  boost-devel >= 1.39
50 BuildRequires:  cmake >= 2.8.8
51 %{?with_doc:BuildRequires:      doxygen}
52 BuildRequires:  expat-devel
53 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
54 BuildRequires:  fontconfig-devel
55 BuildRequires:  freetype-devel >= 2
56 BuildRequires:  gdal-devel
57 %{?with_system_gl2ps:BuildRequires:     gl2ps-devel >= 1.3.8}
58 BuildRequires:  gnuplot
59 BuildRequires:  graphviz
60 BuildRequires:  hdf5-devel
61 %if %{with java}
62 BuildRequires:  jdk >= 1.5
63 BuildRequires:  jpackage-utils
64 %endif
65 BuildRequires:  jsoncpp-devel
66 BuildRequires:  libharu-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libogg-devel
69 BuildRequires:  libpng-devel
70 BuildRequires:  libstdc++-devel
71 BuildRequires:  libtheora-devel
72 BuildRequires:  libtiff-devel
73 BuildRequires:  libxml2-devel >= 2
74 BuildRequires:  lz4-devel
75 BuildRequires:  motif-devel
76 BuildRequires:  mysql-devel
77 BuildRequires:  netcdf-cxx-devel >= 4
78 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
79 #BuildRequires: openqube-devel
80 BuildRequires:  perl-base
81 BuildRequires:  postgresql-devel
82 BuildRequires:  proj-devel >= 6.0
83 BuildRequires:  python3-devel
84 BuildRequires:  python3-sip-devel
85 BuildRequires:  qt5-build >= 4.5.0
86 BuildRequires:  qt5-qmake >= 4.5.0
87 BuildRequires:  rpmbuild(macros) >= 1.605
88 BuildRequires:  sip
89 BuildRequires:  sip-PyQt5
90 BuildRequires:  tcl-devel
91 BuildRequires:  tk-devel
92 BuildRequires:  unixODBC-devel
93 BuildRequires:  wget
94 BuildRequires:  xorg-lib-libICE-devel
95 BuildRequires:  xorg-lib-libSM-devel
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xorg-lib-libXScrnSaver-devel
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXft-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 BuildRequires:  zlib-devel
102 BuildConflicts: libXNVCtrl-devel
103 %{?with_system_gl2ps:Requires:  gl2ps >= 1.3.8}
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         skip_post_check_so      lib.*Python.*\.so.*
107
108 %description
109 The Visualization ToolKit (VTK) is an object oriented software system
110 for 3D computer graphics, image processing, and visualization. VTK
111 includes a textbook, a C++ class library, and several interpreted
112 interface layers including Tcl/Tk, Java, and Python. VTK supports a
113 wide variety of visualization algorithms including scalar, vector,
114 tensor, texture, and volumetric methods. It also supports advanced
115 modeling techniques like implicit modeling, polygon reduction, mesh
116 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
117 dozens of imaging algorithms have been integrated into the system.
118 This allows mixing 2D imaging / 3D graphics algorithms and data.
119
120 %description -l pl.UTF-8
121 Visualization TookKit (VTK) to obiektowo zorientowany system
122 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
123 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
124 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
125 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
126 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
127 Obsługuje także zaawansowane techniki modelowania, takie jak
128 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
129 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
130 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
131 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
132
133 %package devel
134 Summary:        VTK header files for building C++ code
135 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
136 Group:          Development
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       libstdc++-devel
139
140 %description devel
141 This provides the VTK header files required to compile C++ programs
142 that use VTK to do 3D visualisation.
143
144 %description devel -l pl.UTF-8
145 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
146 C++ używających VTK do wizualizacji 3D.
147
148 %package qt
149 Summary:        Qt5 bindings and Qt5 Designer plugin for VTK
150 Summary(pl.UTF-8):      Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
151 Group:          X11/Libraries
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       Qt5Core >= 4.5.0
154 Requires:       Qt5Gui >= 4.5.0
155 Requires:       Qt5Network >= 4.5.0
156 Requires:       Qt5OpenGL >= 4.5.0
157 Requires:       Qt5Sql >= 4.5.0
158 Requires:       Qt5WebKit >= 4.5.0
159
160 %description qt
161 Qt5 bindings and Qt5 Designer plugin for VTK.
162
163 %description qt -l pl.UTF-8
164 Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
165
166 %package qt-devel
167 Summary:        Header files for VTK Qt5 bindings
168 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt5` do VTK
169 Group:          X11/Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       %{name}-qt = %{version}-%{release}
172 Requires:       Qt5Core-devel >= 4.5.0
173 Requires:       Qt5Gui-devel >= 4.5.0
174 Requires:       Qt5OpenGL-devel >= 4.5.0
175 Requires:       Qt5Sql-devel >= 4.5.0
176
177 %description qt-devel
178 Header files for VTK Qt bindings.
179
180 %description qt-devel -l pl.UTF-8
181 Pliki nagłówkowe wiązań Qt do VTK.
182
183 %package java
184 Summary:        Java bindings for VTK
185 Summary(pl.UTF-8):      Wiązania Javy do VTK
186 Group:          Development/Languages/Java
187 Requires:       %{name} = %{version}-%{release}
188 # or separate qt parts?
189 Requires:       %{name}-qt = %{version}-%{release}
190
191 %description java
192 This package contains Java bindings for VTK.
193
194 %description java -l pl.UTF-8
195 Ten pakiet zawiera wiązania Javy do VTK.
196
197 %package java-devel
198 Summary:        Header files for Java VTK binding
199 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
200 Group:          Development/Libraries
201 Requires:       %{name}-devel = %{version}-%{release}
202 Requires:       %{name}-java = %{version}-%{release}
203 # <jni.h>
204 Requires:       jdk
205
206 %description java-devel
207 Header files for Java VTK binding.
208
209 %description java-devel -l pl.UTF-8
210 Pliki nagłówkowe wiązania Javy do VTK.
211
212 %package python3
213 Summary:        Python 3 bindings for VTK
214 Summary(pl.UTF-8):      Wiązania Pythona 3 do VTK
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217 # or separate qt parts again?
218 Requires:       %{name}-qt = %{version}-%{release}
219 Obsoletes:      vtk-python-qt < 6.0.0-1
220 Obsoletes:      vtk-python-sip < 6.0.0-1
221 Obsoletes:      vtk-python < 8.2.0-1
222
223 %description python3
224 This package contains Python 3 bindings for VTK.
225
226 %description python3 -l pl.UTF-8
227 Ten pakiet zawiera wiązania Pythona 3 do VTK.
228
229 %package python3-devel
230 Summary:        Header files for Python 3 VTK binding
231 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona 3 do VTK
232 Group:          Development/Libraries
233 Requires:       %{name}-devel = %{version}-%{release}
234 Requires:       %{name}-python3 = %{version}-%{release}
235 Requires:       python3-devel
236 Obsoletes:      vtk-python-devel < 8.2.0-1
237
238 %description python3-devel
239 Header files for Python 3 VTK binding.
240
241 %description python3-devel -l pl.UTF-8
242 Pliki nagłówkowe wiązania Pythona 3 do VTK.
243
244 %package tcl
245 Summary:        Tcl bindings for VTK
246 Summary(pl.UTF-8):      Wiązania języka Tcl do VTK
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249 # or separate qt parts?
250 Requires:       %{name}-qt = %{version}-%{release}
251
252 %description tcl
253 This package contains Tcl bindings for VTK.
254
255 %description tcl -l pl.UTF-8
256 Ten pakiet zawiera wiązania języka Tcl do VTK.
257
258 %package tcl-devel
259 Summary:        Header files for Tcl VTK bindings
260 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania języka Tcl do VTK
261 Group:          Development/Libraries
262 Requires:       %{name}-devel = %{version}-%{release}
263 Requires:       %{name}-tcl = %{version}-%{release}
264 Requires:       tcl-devel
265 Requires:       tk-devel
266
267 %description tcl-devel
268 Header files for Tcl VTK bindings.
269
270 %description tcl-devel -l pl.UTF-8
271 Pliki nagłówkowe wiązania języka Tcl do VTK.
272
273 %package examples
274 Summary:        C++, Tcl and Python example programs/scripts for VTK
275 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
276 Group:          Development/Libraries
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       %{name}-data = %{version}-%{release}
279
280 %description examples
281 This package contains all the examples from the VTK source. To compile
282 the C++ examples you will need to install the vtk-devel package as
283 well. The Python and Tcl examples can be run with the corresponding
284 packages (vtk-python, vtk-tcl).
285
286 %description examples -l pl.UTF-8
287 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
288 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
289 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
290 (vtk-python, vtk-tcl).
291
292 %package test-suite
293 Summary:        Test programs for VTK
294 Summary(pl.UTF-8):      Programy testowe dla VTK
295 Group:          Development/Libraries
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       %{name}-data = %{version}-%{release}
298
299 %description test-suite
300 This package contains all testing programs from the VTK source. The
301 source code of these programs can be found in the vtk-examples
302 package.
303
304 %description test-suite -l pl.UTF-8
305 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
306 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
307
308 %package data
309 Summary:        Data files for VTK
310 Summary(pl.UTF-8):      Pliki danych dla VTK
311 Group:          Development/Libraries
312 %if "%{_rpmversion}" >= "5"
313 BuildArch:      noarch
314 %endif
315
316 %description data
317 This package contains all the data from the VTKData repository. These
318 data are required to run various examples from the vtk-examples
319 package.
320
321 %description data -l pl.UTF-8
322 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
323 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
324
325 %prep
326 %setup -q -n VTK-%{version} -b 1
327 %patch0 -p1
328 %patch1 -p1
329 %patch2 -p1
330 %patch3 -p1
331 %patch4 -p1
332 %patch5 -p1
333
334 # Replace relative path ../../../VTKData with destination filesystem path
335 grep -Erl '(\.\./)+VTKData' Examples | xargs \
336   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
337
338 # Save an unbuilt copy of the Example's sources for %doc
339 mkdir vtk-examples
340 cp -a Examples vtk-examples
341 # Don't ship Win32 examples
342 %{__rm} -r vtk-examples/Examples/GUI/Win32
343 find vtk-examples -type f | xargs chmod -R a-x
344
345 %build
346 export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
347 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
348 %if %{with java}
349 export JAVA_HOME=%{java_home}
350 %ifarch x32
351 # getting "java.lang.OutOfMemoryError: Java heap space" during the build
352 export JAVA_TOOL_OPTIONS=-Xmx2048m
353 %endif
354 %endif
355
356 # handle cmake & ccache
357 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
358 # ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
359 if [[ "%{__cc}" = *ccache* ]]; then
360         cc="%{__cc}"
361         cxx="%{__cxx}"
362         ccache="
363         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
364         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
365         -DCMAKE_ASM_COMPILER="${cc#ccache }" \
366         "
367 else
368         ccache="
369         -DCMAKE_C_COMPILER="%{__cc}" \
370         -DCMAKE_CXX_COMPILER="%{__cxx}" \
371         -DCMAKE_ASM_COMPILER="%{__cc}" \
372         "
373 fi
374
375 mkdir -p build
376 cd build
377 %cmake .. \
378         $ccache \
379         -Wno-dev \
380         %{cmake_on_off doc DBUILD_DOCUMENTATION} \
381         -DBUILD_EXAMPLES:BOOL=ON \
382         -DBUILD_SHARED_LIBS:BOOL=ON \
383         -DBUILD_TESTING:BOOL=ON \
384         -DCMAKE_SKIP_RPATH:BOOL=ON \
385         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
386         -DPYTHON_INCLUDE_PATH:PATH=%{py3_incdir} \
387         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py3_ver}.so \
388         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
389         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
390         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
391         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
392         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
393         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
394         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
395         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
396         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
397         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
398         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
399         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
400         -DVTK_INSTALL_PYTHON_MODULES_DIR:PATH=%{py3_sitedir} \
401         -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
402         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
403         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
404         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
405         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
406         -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
407         -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
408         %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
409 %if %{with java}
410         -DVTK_WRAP_JAVA:BOOL=ON \
411         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
412         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
413         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
414 %else
415         -DVTK_WRAP_JAVA:BOOL=OFF \
416 %endif
417         -DVTK_WRAP_PYTHON:BOOL=ON \
418         -DVTK_PYTHON_VERSION=3 \
419         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
420         -DVTK_Group_Imaging:BOOL=ON \
421         -DVTK_Group_Qt:BOOL=ON \
422         -DVTK_Group_Rendering:BOOL=ON \
423         -DVTK_Group_StandAlone:BOOL=ON \
424         -DVTK_Group_Tk:BOOL=ON \
425         -DVTK_Group_Views:BOOL=ON \
426         -DModule_vtkFiltersReebGraph:BOOL=ON \
427         %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
428         -DModule_vtkIOGDAL:BOOL=ON \
429         -DModule_vtkIOGeoJSON:BOOL=ON \
430         -DModule_vtkIOMySQL:BOOL=ON \
431         -DModule_vtkIOODBC:BOOL=ON \
432         -DModule_vtkIOParallelExodus:BOOL=ON \
433         -DModule_vtkIOParallelLSDyna:BOOL=ON \
434         -DModule_vtkIOPostgreSQL:BOOL=ON \
435         -DModule_vtkIOVPIC:BOOL=ON \
436         -DModule_vtkIOXdmf2:BOOL=ON \
437         -DModule_vtkInfovisBoost:BOOL=ON \
438         -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
439         -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
440         -DModule_vtkRenderingMatplotlib:BOOL=ON \
441         -DModule_vtkRenderingParallel:BOOL=ON
442 # TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
443 # TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
444 # TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
445 # TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
446 # TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
447 # TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
448
449 %{__make}
450 %{?with_doc:%{__make} DoxygenDoc}
451
452 %install
453 rm -rf $RPM_BUILD_ROOT
454 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
455
456 %{__make} -C build install \
457         DESTDIR=$RPM_BUILD_ROOT
458
459 # ld config
460 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
461
462 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
463         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
464 done
465
466 # Install examples
467 for f in \
468 AmbientSpheres \
469 Arrays \
470 BalloonWidget \
471 BandedContours \
472 Cone \
473 Cone2 \
474 Cone3 \
475 Cone4 \
476 Cone5 \
477 Cone6 \
478 Cube \
479 Cylinder \
480 Delaunay3D \
481 Delaunay3DAlpha \
482 DiffuseSpheres \
483 DumpXMLFile \
484 FilledContours \
485 FixedPointVolumeRayCastMapperCT \
486 GPURenderDemo \
487 Generate2DAMRDataSetWithPulse \
488 Generate3DAMRDataSetWithPulse \
489 GenerateCubesFromLabels \
490 GenerateModelsFromLabels \
491 HierarchicalBoxPipeline \
492 ImageSlicing \
493 LabeledMesh \
494 Medical1 \
495 Medical2 \
496 Medical3 \
497 Medical4 \
498 MultiBlock \
499 ParticleReader \
500 RGrid \
501 SGrid \
502 SimpleView \
503 Slider \
504 Slider2D \
505 SpecularSpheres \
506 TubesWithVaryingRadiusAndColors \
507 finance ; do
508         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
509 done
510
511 # Install test binaries
512 for f in build/bin/*Tests build/bin/Test*; do
513         install $f $RPM_BUILD_ROOT%{_bindir}
514 done
515
516 %if %{with java}
517 install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
518 %endif
519 install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
520
521 # unwanted doxygen files and misplaced verdict docs
522 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}}
523
524 %clean
525 rm -rf $RPM_BUILD_ROOT
526
527 %post   -p /sbin/ldconfig
528 %postun -p /sbin/ldconfig
529
530 %post   qt -p /sbin/ldconfig
531 %postun qt -p /sbin/ldconfig
532
533 %post   java -p /sbin/ldconfig
534 %postun java -p /sbin/ldconfig
535
536 %post   python3 -p /sbin/ldconfig
537 %postun python3 -p /sbin/ldconfig
538
539 %post   tcl -p /sbin/ldconfig
540 %postun tcl -p /sbin/ldconfig
541
542 %files
543 %defattr(644,root,root,755)
544 %doc README.md vtkBanner.gif vtkLogo.ico Wrapping/Tools/README*
545 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
546 %dir %{_libdir}/vtk
547 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
548 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
549 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
550 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
551 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
552 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
553 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
554 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
555 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
556 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
557 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
558 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
559 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
560 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
561 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
562 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
563 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
564 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
565 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
566 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
567 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
568 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
569 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
570 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
571 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
572 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
573 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
574 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
575 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
576 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
577 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
578 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
579 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
580 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
581 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
582 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
583 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
584 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
585 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
586 %if %{with java}
587 %exclude %{_libdir}/vtk/libvtk*Java.so.1
588 %endif
589 %exclude %{_libdir}/vtk/libvtk*Python3?D.so.1
590 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so.1
591
592 %files devel
593 %defattr(644,root,root,755)
594 %doc Utilities/Upgrading/*
595 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
596 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
597 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
598 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
599 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
600 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
601 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
602 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
603 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
604 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
605 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
606 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
607 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
608 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
609 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
610 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
611 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
612 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
613 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
614 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
615 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
616 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
617 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
618 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
619 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
620 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
621 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
622 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
623 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
624 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
625 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
626 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
627 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
628 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
629 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
630 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
631 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
632 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
633 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
634 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
635 %if %{with java}
636 %exclude %{_libdir}/vtk/libvtk*Java.so
637 %endif
638 %exclude %{_libdir}/vtk/libvtk*Python3?D.so
639 %exclude %{_libdir}/vtk/libvtkWrappingPython3?Core.so
640 %{_libdir}/vtk/libvtkWrappingTools.a
641 %dir %{_includedir}/vtk
642 %{_includedir}/vtk/VPIC
643 %{_includedir}/vtk/DICOM*.h
644 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
645 %{_includedir}/vtk/vtkgl2ps
646 %{_includedir}/vtk/vtkkwiml
647 %{_includedir}/vtk/vtklibharu
648 %{_includedir}/vtk/vtkmetaio
649 %{_includedir}/vtk/vtksys
650 %{_includedir}/vtk/vtkverdict
651 %{_includedir}/vtk/vtkxdmf2
652 %{_includedir}/vtk/vtk*.h
653 %{_includedir}/vtk/vtk*.txx
654 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
655 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
656 %if %{with java}
657 %exclude %{_includedir}/vtk/vtkJavaUtil.h
658 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
659 %endif
660 %exclude %{_includedir}/vtk/vtkPython*.h
661 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
662 %exclude %{_includedir}/vtk/vtkQt*.h
663 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
664 %exclude %{_includedir}/vtk/vtkTk*.h
665 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
666 %{_libdir}/cmake/vtk
667
668 %files qt
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
671 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
672 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
673 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
674 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
675
676 %files qt-devel
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
679 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
680 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
681 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
682 %{_includedir}/vtk/QFilterTreeProxyModel.h
683 %{_includedir}/vtk/QVTK*.h
684 %{_includedir}/vtk/vtkEventQtSlotConnect.h
685 %{_includedir}/vtk/vtkGUISupportQt*.h
686 %{_includedir}/vtk/vtkQImageToImageSource.h
687 %{_includedir}/vtk/vtkQt*.h
688 %{_includedir}/vtk/vtkRenderingQtModule.h
689 %{_includedir}/vtk/vtkViewsQtModule.h
690
691 %if %{with java}
692 %files java
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
695 %attr(755,root,root) %{_bindir}/vtkParseJava
696 %attr(755,root,root) %{_bindir}/vtkWrapJava
697 # common library
698 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
699 # java modules
700 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
701 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
702 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
703 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
704 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
705 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
706 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
707 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
708 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
709 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
710 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
711 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
712 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
713 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
714 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
715 %{_libdir}/vtk/vtk.jar
716
717 %files java-devel
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
720 %{_includedir}/vtk/vtkJavaUtil.h
721 %{_includedir}/vtk/vtkWrappingJavaModule.h
722 %endif
723
724 %files python3
725 %defattr(644,root,root,755)
726 %doc Wrapping/Python/README*
727 %attr(755,root,root) %{_bindir}/vtkWrapPython
728 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
729 %attr(755,root,root) %{_bindir}/vtkpython
730 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
731 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
732 # RenderingMatplotlib requires PythonInterpreter
733 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
734 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.1.so
735 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
736 %dir %{py3_sitedir}/vtk
737 %{py3_sitedir}/vtk/*.py[co]
738 %dir %{py3_sitedir}/vtk/gtk
739 %{py3_sitedir}/vtk/gtk/*.py[co]
740 %dir %{py3_sitedir}/vtk/numpy_interface
741 %{py3_sitedir}/vtk/numpy_interface/*.py[co]
742 %dir %{py3_sitedir}/vtk/qt
743 %{py3_sitedir}/vtk/qt/*.py[co]
744 %dir %{py3_sitedir}/vtk/qt4
745 %{py3_sitedir}/vtk/qt4/*.py[co]
746 %dir %{py3_sitedir}/vtk/test
747 %{py3_sitedir}/vtk/test/*.py[co]
748 %dir %{py3_sitedir}/vtk/tk
749 %{py3_sitedir}/vtk/tk/*.py[co]
750 %dir %{py3_sitedir}/vtk/util
751 %{py3_sitedir}/vtk/util/*.py[co]
752 %dir %{py3_sitedir}/vtk/wx
753 %{py3_sitedir}/vtk/wx/*.py[co]
754 %attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
755
756 %files python3-devel
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python3?D.so
759 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
760 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
761 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython3?Core.so
762 %{_includedir}/vtk/PyVTK*.h
763 %{_includedir}/vtk/vtkPython*.h
764
765 %files tcl
766 %defattr(644,root,root,755)
767 %doc Wrapping/Tcl/README*
768 %attr(755,root,root) %{_bindir}/vtkWrapTcl
769 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
770 %attr(755,root,root) %{_bindir}/vtk
771 %{_datadir}/tcl%{tcl_version}/vtk
772
773 %files tcl-devel
774 %defattr(644,root,root,755)
775 %{_includedir}/vtk/vtkTcl*.h
776 %{_includedir}/vtk/vtkTk*.h
777
778 %files test-suite
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_bindir}/*Tests
781 %attr(755,root,root) %{_bindir}/Test*
782
783 %files examples
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_bindir}/AmbientSpheres
786 %attr(755,root,root) %{_bindir}/Arrays
787 %attr(755,root,root) %{_bindir}/Cone
788 %attr(755,root,root) %{_bindir}/Cone2
789 %attr(755,root,root) %{_bindir}/Cone3
790 %attr(755,root,root) %{_bindir}/Cone4
791 %attr(755,root,root) %{_bindir}/Cone5
792 %attr(755,root,root) %{_bindir}/Cone6
793 %attr(755,root,root) %{_bindir}/Cube
794 %attr(755,root,root) %{_bindir}/Cylinder
795 %attr(755,root,root) %{_bindir}/DiffuseSpheres
796 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
797 %attr(755,root,root) %{_bindir}/Medical1
798 %attr(755,root,root) %{_bindir}/Medical2
799 %attr(755,root,root) %{_bindir}/Medical3
800 %attr(755,root,root) %{_bindir}/Medical4
801 %attr(755,root,root) %{_bindir}/MultiBlock
802 %attr(755,root,root) %{_bindir}/RGrid
803 %attr(755,root,root) %{_bindir}/SGrid
804 %attr(755,root,root) %{_bindir}/SimpleView
805 %attr(755,root,root) %{_bindir}/SpecularSpheres
806 %attr(755,root,root) %{_bindir}/finance
807 %attr(755,root,root) %{_bindir}/BalloonWidget
808 %attr(755,root,root) %{_bindir}/BandedContours
809 %attr(755,root,root) %{_bindir}/Delaunay3D
810 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
811 %attr(755,root,root) %{_bindir}/DumpXMLFile
812 %attr(755,root,root) %{_bindir}/FilledContours
813 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
814 %attr(755,root,root) %{_bindir}/GPURenderDemo
815 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
816 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
817 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
818 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
819 %attr(755,root,root) %{_bindir}/ImageSlicing
820 %attr(755,root,root) %{_bindir}/LabeledMesh
821 %attr(755,root,root) %{_bindir}/ParticleReader
822 %attr(755,root,root) %{_bindir}/Slider
823 %attr(755,root,root) %{_bindir}/Slider2D
824 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
825 %{_examplesdir}/%{name}-%{version}
826
827 %files data
828 %defattr(644,root,root,755)
829 %dir %{_datadir}/vtk-8.1
830 %{_datadir}/vtk-8.1/Data
This page took 0.115881 seconds and 4 git commands to generate.