]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- started update to 8.2.0
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5 # - CUDA for Accelerators/Piston (on bcond)
6 # - NVCtrlLib for Rendering/OpenGL (on bcond)
7 # - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8 # - python bcond?
9 #
10 # Conditional build
11 %bcond_without  java            # Java wrappers
12 %bcond_without  ffmpeg          # FFMPEG .avi saving support
13 %bcond_with     doc             # do not build and package doxygen documentation
14 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
15 %bcond_with     system_gl2ps    # use system gl2ps (VTK currently is carrying local modifications to gl2ps)
16
17 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
18 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
19 Name:           vtk
20 Version:        8.2.0
21 Release:        0.1
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://www.vtk.org/files/release/8.2/VTK-%{version}.tar.gz
25 # Source0-md5:  8af3307da0fc2ef8cafe4a312b821111
26 Source1:        http://www.vtk.org/files/release/8.2/VTKData-%{version}.tar.gz
27 # Source1-md5:  a6eab7bc02cee1376ee69243dde373ce
28 Patch0:         vtk-abi.patch
29 Patch1:         gcc10.patch
30 Patch2:         proj6_compat.patch
31 Patch3:         qt-5.15.patch
32 Patch4:         python-3.8.patch
33 Patch5:         link.patch
34 URL:            http://www.vtk.org/
35 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  Qt5Core-devel
39 BuildRequires:  Qt5Designer-devel
40 BuildRequires:  Qt5Gui-devel
41 BuildRequires:  Qt5Network-devel
42 BuildRequires:  Qt5OpenGL-devel
43 BuildRequires:  Qt5Sql-devel
44 BuildRequires:  Qt5WebKit-devel
45 BuildRequires:  Qt5X11Extras-devel
46 BuildRequires:  Qt5XmlPatterns-devel
47 BuildRequires:  Qt5UiTools-devel
48 BuildRequires:  R
49 BuildRequires:  boost-devel >= 1.39
50 BuildRequires:  cmake >= 2.8.8
51 %{?with_doc:BuildRequires:      doxygen}
52 BuildRequires:  expat-devel
53 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
54 BuildRequires:  fontconfig-devel
55 BuildRequires:  freetype-devel >= 2
56 BuildRequires:  gdal-devel
57 %{?with_system_gl2ps:BuildRequires:     gl2ps-devel >= 1.3.8}
58 BuildRequires:  gnuplot
59 BuildRequires:  graphviz
60 BuildRequires:  hdf5-devel
61 %if %{with java}
62 BuildRequires:  jdk >= 1.5
63 BuildRequires:  jpackage-utils
64 %endif
65 BuildRequires:  jsoncpp-devel
66 BuildRequires:  libharu-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libogg-devel
69 BuildRequires:  libpng-devel
70 BuildRequires:  libstdc++-devel
71 BuildRequires:  libtheora-devel
72 BuildRequires:  libtiff-devel
73 BuildRequires:  libxml2-devel >= 2
74 BuildRequires:  lz4-devel
75 BuildRequires:  motif-devel
76 BuildRequires:  mysql-devel
77 BuildRequires:  netcdf-cxx-devel >= 4
78 # some code using it exists (Domains/Chemistry), but is not included in cmakefiles
79 #BuildRequires: openqube-devel
80 BuildRequires:  perl-base
81 BuildRequires:  postgresql-devel
82 BuildRequires:  proj-devel >= 6.0
83 BuildRequires:  python-devel >= 2
84 BuildRequires:  python-sip-devel
85 BuildRequires:  qt5-build >= 4.5.0
86 BuildRequires:  qt5-qmake >= 4.5.0
87 BuildRequires:  rpmbuild(macros) >= 1.605
88 BuildRequires:  sip
89 BuildRequires:  sip-PyQt5
90 BuildRequires:  tcl-devel
91 BuildRequires:  tk-devel
92 BuildRequires:  unixODBC-devel
93 BuildRequires:  wget
94 BuildRequires:  xorg-lib-libICE-devel
95 BuildRequires:  xorg-lib-libSM-devel
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xorg-lib-libXScrnSaver-devel
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXft-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 BuildRequires:  zlib-devel
102 BuildConflicts: libXNVCtrl-devel
103 %{?with_system_gl2ps:Requires:  gl2ps >= 1.3.8}
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         skip_post_check_so      lib.*Python.*\.so.*
107
108 %description
109 The Visualization ToolKit (VTK) is an object oriented software system
110 for 3D computer graphics, image processing, and visualization. VTK
111 includes a textbook, a C++ class library, and several interpreted
112 interface layers including Tcl/Tk, Java, and Python. VTK supports a
113 wide variety of visualization algorithms including scalar, vector,
114 tensor, texture, and volumetric methods. It also supports advanced
115 modeling techniques like implicit modeling, polygon reduction, mesh
116 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
117 dozens of imaging algorithms have been integrated into the system.
118 This allows mixing 2D imaging / 3D graphics algorithms and data.
119
120 %description -l pl.UTF-8
121 Visualization TookKit (VTK) to obiektowo zorientowany system
122 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
123 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
124 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
125 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
126 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
127 Obsługuje także zaawansowane techniki modelowania, takie jak
128 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
129 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
130 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
131 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
132
133 %package devel
134 Summary:        VTK header files for building C++ code
135 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
136 Group:          Development
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       libstdc++-devel
139
140 %description devel
141 This provides the VTK header files required to compile C++ programs
142 that use VTK to do 3D visualisation.
143
144 %description devel -l pl.UTF-8
145 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
146 C++ używających VTK do wizualizacji 3D.
147
148 %package qt
149 Summary:        Qt5 bindings and Qt5 Designer plugin for VTK
150 Summary(pl.UTF-8):      Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK
151 Group:          X11/Libraries
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       Qt5Core >= 4.5.0
154 Requires:       Qt5Gui >= 4.5.0
155 Requires:       Qt5Network >= 4.5.0
156 Requires:       Qt5OpenGL >= 4.5.0
157 Requires:       Qt5Sql >= 4.5.0
158 Requires:       Qt5WebKit >= 4.5.0
159
160 %description qt
161 Qt5 bindings and Qt5 Designer plugin for VTK.
162
163 %description qt -l pl.UTF-8
164 Wiązania Qt5 oraz wtyczka Qt5 Designera do VTK.
165
166 %package qt-devel
167 Summary:        Header files for VTK Qt5 bindings
168 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt5` do VTK
169 Group:          X11/Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       %{name}-qt = %{version}-%{release}
172 Requires:       Qt5Core-devel >= 4.5.0
173 Requires:       Qt5Gui-devel >= 4.5.0
174 Requires:       Qt5OpenGL-devel >= 4.5.0
175 Requires:       Qt5Sql-devel >= 4.5.0
176
177 %description qt-devel
178 Header files for VTK Qt bindings.
179
180 %description qt-devel -l pl.UTF-8
181 Pliki nagłówkowe wiązań Qt do VTK.
182
183 %package java
184 Summary:        Java bindings for VTK
185 Summary(pl.UTF-8):      Wiązania Javy do VTK
186 Group:          Development/Languages/Java
187 Requires:       %{name} = %{version}-%{release}
188 # or separate qt parts?
189 Requires:       %{name}-qt = %{version}-%{release}
190
191 %description java
192 This package contains Java bindings for VTK.
193
194 %description java -l pl.UTF-8
195 Ten pakiet zawiera wiązania Javy do VTK.
196
197 %package java-devel
198 Summary:        Header files for Java VTK binding
199 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
200 Group:          Development/Libraries
201 Requires:       %{name}-devel = %{version}-%{release}
202 Requires:       %{name}-java = %{version}-%{release}
203 # <jni.h>
204 Requires:       jdk
205
206 %description java-devel
207 Header files for Java VTK binding.
208
209 %description java-devel -l pl.UTF-8
210 Pliki nagłówkowe wiązania Javy do VTK.
211
212 %package python
213 Summary:        Python bindings for VTK
214 Summary(pl.UTF-8):      Wiązania Pythona do VTK
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217 # or separate qt parts again?
218 Requires:       %{name}-qt = %{version}-%{release}
219 Obsoletes:      vtk-python-qt < 6.0.0-1
220 Obsoletes:      vtk-python-sip < 6.0.0-1
221
222 %description python
223 This package contains Python bindings for VTK.
224
225 %description python -l pl.UTF-8
226 Ten pakiet zawiera wiązania Pythona do VTK.
227
228 %package python-devel
229 Summary:        Header files for Python VTK binding
230 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona do VTK
231 Group:          Development/Libraries
232 Requires:       %{name}-devel = %{version}-%{release}
233 Requires:       %{name}-python = %{version}-%{release}
234 Requires:       python-devel
235
236 %description python-devel
237 Header files for Python VTK binding.
238
239 %description python-devel -l pl.UTF-8
240 Pliki nagłówkowe wiązania Pythona do VTK.
241
242 %package tcl
243 Summary:        Tcl bindings for VTK
244 Summary(pl.UTF-8):      Wiązania języka Tcl do VTK
245 Group:          Libraries
246 Requires:       %{name} = %{version}-%{release}
247 # or separate qt parts?
248 Requires:       %{name}-qt = %{version}-%{release}
249
250 %description tcl
251 This package contains Tcl bindings for VTK.
252
253 %description tcl -l pl.UTF-8
254 Ten pakiet zawiera wiązania języka Tcl do VTK.
255
256 %package tcl-devel
257 Summary:        Header files for Tcl VTK bindings
258 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania języka Tcl do VTK
259 Group:          Development/Libraries
260 Requires:       %{name}-devel = %{version}-%{release}
261 Requires:       %{name}-tcl = %{version}-%{release}
262 Requires:       tcl-devel
263 Requires:       tk-devel
264
265 %description tcl-devel
266 Header files for Tcl VTK bindings.
267
268 %description tcl-devel -l pl.UTF-8
269 Pliki nagłówkowe wiązania języka Tcl do VTK.
270
271 %package examples
272 Summary:        C++, Tcl and Python example programs/scripts for VTK
273 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
274 Group:          Development/Libraries
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       %{name}-data = %{version}-%{release}
277
278 %description examples
279 This package contains all the examples from the VTK source. To compile
280 the C++ examples you will need to install the vtk-devel package as
281 well. The Python and Tcl examples can be run with the corresponding
282 packages (vtk-python, vtk-tcl).
283
284 %description examples -l pl.UTF-8
285 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
286 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
287 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
288 (vtk-python, vtk-tcl).
289
290 %package test-suite
291 Summary:        Test programs for VTK
292 Summary(pl.UTF-8):      Programy testowe dla VTK
293 Group:          Development/Libraries
294 Requires:       %{name} = %{version}-%{release}
295 Requires:       %{name}-data = %{version}-%{release}
296
297 %description test-suite
298 This package contains all testing programs from the VTK source. The
299 source code of these programs can be found in the vtk-examples
300 package.
301
302 %description test-suite -l pl.UTF-8
303 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
304 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
305
306 %package data
307 Summary:        Data files for VTK
308 Summary(pl.UTF-8):      Pliki danych dla VTK
309 Group:          Development/Libraries
310 %if "%{_rpmversion}" >= "5"
311 BuildArch:      noarch
312 %endif
313
314 %description data
315 This package contains all the data from the VTKData repository. These
316 data are required to run various examples from the vtk-examples
317 package.
318
319 %description data -l pl.UTF-8
320 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
321 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
322
323 %prep
324 %setup -q -n VTK-%{version} -b 1
325 %patch0 -p1
326 %patch1 -p1
327 %patch2 -p1
328 %patch3 -p1
329 %patch4 -p1
330 %patch5 -p1
331
332 # Replace relative path ../../../VTKData with destination filesystem path
333 grep -Erl '(\.\./)+VTKData' Examples | xargs \
334   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-8.1,g'
335
336 # Save an unbuilt copy of the Example's sources for %doc
337 mkdir vtk-examples
338 cp -a Examples vtk-examples
339 # Don't ship Win32 examples
340 %{__rm} -r vtk-examples/Examples/GUI/Win32
341 find vtk-examples -type f | xargs chmod -R a-x
342
343 %build
344 export CFLAGS="%{rpmcflags} -D_UNICODE -DHAVE_UINTPTR_T"
345 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE -DHAVE_UINTPTR_T"
346 %if %{with java}
347 export JAVA_HOME=%{java_home}
348 %ifarch x32
349 # getting "java.lang.OutOfMemoryError: Java heap space" during the build
350 export JAVA_TOOL_OPTIONS=-Xmx2048m
351 %endif
352 %endif
353
354 # handle cmake & ccache
355 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
356 # ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
357 if [[ "%{__cc}" = *ccache* ]]; then
358         cc="%{__cc}"
359         cxx="%{__cxx}"
360         ccache="
361         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
362         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
363         -DCMAKE_ASM_COMPILER="${cc#ccache }" \
364         "
365 else
366         ccache="
367         -DCMAKE_C_COMPILER="%{__cc}" \
368         -DCMAKE_CXX_COMPILER="%{__cxx}" \
369         -DCMAKE_ASM_COMPILER="%{__cc}" \
370         "
371 fi
372
373 mkdir -p build
374 cd build
375 %cmake .. \
376         $ccache \
377         -Wno-dev \
378         %{cmake_on_off doc DBUILD_DOCUMENTATION} \
379         -DBUILD_EXAMPLES:BOOL=ON \
380         -DBUILD_SHARED_LIBS:BOOL=ON \
381         -DBUILD_TESTING:BOOL=ON \
382         -DCMAKE_SKIP_RPATH:BOOL=ON \
383         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
384         -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
385         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
386         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
387         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
388         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
389         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
390         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
391         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
392         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
393         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
394         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
395         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
396         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
397         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt5/plugins/designer \
398         -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
399         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
400         -DVTK_WRAP_PYTHON:BOOL=ON \
401         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
402         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
403         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
404         -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
405         -DVTK_USE_SYSTEM_LIBHARU:BOOL=OFF \
406         %{!?with_system_gl2ps:-DVTK_USE_SYSTEM_GL2PS:BOOL=OFF} \
407 %if %{with java}
408         -DVTK_WRAP_JAVA:BOOL=ON \
409         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
410         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
411         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
412 %else
413         -DVTK_WRAP_JAVA:BOOL=OFF \
414 %endif
415         -DVTK_WRAP_PYTHON:BOOL=ON \
416         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
417         -DVTK_Group_Imaging:BOOL=ON \
418         -DVTK_Group_Qt:BOOL=ON \
419         -DVTK_Group_Rendering:BOOL=ON \
420         -DVTK_Group_StandAlone:BOOL=ON \
421         -DVTK_Group_Tk:BOOL=ON \
422         -DVTK_Group_Views:BOOL=ON \
423         -DModule_vtkFiltersReebGraph:BOOL=ON \
424         %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
425         -DModule_vtkIOGDAL:BOOL=ON \
426         -DModule_vtkIOGeoJSON:BOOL=ON \
427         -DModule_vtkIOMySQL:BOOL=ON \
428         -DModule_vtkIOODBC:BOOL=ON \
429         -DModule_vtkIOParallelExodus:BOOL=ON \
430         -DModule_vtkIOParallelLSDyna:BOOL=ON \
431         -DModule_vtkIOPostgreSQL:BOOL=ON \
432         -DModule_vtkIOVPIC:BOOL=ON \
433         -DModule_vtkIOXdmf2:BOOL=ON \
434         -DModule_vtkInfovisBoost:BOOL=ON \
435         -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
436         -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
437         -DModule_vtkRenderingMatplotlib:BOOL=ON \
438         -DModule_vtkRenderingParallel:BOOL=ON
439 # TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
440 # TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
441 # TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
442 # TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
443 # TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
444 # TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
445
446 %{__make}
447 %{?with_doc:%{__make} DoxygenDoc}
448
449 %install
450 rm -rf $RPM_BUILD_ROOT
451 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
452
453 %{__make} -C build install \
454         DESTDIR=$RPM_BUILD_ROOT
455
456 # ld config
457 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
458
459 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
460         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-8.1/$f
461 done
462
463 # Install examples
464 for f in \
465 AmbientSpheres \
466 Arrays \
467 BalloonWidget \
468 BandedContours \
469 Cone \
470 Cone2 \
471 Cone3 \
472 Cone4 \
473 Cone5 \
474 Cone6 \
475 Cube \
476 Cylinder \
477 Delaunay3D \
478 Delaunay3DAlpha \
479 DiffuseSpheres \
480 DumpXMLFile \
481 FilledContours \
482 FixedPointVolumeRayCastMapperCT \
483 GPURenderDemo \
484 Generate2DAMRDataSetWithPulse \
485 Generate3DAMRDataSetWithPulse \
486 GenerateCubesFromLabels \
487 GenerateModelsFromLabels \
488 HierarchicalBoxPipeline \
489 ImageSlicing \
490 LabeledMesh \
491 Medical1 \
492 Medical2 \
493 Medical3 \
494 Medical4 \
495 MultiBlock \
496 ParticleReader \
497 RGrid \
498 SGrid \
499 SimpleView \
500 Slider \
501 Slider2D \
502 SpecularSpheres \
503 TubesWithVaryingRadiusAndColors \
504 finance ; do
505         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
506 done
507
508 # Install test binaries
509 for f in build/bin/*Tests build/bin/Test*; do
510         install $f $RPM_BUILD_ROOT%{_bindir}
511 done
512
513 %if %{with java}
514 install -p build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
515 %endif
516 install -p build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
517
518 # unwanted doxygen files and misplaced verdict docs
519 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-*/{doxygen,verdict}}
520
521 # only *.pyc are built by default, add *.pyo
522 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
523 %py_postclean
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %post   -p /sbin/ldconfig
529 %postun -p /sbin/ldconfig
530
531 %post   qt -p /sbin/ldconfig
532 %postun qt -p /sbin/ldconfig
533
534 %post   java -p /sbin/ldconfig
535 %postun java -p /sbin/ldconfig
536
537 %post   python -p /sbin/ldconfig
538 %postun python -p /sbin/ldconfig
539
540 %post   tcl -p /sbin/ldconfig
541 %postun tcl -p /sbin/ldconfig
542
543 %files
544 %defattr(644,root,root,755)
545 %doc README.md vtkBanner.gif vtkLogo.ico Wrapping/Tools/README*
546 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
547 %dir %{_libdir}/vtk
548 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
549 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
550 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
551 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so.1
552 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
553 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
554 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
555 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
556 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
557 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
558 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
559 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
560 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
561 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
562 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
563 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so.1
564 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
565 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
566 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
567 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so.1
568 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
569 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
570 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
571 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so.1
572 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
573 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so.1
574 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
575 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
576 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
577 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
578 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
579 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
580 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
581 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so.1
582 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so.1
583 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
584 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
585 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
586 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
587 %if %{with java}
588 %exclude %{_libdir}/vtk/libvtk*Java.so.1
589 %endif
590 %exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
591 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
592
593 %files devel
594 %defattr(644,root,root,755)
595 %doc Utilities/Upgrading/*
596 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
597 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
598 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
599 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
600 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2.so
601 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
602 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
603 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
604 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
605 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
606 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
607 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
608 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
609 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
610 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
611 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
612 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL2.so
613 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
614 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
615 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
616 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PSOpenGL2.so
617 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
618 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
619 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
620 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL2.so
621 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
622 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL2.so
623 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
624 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
625 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
626 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
627 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
628 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
629 %attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
630 %attr(755,root,root) %{_libdir}/vtk/libvtkgl2ps.so
631 %attr(755,root,root) %{_libdir}/vtk/libvtklibharu.so
632 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
633 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
634 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
635 %attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
636 %if %{with java}
637 %exclude %{_libdir}/vtk/libvtk*Java.so
638 %endif
639 %exclude %{_libdir}/vtk/libvtk*Python2?D.so
640 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
641 %{_libdir}/vtk/libvtkWrappingTools.a
642 %dir %{_includedir}/vtk
643 %{_includedir}/vtk/VPIC
644 %{_includedir}/vtk/DICOM*.h
645 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
646 %{_includedir}/vtk/vtkgl2ps
647 %{_includedir}/vtk/vtkkwiml
648 %{_includedir}/vtk/vtklibharu
649 %{_includedir}/vtk/vtkmetaio
650 %{_includedir}/vtk/vtksys
651 %{_includedir}/vtk/vtkverdict
652 %{_includedir}/vtk/vtkxdmf2
653 %{_includedir}/vtk/vtk*.h
654 %{_includedir}/vtk/vtk*.txx
655 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
656 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
657 %if %{with java}
658 %exclude %{_includedir}/vtk/vtkJavaUtil.h
659 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
660 %endif
661 %exclude %{_includedir}/vtk/vtkPython*.h
662 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
663 %exclude %{_includedir}/vtk/vtkQt*.h
664 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
665 %exclude %{_includedir}/vtk/vtkTk*.h
666 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
667 %{_libdir}/cmake/vtk
668
669 %files qt
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
672 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
673 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
674 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
675 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libQVTKWidgetPlugin.so
676
677 %files qt-devel
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
680 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
681 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
682 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
683 %{_includedir}/vtk/QFilterTreeProxyModel.h
684 %{_includedir}/vtk/QVTK*.h
685 %{_includedir}/vtk/vtkEventQtSlotConnect.h
686 %{_includedir}/vtk/vtkGUISupportQt*.h
687 %{_includedir}/vtk/vtkQImageToImageSource.h
688 %{_includedir}/vtk/vtkQt*.h
689 %{_includedir}/vtk/vtkRenderingQtModule.h
690 %{_includedir}/vtk/vtkViewsQtModule.h
691
692 %if %{with java}
693 %files java
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
696 %attr(755,root,root) %{_bindir}/vtkParseJava
697 %attr(755,root,root) %{_bindir}/vtkWrapJava
698 # common library
699 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
700 # java modules
701 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
702 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
703 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
704 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryOpenGL2Java.so
705 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
706 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
707 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
708 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
709 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
710 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
711 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
712 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
713 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
714 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
715 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
716 %{_libdir}/vtk/vtk.jar
717
718 %files java-devel
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
721 %{_includedir}/vtk/vtkJavaUtil.h
722 %{_includedir}/vtk/vtkWrappingJavaModule.h
723 %endif
724
725 %files python
726 %defattr(644,root,root,755)
727 %doc Wrapping/Python/README*
728 %attr(755,root,root) %{_bindir}/vtkWrapPython
729 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
730 %attr(755,root,root) %{_bindir}/vtkpython
731 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
732 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
733 # RenderingMatplotlib requires PythonInterpreter
734 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
735 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-8.1.so
736 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
737 %dir %{py_sitedir}/vtk
738 %{py_sitedir}/vtk/*.py[co]
739 %dir %{py_sitedir}/vtk/gtk
740 %{py_sitedir}/vtk/gtk/*.py[co]
741 %dir %{py_sitedir}/vtk/numpy_interface
742 %{py_sitedir}/vtk/numpy_interface/*.py[co]
743 %dir %{py_sitedir}/vtk/qt
744 %{py_sitedir}/vtk/qt/*.py[co]
745 %dir %{py_sitedir}/vtk/qt4
746 %{py_sitedir}/vtk/qt4/*.py[co]
747 %dir %{py_sitedir}/vtk/test
748 %{py_sitedir}/vtk/test/*.py[co]
749 %dir %{py_sitedir}/vtk/tk
750 %{py_sitedir}/vtk/tk/*.py[co]
751 %dir %{py_sitedir}/vtk/util
752 %{py_sitedir}/vtk/util/*.py[co]
753 %dir %{py_sitedir}/vtk/wx
754 %{py_sitedir}/vtk/wx/*.py[co]
755 %attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
756
757 %files python-devel
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
760 %attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
761 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
762 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
763 %{_includedir}/vtk/PyVTK*.h
764 %{_includedir}/vtk/vtkPython*.h
765
766 %files tcl
767 %defattr(644,root,root,755)
768 %doc Wrapping/Tcl/README*
769 %attr(755,root,root) %{_bindir}/vtkWrapTcl
770 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
771 %attr(755,root,root) %{_bindir}/vtk
772 %{_datadir}/tcl%{tcl_version}/vtk
773
774 %files tcl-devel
775 %defattr(644,root,root,755)
776 %{_includedir}/vtk/vtkTcl*.h
777 %{_includedir}/vtk/vtkTk*.h
778
779 %files test-suite
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_bindir}/*Tests
782 %attr(755,root,root) %{_bindir}/Test*
783
784 %files examples
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_bindir}/AmbientSpheres
787 %attr(755,root,root) %{_bindir}/Arrays
788 %attr(755,root,root) %{_bindir}/Cone
789 %attr(755,root,root) %{_bindir}/Cone2
790 %attr(755,root,root) %{_bindir}/Cone3
791 %attr(755,root,root) %{_bindir}/Cone4
792 %attr(755,root,root) %{_bindir}/Cone5
793 %attr(755,root,root) %{_bindir}/Cone6
794 %attr(755,root,root) %{_bindir}/Cube
795 %attr(755,root,root) %{_bindir}/Cylinder
796 %attr(755,root,root) %{_bindir}/DiffuseSpheres
797 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
798 %attr(755,root,root) %{_bindir}/Medical1
799 %attr(755,root,root) %{_bindir}/Medical2
800 %attr(755,root,root) %{_bindir}/Medical3
801 %attr(755,root,root) %{_bindir}/Medical4
802 %attr(755,root,root) %{_bindir}/MultiBlock
803 %attr(755,root,root) %{_bindir}/RGrid
804 %attr(755,root,root) %{_bindir}/SGrid
805 %attr(755,root,root) %{_bindir}/SimpleView
806 %attr(755,root,root) %{_bindir}/SpecularSpheres
807 %attr(755,root,root) %{_bindir}/finance
808 %attr(755,root,root) %{_bindir}/BalloonWidget
809 %attr(755,root,root) %{_bindir}/BandedContours
810 %attr(755,root,root) %{_bindir}/Delaunay3D
811 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
812 %attr(755,root,root) %{_bindir}/DumpXMLFile
813 %attr(755,root,root) %{_bindir}/FilledContours
814 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
815 %attr(755,root,root) %{_bindir}/GPURenderDemo
816 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
817 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
818 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
819 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
820 %attr(755,root,root) %{_bindir}/ImageSlicing
821 %attr(755,root,root) %{_bindir}/LabeledMesh
822 %attr(755,root,root) %{_bindir}/ParticleReader
823 %attr(755,root,root) %{_bindir}/Slider
824 %attr(755,root,root) %{_bindir}/Slider2D
825 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
826 %{_examplesdir}/%{name}-%{version}
827
828 %files data
829 %defattr(644,root,root,755)
830 %dir %{_datadir}/vtk-8.1
831 %{_datadir}/vtk-8.1/Data
This page took 0.183582 seconds and 3 git commands to generate.