]> git.pld-linux.org Git - packages/vtk.git/blob - vtk.spec
- started update to 6.1.0
[packages/vtk.git] / vtk.spec
1 # TODO:
2 # - check dependencies after upgrade to 6.1.0
3 # - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
4 # - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
5 # - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
6 # - CUDA for Accelerators/Piston (on bcond)
7 # - NVCtrlLib for Rendering/OpenGL (on bcond)
8 # - IO/GDAL? (seems not handled by main build system)
9 # - IO/ODBC? (VTK_USE_ODBC=ON)
10 # - Xdmf2? (not build by default?)
11 #
12 # Conditional build
13 %bcond_without  java            # Java wrappers
14 %bcond_without  ffmpeg          # FFMPEG .avi saving support
15 %bcond_with     OSMesa          # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
16 %bcond_with     system_proj     # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
17 #
18 Summary:        Toolkit for 3D computer graphics, image processing, and visualization
19 Summary(pl.UTF-8):      Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
20 Name:           vtk
21 Version:        6.1.0
22 Release:        0.1
23 License:        BSD
24 Group:          Libraries
25 Source0:        http://www.vtk.org/files/release/6.1/VTK-%{version}.tar.gz
26 # Source0-md5:  25e4dfb3bad778722dcaec80cd5dab7d
27 Source1:        http://www.vtk.org/files/release/6.1/VTKData-%{version}.tar.gz
28 # Source1-md5:  f82c8fe151279c0422ab8a6cfe991c94
29 Patch0:         %{name}-system-libs.patch
30 Patch1:         %{name}-install.patch
31 Patch2:         %{name}-chemistry.patch
32 URL:            http://www.vtk.org/
33 %{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
34 BuildRequires:  OpenGL-GLX-devel
35 BuildRequires:  OpenGL-devel
36 BuildRequires:  QtCore-devel >= 4.5.0
37 BuildRequires:  QtGui-devel >= 4.5.0
38 BuildRequires:  QtNetwork-devel >= 4.5.0
39 BuildRequires:  QtOpenGL-devel >= 4.5.0
40 BuildRequires:  QtSql-devel >= 4.5.0
41 BuildRequires:  QtWebKit-devel >= 4.5.0
42 BuildRequires:  QtXmlPatterns-devel >= 4.5.0
43 BuildRequires:  R
44 BuildRequires:  boost-devel >= 1.39
45 BuildRequires:  cmake >= 2.8.8
46 BuildRequires:  doxygen
47 BuildRequires:  eigen >= 2
48 BuildRequires:  expat-devel
49 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
50 BuildRequires:  fontconfig-devel
51 BuildRequires:  freetype-devel >= 2
52 BuildRequires:  gl2ps-devel >= 1.3.8
53 BuildRequires:  gnuplot
54 BuildRequires:  graphviz
55 BuildRequires:  hdf5-devel
56 %if %{with java}
57 BuildRequires:  jdk >= 1.5
58 BuildRequires:  jpackage-utils
59 %endif
60 BuildRequires:  jsoncpp-devel
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libogg-devel
63 BuildRequires:  libpng-devel
64 BuildRequires:  libstdc++-devel
65 BuildRequires:  libtheora-devel
66 BuildRequires:  libtiff-devel
67 BuildRequires:  libxml2-devel >= 2
68 BuildRequires:  motif-devel
69 BuildRequires:  mysql-devel
70 BuildRequires:  netcdf-devel >= 4
71 BuildRequires:  openqube-devel
72 BuildRequires:  postgresql-devel
73 %{?with_system_proj:BuildRequires:      proj-devel >= 4.3, proj-devel < 4.4}
74 BuildRequires:  python-devel
75 BuildRequires:  python-sip-devel
76 BuildRequires:  python-PyQt4-devel
77 BuildRequires:  qt4-build >= 4.5.0
78 BuildRequires:  rpmbuild(macros) >= 1.605
79 BuildRequires:  sip
80 BuildRequires:  tcl-devel
81 BuildRequires:  tk-devel
82 BuildRequires:  wget
83 BuildRequires:  xorg-lib-libICE-devel
84 BuildRequires:  xorg-lib-libSM-devel
85 BuildRequires:  xorg-lib-libX11-devel
86 BuildRequires:  xorg-lib-libXScrnSaver-devel
87 BuildRequires:  xorg-lib-libXext-devel
88 BuildRequires:  xorg-lib-libXft-devel
89 BuildRequires:  xorg-lib-libXt-devel
90 BuildRequires:  zlib-devel
91 Requires:       gl2ps >= 1.3.8
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         skip_post_check_so      lib.*Python.*\.so.*
95
96 %description
97 The Visualization ToolKit (VTK) is an object oriented software system
98 for 3D computer graphics, image processing, and visualization. VTK
99 includes a textbook, a C++ class library, and several interpreted
100 interface layers including Tcl/Tk, Java, and Python. VTK supports a
101 wide variety of visualization algorithms including scalar, vector,
102 tensor, texture, and volumetric methods. It also supports advanced
103 modeling techniques like implicit modeling, polygon reduction, mesh
104 smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
105 dozens of imaging algorithms have been integrated into the system.
106 This allows mixing 2D imaging / 3D graphics algorithms and data.
107
108 %description -l pl.UTF-8
109 Visualization TookKit (VTK) to obiektowo zorientowany system
110 oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
111 obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
112 kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
113 Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
114 metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
115 Obsługuje także zaawansowane techniki modelowania, takie jak
116 modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
117 przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
118 algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
119 na mieszanie algorytmów obrazowania 2D i grafiki 3D.
120
121 %package devel
122 Summary:        VTK header files for building C++ code
123 Summary(pl.UTF-8):      Pliki nagłówkowe VTK dla C++
124 Group:          Development
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       libstdc++-devel
127
128 %description devel
129 This provides the VTK header files required to compile C++ programs
130 that use VTK to do 3D visualisation.
131
132 %description devel -l pl.UTF-8
133 Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
134 C++ używających VTK do wizualizacji 3D.
135
136 %package qt
137 Summary:        Qt bindings and Qt Designer plugin for VTK
138 Summary(pl.UTF-8):      Wiązania Qt oraz wtyczka Qt Designera do VTK
139 Group:          X11/Libraries
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       QtCore >= 4.5.0
142 Requires:       QtGui >= 4.5.0
143 Requires:       QtNetwork >= 4.5.0
144 Requires:       QtOpenGL >= 4.5.0
145 Requires:       QtSql >= 4.5.0
146 Requires:       QtWebKit >= 4.5.0
147
148 %description qt
149 Qt bindings and Qt Designer plugin for VTK.
150
151 %description qt -l pl.UTF-8
152 Wiązania Qt oraz wtyczka Qt Designera do VTK.
153
154 %package qt-devel
155 Summary:        Header files for VTK Qt bindings
156 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Qt do VTK
157 Group:          X11/Development/Libraries
158 Requires:       %{name}-devel = %{version}-%{release}
159 Requires:       %{name}-qt = %{version}-%{release}
160 Requires:       QtCore-devel >= 4.5.0
161 Requires:       QtGui-devel >= 4.5.0
162 Requires:       QtOpenGL-devel >= 4.5.0
163 Requires:       QtSql-devel >= 4.5.0
164
165 %description qt-devel
166 Header files for VTK Qt bindings.
167
168 %description qt-devel -l pl.UTF-8
169 Pliki nagłówkowe wiązań Qt do VTK.
170
171 %package java
172 Summary:        Java bindings for VTK
173 Summary(pl.UTF-8):      Wiązania Javy do VTK
174 Group:          Development/Languages/Java
175 Requires:       %{name} = %{version}-%{release}
176 # or separate qt parts?
177 Requires:       %{name}-qt = %{version}-%{release}
178
179 %description java
180 This package contains Java bindings for VTK.
181
182 %description java -l pl.UTF-8
183 Ten pakiet zawiera wiązania Javy do VTK.
184
185 %package java-devel
186 Summary:        Header files for Java VTK binding
187 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Javy do VTK
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}-%{release}
190 Requires:       %{name}-java = %{version}-%{release}
191 # <jni.h>
192 Requires:       jdk
193
194 %description java-devel
195 Header files for Java VTK binding.
196
197 %description java-devel -l pl.UTF-8
198 Pliki nagłówkowe wiązania Javy do VTK.
199
200 %package python
201 Summary:        Python bindings for VTK
202 Summary(pl.UTF-8):      Wiązania Pythona do VTK
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205 # or separate qt parts again?
206 Requires:       %{name}-qt = %{version}-%{release}
207 Obsoletes:      vtk-python-qt < 6.0.0-1
208 Obsoletes:      vtk-python-sip < 6.0.0-1
209
210 %description python
211 This package contains Python bindings for VTK.
212
213 %description python -l pl.UTF-8
214 Ten pakiet zawiera wiązania Pythona do VTK.
215
216 %package python-devel
217 Summary:        Header files for Python VTK binding
218 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania Pythona do VTK
219 Group:          Development/Libraries
220 Requires:       %{name}-devel = %{version}-%{release}
221 Requires:       %{name}-python = %{version}-%{release}
222 Requires:       python-devel
223
224 %description python-devel
225 Header files for Python VTK binding.
226
227 %description python-devel -l pl.UTF-8
228 Pliki nagłówkowe wiązania Pythona do VTK.
229
230 %package tcl
231 Summary:        Tcl bindings for VTK
232 Summary(pl.UTF-8):      Wiązania języka Tcl do VTK
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235 # or separate qt parts?
236 Requires:       %{name}-qt = %{version}-%{release}
237
238 %description tcl
239 This package contains Tcl bindings for VTK.
240
241 %description tcl -l pl.UTF-8
242 Ten pakiet zawiera wiązania języka Tcl do VTK.
243
244 %package tcl-devel
245 Summary:        Header files for Tcl VTK bindings
246 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania języka Tcl do VTK
247 Group:          Development/Libraries
248 Requires:       %{name}-devel = %{version}-%{release}
249 Requires:       %{name}-tcl = %{version}-%{release}
250 Requires:       tcl-devel
251 Requires:       tk-devel
252
253 %description tcl-devel
254 Header files for Tcl VTK bindings.
255
256 %description tcl-devel -l pl.UTF-8
257 Pliki nagłówkowe wiązania języka Tcl do VTK.
258
259 %package examples
260 Summary:        C++, Tcl and Python example programs/scripts for VTK
261 Summary(pl.UTF-8):      Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
262 Group:          Development/Libraries
263 Requires:       %{name} = %{version}-%{release}
264 Requires:       %{name}-data = %{version}-%{release}
265
266 %description examples
267 This package contains all the examples from the VTK source. To compile
268 the C++ examples you will need to install the vtk-devel package as
269 well. The Python and Tcl examples can be run with the corresponding
270 packages (vtk-python, vtk-tcl).
271
272 %description examples -l pl.UTF-8
273 Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
274 przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
275 Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
276 (vtk-python, vtk-tcl).
277
278 %package test-suite
279 Summary:        Test programs for VTK
280 Summary(pl.UTF-8):      Programy testowe dla VTK
281 Group:          Development/Libraries
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       %{name}-data = %{version}-%{release}
284
285 %description test-suite
286 This package contains all testing programs from the VTK source. The
287 source code of these programs can be found in the vtk-examples
288 package.
289
290 %description test-suite -l pl.UTF-8
291 Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
292 źródłowy tych programów można znaleźć w pakiecie vtk-examples.
293
294 %package data
295 Summary:        Data files for VTK
296 Summary(pl.UTF-8):      Pliki danych dla VTK
297 Group:          Development/Libraries
298 %if "%{_rpmversion}" >= "5"
299 BuildArch:      noarch
300 %endif
301
302 %description data
303 This package contains all the data from the VTKData repository. These
304 data are required to run various examples from the vtk-examples
305 package.
306
307 %description data -l pl.UTF-8
308 Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
309 potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
310
311 %prep
312 %setup -q -n VTK-%{version} -b 1
313 %patch0 -p1
314 %patch1 -p1
315 %patch2 -p1
316
317 # Replace relative path ../../../VTKData with destination filesystem path
318 grep -Erl '(\.\./)+VTKData' Examples | xargs \
319   perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-6.1,g'
320
321 # Save an unbuilt copy of the Example's sources for %doc
322 mkdir vtk-examples
323 cp -a Examples vtk-examples
324 # Don't ship Win32 examples
325 %{__rm} -r vtk-examples/Examples/GUI/Win32
326 find vtk-examples -type f | xargs chmod -R a-x
327
328 %build
329 export CFLAGS="%{rpmcflags} -D_UNICODE"
330 export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
331 %if %{with java}
332 export JAVA_HOME=%{java_home}
333 %endif
334
335 mkdir build
336 cd build
337 %cmake .. \
338         -DBUILD_DOCUMENTATION:BOOL=ON \
339         -DBUILD_EXAMPLES:BOOL=ON \
340         -DBUILD_SHARED_LIBS:BOOL=ON \
341         -DBUILD_TESTING:BOOL=ON \
342         -DCMAKE_C_COMPILER:PATH="%{__cc}" \
343         -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
344         -DCMAKE_SKIP_RPATH:BOOL=ON \
345         -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
346         -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
347         -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
348         -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
349         -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
350         -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
351         -DTK_INCLUDE_PATH:PATH=%{_includedir} \
352         -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
353         -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk-6.1 \
354         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
355         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
356         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
357         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
358         -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
359         -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
360         -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{py_sitedir} \
361         -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
362         %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
363         -DVTK_WRAP_PYTHON:BOOL=ON \
364         -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
365         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
366         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
367         -DVTK_USE_RENDERING:BOOL=ON \
368         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
369         %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
370 %if %{with java}
371         -DVTK_WRAP_JAVA:BOOL=ON \
372         -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
373         -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
374         -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
375 %else
376         -DVTK_WRAP_JAVA:BOOL=OFF \
377 %endif
378         -DVTK_WRAP_PYTHON:BOOL=ON \
379         %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
380         -DVTK_WRAP_TCL:BOOL=ON \
381         -DVTK_Group_Imaging:BOOL=ON \
382         -DVTK_Group_Qt:BOOL=ON \
383         -DVTK_Group_Rendering:BOOL=ON \
384         -DVTK_Group_StandAlone:BOOL=ON \
385         -DVTK_Group_Tk:BOOL=ON \
386         -DVTK_Group_Views:BOOL=ON \
387         -DModule_vtkFiltersStatisticsGnuR:BOOL=ON
388
389 %{__make}
390
391 %install
392 rm -rf $RPM_BUILD_ROOT
393 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
394
395 %{__make} -C build install \
396         DESTDIR=$RPM_BUILD_ROOT
397
398 # ld config
399 echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
400
401 for f in $(cd build/ExternalData/Testing ; find Data -type l); do
402         install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-6.1/$f
403 done
404
405 # Install utilities
406 install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
407
408 # Install examples
409 for f in \
410 AmbientSpheres \
411 Arrays \
412 BalloonWidget \
413 BandedContours \
414 Cone \
415 Cone2 \
416 Cone3 \
417 Cone4 \
418 Cone5 \
419 Cone6 \
420 Cube \
421 Cylinder \
422 Delaunay3D \
423 Delaunay3DAlpha \
424 DiffuseSpheres \
425 DumpXMLFile \
426 FilledContours \
427 FixedPointVolumeRayCastMapperCT \
428 GPURenderDemo \
429 Generate2DAMRDataSetWithPulse \
430 Generate3DAMRDataSetWithPulse \
431 GenerateCubesFromLabels \
432 GenerateModelsFromLabels \
433 HierarchicalBoxPipeline \
434 ImageDataLIC2DDemo \
435 ImageSlicing \
436 LabeledMesh \
437 Medical1 \
438 Medical2 \
439 Medical3 \
440 Medical4 \
441 MultiBlock \
442 ParticleReader \
443 RGrid \
444 SGrid \
445 SimpleView \
446 Slider \
447 Slider2D \
448 SpecularSpheres \
449 StructuredGridLIC2DDemo \
450 SurfaceLICDemo \
451 TimeRenderer \
452 TimeRenderer2 \
453 TubesWithVaryingRadiusAndColors \
454 finance ; do
455         install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
456 done
457
458 # Install test binaries
459 for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark ; do
460         install $f $RPM_BUILD_ROOT%{_bindir}
461 done
462
463 install build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
464 install build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
465
466 # unwanted doxygen files and misplaced verdict docs
467 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.1/{doxygen,verdict}
468
469 # only *.pyc are built by default, add *.pyo
470 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
471 %py_postclean
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %post   -p /sbin/ldconfig
477 %postun -p /sbin/ldconfig
478
479 %post   qt -p /sbin/ldconfig
480 %postun qt -p /sbin/ldconfig
481
482 %post   java -p /sbin/ldconfig
483 %postun java -p /sbin/ldconfig
484
485 %post   python -p /sbin/ldconfig
486 %postun python -p /sbin/ldconfig
487
488 %post   tcl -p /sbin/ldconfig
489 %postun tcl -p /sbin/ldconfig
490
491 %files
492 %defattr(644,root,root,755)
493 %doc README.html vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
494 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
495 %dir %{_libdir}/vtk
496 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
497 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
498 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
499 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
500 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
501 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
502 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
503 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
504 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
505 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
506 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
507 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
508 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
509 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
510 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
511 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
512 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so.1
513 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so.1
514 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
515 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so.1
516 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
517 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
518 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so.1
519 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
520 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so.1
521 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so.1
522 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
523 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
524 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
525 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
526 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
527 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
528 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
529 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.1
530 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
531 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
532 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
533 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
534 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
535 %exclude %{_libdir}/vtk/libvtk*Java.so.1
536 %exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
537 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
538 %exclude %{_libdir}/vtk/libvtk*TCL.so.1
539
540 %files devel
541 %defattr(644,root,root,755)
542 %doc Utilities/Upgrading/*
543 %attr(755,root,root) %{_bindir}/lproj
544 %attr(755,root,root) %{_bindir}/vtkEncodeString
545 %attr(755,root,root) %{_bindir}/vtkHashSource
546 %attr(755,root,root) %{_bindir}/vtkParseOGLExt
547 %attr(755,root,root) %{_bindir}/vtkWrapHierarchy
548 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
549 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
550 %attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
551 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
552 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
553 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
554 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
555 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
556 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
557 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
558 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
559 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
560 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
561 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
562 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
563 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
564 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeOpenGL.so
565 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so
566 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
567 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so
568 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
569 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
570 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so
571 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
572 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeAMR.so
573 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so
574 %attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
575 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
576 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
577 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
578 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
579 %attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
580 %attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
581 %attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
582 %attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
583 %attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
584 %attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
585 %attr(755,root,root) %{_libdir}/vtk/libvtksys.so
586 %attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
587 %exclude %{_libdir}/vtk/libvtk*Java.so
588 %exclude %{_libdir}/vtk/libvtk*Python2?D.so
589 %exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
590 %exclude %{_libdir}/vtk/libvtk*TCL.so
591 %{_libdir}/vtk/libvtkWrappingTools.a
592 %dir %{_includedir}/vtk
593 %{_includedir}/vtk/DICOM*.h
594 %{_includedir}/vtk/DatabaseSchemaWith2Tables.h
595 %{_includedir}/vtk/LSDyna*.h
596 %{_includedir}/vtk/alglib
597 %{_includedir}/vtk/vtklibproj4
598 %{_includedir}/vtk/vtkmetaio
599 %{_includedir}/vtk/vtkverdict
600 %{_includedir}/vtk/vtksqlite
601 %{_includedir}/vtk/vtksys
602 %{_includedir}/vtk/vtk*.h
603 %{_includedir}/vtk/vtk*.txx
604 %exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
605 %exclude %{_includedir}/vtk/vtkGUISupportQt*.h
606 %exclude %{_includedir}/vtk/vtkJavaUtil.h
607 %exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
608 %exclude %{_includedir}/vtk/vtkPython*.h
609 %exclude %{_includedir}/vtk/vtkQImageToImageSource.h
610 %exclude %{_includedir}/vtk/vtkQt*.h
611 %exclude %{_includedir}/vtk/vtkRenderingQtModule.h
612 %exclude %{_includedir}/vtk/vtkTcl*.h
613 %exclude %{_includedir}/vtk/vtkTk*.h
614 %exclude %{_includedir}/vtk/vtkViewsQtModule.h
615 %{_libdir}/cmake/vtk
616
617 %files qt
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
620 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so.1
621 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
622 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so.1
623 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
624 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
625 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
626
627 %files qt-devel
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
630 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so
631 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
632 %attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so
633 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
634 %attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
635 %{_includedir}/vtk/QFilterTreeProxyModel.h
636 %{_includedir}/vtk/QVTK*.h
637 %{_includedir}/vtk/vtkEventQtSlotConnect.h
638 %{_includedir}/vtk/vtkGUISupportQt*.h
639 %{_includedir}/vtk/vtkQImageToImageSource.h
640 %{_includedir}/vtk/vtkQt*.h
641 %{_includedir}/vtk/vtkRenderingQtModule.h
642 %{_includedir}/vtk/vtkViewsQtModule.h
643
644 %if %{with java}
645 %files java
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_bindir}/VTKJavaExecutable
648 %attr(755,root,root) %{_bindir}/vtkParseJava
649 %attr(755,root,root) %{_bindir}/vtkWrapJava
650 # common library
651 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
652 # java modules
653 %attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
654 %attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
655 %attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
656 %attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
657 %attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
658 %attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
659 %attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
660 %attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
661 %attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
662 %attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
663 %attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
664 %attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
665 %attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
666 %attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
667 %{_libdir}/vtk/vtk.jar
668
669 %files java-devel
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
672 %{_includedir}/vtk/vtkJavaUtil.h
673 %{_includedir}/vtk/vtkWrappingJavaModule.h
674 %endif
675
676 %files python
677 %defattr(644,root,root,755)
678 %doc Wrapping/Python/README*
679 %attr(755,root,root) %{_bindir}/vtkWrapPython
680 %attr(755,root,root) %{_bindir}/vtkWrapPythonInit
681 %attr(755,root,root) %{_bindir}/vtkpython
682 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
683 %attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-6.1.so
684 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
685 %dir %{py_sitedir}/vtk
686 %{py_sitedir}/vtk/*.py[co]
687 %dir %{py_sitedir}/vtk/gtk
688 %{py_sitedir}/vtk/gtk/*.py[co]
689 %dir %{py_sitedir}/vtk/qt4
690 %{py_sitedir}/vtk/qt4/*.py[co]
691 %dir %{py_sitedir}/vtk/test
692 %{py_sitedir}/vtk/test/*.py[co]
693 %dir %{py_sitedir}/vtk/tk
694 %{py_sitedir}/vtk/tk/*.py[co]
695 %dir %{py_sitedir}/vtk/util
696 %{py_sitedir}/vtk/util/*.py[co]
697 %dir %{py_sitedir}/vtk/wx
698 %{py_sitedir}/vtk/wx/*.py[co]
699 %attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
700
701 %files python-devel
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
704 %attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
705 %{_includedir}/vtk/PyVTK*.h
706 %{_includedir}/vtk/vtkPython*.h
707
708 %files tcl
709 %defattr(644,root,root,755)
710 %doc Wrapping/Tcl/README*
711 %attr(755,root,root) %{_bindir}/vtkWrapTcl
712 %attr(755,root,root) %{_bindir}/vtkWrapTclInit
713 %attr(755,root,root) %{_bindir}/vtk
714 %{_datadir}/tcl%{tcl_version}/vtk
715 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
716
717 %files tcl-devel
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
720 %{_includedir}/vtk/vtkTcl*.h
721 %{_includedir}/vtk/vtkTk*.h
722
723 %files test-suite
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_bindir}/*Tests
726 %attr(755,root,root) %{_bindir}/Test*
727 %attr(755,root,root) %{_bindir}/VTKBenchMark
728
729 %files examples
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_bindir}/AmbientSpheres
732 %attr(755,root,root) %{_bindir}/Arrays
733 %attr(755,root,root) %{_bindir}/Cone
734 %attr(755,root,root) %{_bindir}/Cone2
735 %attr(755,root,root) %{_bindir}/Cone3
736 %attr(755,root,root) %{_bindir}/Cone4
737 %attr(755,root,root) %{_bindir}/Cone5
738 %attr(755,root,root) %{_bindir}/Cone6
739 %attr(755,root,root) %{_bindir}/Cube
740 %attr(755,root,root) %{_bindir}/Cylinder
741 %attr(755,root,root) %{_bindir}/DiffuseSpheres
742 %attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
743 %attr(755,root,root) %{_bindir}/Medical1
744 %attr(755,root,root) %{_bindir}/Medical2
745 %attr(755,root,root) %{_bindir}/Medical3
746 %attr(755,root,root) %{_bindir}/Medical4
747 %attr(755,root,root) %{_bindir}/MultiBlock
748 %attr(755,root,root) %{_bindir}/RGrid
749 %attr(755,root,root) %{_bindir}/SGrid
750 %attr(755,root,root) %{_bindir}/SimpleView
751 %attr(755,root,root) %{_bindir}/SpecularSpheres
752 %attr(755,root,root) %{_bindir}/finance
753 %attr(755,root,root) %{_bindir}/BalloonWidget
754 %attr(755,root,root) %{_bindir}/BandedContours
755 %attr(755,root,root) %{_bindir}/Delaunay3D
756 %attr(755,root,root) %{_bindir}/Delaunay3DAlpha
757 %attr(755,root,root) %{_bindir}/DumpXMLFile
758 %attr(755,root,root) %{_bindir}/FilledContours
759 %attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
760 %attr(755,root,root) %{_bindir}/GPURenderDemo
761 %attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
762 %attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
763 %attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
764 %attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
765 %attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
766 %attr(755,root,root) %{_bindir}/ImageSlicing
767 %attr(755,root,root) %{_bindir}/LabeledMesh
768 %attr(755,root,root) %{_bindir}/ParticleReader
769 %attr(755,root,root) %{_bindir}/Slider
770 %attr(755,root,root) %{_bindir}/Slider2D
771 %attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
772 %attr(755,root,root) %{_bindir}/SurfaceLICDemo
773 %attr(755,root,root) %{_bindir}/TimeRenderer
774 %attr(755,root,root) %{_bindir}/TimeRenderer2
775 %attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
776 %{_examplesdir}/%{name}-%{version}
777
778 %files data
779 %defattr(644,root,root,755)
780 %dir %{_datadir}/vtk-6.1
781 %{_datadir}/vtk-6.1/Data
782 %{_datadir}/vtk-6.1/vtkDomainsChemistry
This page took 0.44016 seconds and 3 git commands to generate.