]> git.pld-linux.org Git - packages/vte.git/commitdiff
- fix for https://bugzilla.gnome.org/show_bug.cgi?id=663779 auto/th/vte-0_30_1-2 auto/ti/vte-0_30_1-2
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Fri, 18 Nov 2011 20:23:47 +0000 (20:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 2

Changed files:
    vte-alt-meta.patch -> 1.1
    vte.spec -> 1.175

vte-alt-meta.patch [new file with mode: 0644]
vte.spec

diff --git a/vte-alt-meta.patch b/vte-alt-meta.patch
new file mode 100644 (file)
index 0000000..bd364be
--- /dev/null
@@ -0,0 +1,74 @@
+From 180dcc578e13c6096e277fb853e7162db640f207 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 15 Nov 2011 03:06:40 -0500
+Subject: [PATCH] Map both gdk's Meta and Alt to vte's Meta for >=gtk+-3.2.2
+ compatibility
+
+Also, since VTE_META_MASK is now a mask with multiple bits set, code that
+compares gdk key modifiers to VTE_META_MASK by numerical equality is no
+longer guaranteed to work. Therefore, for such comparisons a new function,
+vte_keymap_fixup_modifiers, is introduced; it ensures that if any bits
+matching matching VTE_META_MASK are set, then all are set.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=663779
+---
+ src/keymap.c |   15 +++++++++++++--
+ src/keymap.h |    2 +-
+ 2 files changed, 14 insertions(+), 3 deletions(-)
+
+diff --git a/src/keymap.c b/src/keymap.c
+index 9a21669..95b4c5b 100644
+--- a/src/keymap.c
++++ b/src/keymap.c
+@@ -990,6 +990,17 @@ static const struct _vte_keymap_group {
+       {GDK_KEY (F35),         _vte_keymap_GDK_F35},
+ };
++/* Restrict modifiers to the specified mask and ensure that VTE_META_MASK,
++ * despite being a compound mask, is treated as indivisible. */
++GdkModifierType
++_vte_keymap_fixup_modifiers(GdkModifierType modifiers,
++              GdkModifierType mask)
++{
++      if (modifiers & VTE_META_MASK)
++              modifiers |= VTE_META_MASK;
++      return modifiers & mask;
++}
++
+ /* Map the specified keyval/modifier setup, dependent on the mode, to either
+  * a literal string or a capability name. */
+ void
+@@ -1104,7 +1115,7 @@ _vte_keymap_map(guint keyval,
+       } else {
+               fkey_mode = fkey_default;
+       }
+-      modifiers &= (GDK_SHIFT_MASK | GDK_CONTROL_MASK | VTE_META_MASK | VTE_NUMLOCK_MASK);
++      modifiers = _vte_keymap_fixup_modifiers(modifiers, GDK_SHIFT_MASK | GDK_CONTROL_MASK | VTE_META_MASK | VTE_NUMLOCK_MASK);
+       /* Search for the conditions. */
+       for (i = 0; entries[i].normal_length || entries[i].special[0]; i++)
+@@ -1375,7 +1386,7 @@ _vte_keymap_key_add_key_modifiers(guint keyval,
+               return;
+       }
+-      switch (modifiers & significant_modifiers) {
++      switch (_vte_keymap_fixup_modifiers(modifiers, significant_modifiers)) {
+       case 0:
+               modifier = 0;
+               break;
+diff --git a/src/keymap.h b/src/keymap.h
+index 243e22e..21d9b8e 100644
+--- a/src/keymap.h
++++ b/src/keymap.h
+@@ -27,7 +27,7 @@
+ G_BEGIN_DECLS
+-#define VTE_META_MASK         GDK_META_MASK
++#define VTE_META_MASK         (GDK_META_MASK | GDK_MOD1_MASK)
+ #define VTE_NUMLOCK_MASK      GDK_MOD2_MASK
+ /* Map the specified keyval/modifier setup, dependent on the mode, to either
+-- 
+1.7.8.rc3
+
index cec761efcc1c4d6cfd73a7f0d842f08af25ee993..28d12a05024dc4fe43a130bc5e884fb3d3c18cd2 100644 (file)
--- a/vte.spec
+++ b/vte.spec
@@ -2,11 +2,13 @@ Summary:      VTE terminal widget library
 Summary(pl.UTF-8):     Biblioteka z kontrolkÄ… terminala VTE
 Name:          vte
 Version:       0.30.1
-Release:       1
+Release:       2
 License:       LGPL v2+
 Group:         X11/Libraries
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/vte/0.30/%{name}-%{version}.tar.xz
 # Source0-md5: 514f48346f176f91297731f6fdb1cffc
+# https://bugzilla.gnome.org/show_bug.cgi?id=663779
+Patch0:                %{name}-alt-meta.patch
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.9
 BuildRequires: docbook-dtd412-xml
@@ -97,6 +99,7 @@ Dokumentacja API VTE (wersja dla GTK+ 3).
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__gtkdocize}
This page took 0.17979 seconds and 4 git commands to generate.