]> git.pld-linux.org Git - packages/vte.git/commitdiff
- vte-keys.patch: fix Home & End in the default mode (but I don't know vte-0_11_8-1
authorqrczak <qrczak@pld-linux.org>
Mon, 3 Mar 2003 09:41:04 +0000 (09:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  what they should generate in other modes), map Shift-F1 to F11 ...
  Shift-F10 to F20.
- Release 2.

Changed files:
    vte-keys.patch -> 1.1
    vte.spec -> 1.30

vte-keys.patch [new file with mode: 0644]
vte.spec

diff --git a/vte-keys.patch b/vte-keys.patch
new file mode 100644 (file)
index 0000000..964377b
--- /dev/null
@@ -0,0 +1,53 @@
+--- vte-0.10.25/src/keymap.c.orig      Fri Feb 21 05:02:58 2003
++++ vte-0.10.25/src/keymap.c   Mon Mar  3 02:33:09 2003
+@@ -184,16 +184,14 @@
+  * system to system, or mine's just broken.  But anyway. */
+ static struct _vte_keymap_entry _vte_keymap_GDK_Home[] = {
+       {cursor_all, keypad_all, fkey_all, 0, NULL, 0, "kh"},
+-      {cursor_all, keypad_all, fkey_vt220, 0, _VTE_CAP_CSI "1~", -1, NULL},
++      {cursor_all, keypad_all, fkey_nothp, 0, _VTE_CAP_CSI "1~", -1, NULL},
+       {cursor_all, keypad_all, fkey_hp, 0, _VTE_CAP_ESC "h", -1, NULL},
+-      {cursor_all, keypad_all, fkey_nothpvt, 0, NULL, 0, "kh"},
+       {cursor_all, keypad_all, fkey_all, 0, NULL, 0, NULL},
+ };
+ static struct _vte_keymap_entry _vte_keymap_GDK_End[] = {
+       {cursor_all, keypad_all, fkey_all, 0, NULL, 0, "@7"},
+-      {cursor_all, keypad_all, fkey_vt220, 0, _VTE_CAP_CSI "4~", -1, NULL},
+-      {cursor_all, keypad_all, fkey_notvt220, 0, NULL, 0, "@7"},
++      {cursor_all, keypad_all, fkey_all, 0, _VTE_CAP_CSI "4~", -1, NULL},
+       {cursor_all, keypad_all, fkey_all, 0, NULL, 0, NULL},
+ };
+@@ -968,6 +966,13 @@
+       *special = NULL;
+       *normal_length = 0;
++      /* Map Shift-F1 to F11 ... Shift-F10 to F20 */
++      if (keyval >= GDK_F1 && keyval <= GDK_F10 &&
++          (modifiers & GDK_SHIFT_MASK)) {
++              keyval += 10;
++              modifiers &= ~GDK_SHIFT_MASK;
++      }
++
+       /* Search for the list for this key. */
+       entries = NULL;
+       for (i = 0; i < G_N_ELEMENTS(_vte_keymap); i++) {
+@@ -1223,7 +1228,7 @@
+ _vte_keymap_key_gets_modifiers(guint keyval)
+ {
+       gboolean fkey = FALSE;
+-      /* Determine if this is just a modifier key. */
++      /* Determine if the key can take modifiers. */
+       switch (keyval) {
+       case GDK_Up:
+       case GDK_Down:
+@@ -1231,6 +1236,8 @@
+       case GDK_Right:
+       case GDK_Insert:
+       case GDK_Delete:
++      case GDK_Home:
++      case GDK_End:
+       case GDK_Page_Up:
+       case GDK_Page_Down:
+       case GDK_KP_Up:
index f68bee2b5b1a8a50c2bfeeb4665e3523b9ada023..57a6d94b1fbc1c93c77fbec42bb786cd6db57641 100644 (file)
--- a/vte.spec
+++ b/vte.spec
@@ -5,10 +5,11 @@ Summary:      VTE terminal widget library
 Summary(pl):   Biblioteka z kontrolk± terminala VTE
 Name:          vte
 Version:       0.10.25
-Release:       1
+Release:       2
 License:       LGPL
 Group:         X11/Libraries
 Source0:       ftp://ftp.gnome.org/pub/gnome/sources/%{name}/0.10/%{name}-%{version}.tar.bz2
+Patch0:                %{name}-keys.patch
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: Xft-devel >= 2.1-3
@@ -77,7 +78,8 @@ Python VTE library.
 Biblioteka VTE dla pythona.
 
 %prep
-%setup  -q
+%setup -q
+%patch0 -p1
 
 %build
 glib-gettextize --copy --force
This page took 0.039788 seconds and 4 git commands to generate.