]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- up to 0.14.2
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx     # drawing using GLX
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl):    Biblioteka z kontrolk± terminala VTE
7 Name:           vte
8 Version:        0.14.2
9 Release:        1
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/vte/0.14/%{name}-%{version}.tar.bz2
13 # Source0-md5:  eceafec1b564cc059fa3407f83631817
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-link.patch
16 %{?with_glx:BuildRequires:      OpenGL-GLU-devel}
17 %{?with_glx:BuildRequires:      OpenGL-GLX-devel}
18 BuildRequires:  autoconf >= 2.59-9
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.10.5
22 BuildRequires:  gtk-doc
23 BuildRequires:  intltool >= 0.35.0
24 BuildRequires:  libart_lgpl-devel >= 2.3.17
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygtk-devel >= 2:2.10.2
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 Requires(pre):  utempter
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The vte package contains a terminal widget for GTK+. It's used by
36 gnome-terminal among other programs.
37
38 %description -l pl
39 Ten pakiet zawiera kontrolkê terminala dla GTK+. Jest u¿ywany przez
40 gnome-terminal oraz inne programy.
41
42 %package devel
43 Summary:        Headers for VTE
44 Summary(pl):    Pliki nag³ówkowe VTE
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 %{?with_glx:Requires:   OpenGL-GLU-devel}
48 Requires:       gtk+2-devel >= 2:2.10.5
49 Requires:       libart_lgpl-devel >= 2.3.17
50 Requires:       ncurses-devel
51 Conflicts:      gnome-libs-devel < 1.4.1.2
52
53 %description devel
54 The vte package contains a terminal widget for GTK+. It's used by
55 gnome-terminal among other programs.
56
57 You should install the vte-devel package if you would like to compile
58 applications that use the vte terminal widget. You do not need to
59 install vte-devel if you just want to use precompiled applications.
60
61 %description devel -l pl
62 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych vte.
63
64 %package static
65 Summary:        Static VTE library
66 Summary(pl):    Statyczna biblioteka VTE
67 Group:          X11/Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69 Conflicts:      gnome-libs-static < 1.4.1.2
70
71 %description static
72 Static version of VTE libraries.
73
74 %description static -l pl
75 Statyczna wersja bibliotek VTE.
76
77 %package -n python-vte
78 Summary:        Python VTE module
79 Summary(pl):    Modu³ VTE dla pythona
80 Group:          Libraries
81 %pyrequires_eq  python-libs
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       python-pygtk-gtk >= 2:2.10.2
84
85 %description -n python-vte
86 Python VTE library.
87
88 %description -n python-vte -l pl
89 Biblioteka VTE dla pythona.
90
91 %package apidocs
92 Summary:        VTE API documentation
93 Summary(pl):    Dokumentacja API VTE
94 Group:          Documentation
95 Requires:       gtk-doc-common
96
97 %description apidocs
98 VTE API documentation.
99
100 %description apidocs -l pl
101 Dokumentacja API VTE.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107
108 %build
109 %{__intltoolize}
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoheader}
113 %{__automake}
114 %{__autoconf}
115 cd gnome-pty-helper
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoheader}
119 %{__automake}
120 %{__autoconf}
121 cd ..
122 %configure \
123         --enable-gtk-doc \
124         --with-default-emulation=xterm \
125         %{?with_glx:--with-glX} \
126         --with-html-dir=%{_gtkdocdir} \
127         --with-pangox \
128         --with-xft2
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
139
140 %find_lang vte
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f vte.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
151 %attr(755,root,root) %{_bindir}/vte
152 %attr(755,root,root) %{_libdir}/libvte.so.*.*.*
153 %dir %{_libdir}/vte
154 %attr(755,root,root) %{_libdir}/vte/*
155 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
156 %{_datadir}/vte
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libvte.so
161 %{_libdir}/libvte.la
162 %{_includedir}/vte
163 %{_pkgconfigdir}/vte.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libvte.a
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/vte
172
173 %files -n python-vte
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{py_sitedir}/gtk-2.0/vtemodule.so
This page took 0.23176 seconds and 4 git commands to generate.