]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- missing pyreqeq, release 11
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx # build for glX support
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl):    Biblioteka z kontrolk± terminala VTE
7 Name:           vte
8 Version:        0.11.11
9 Release:        11
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.11/%{name}-%{version}.tar.bz2
13 # Source0-md5:  4d7a3674df5b8be7f1adffa981c1fc3d
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-localenames.patch
16 Patch2:         %{name}-atktextselection.patch
17 Patch3:         %{name}-types-include.patch
18 Patch4:         %{name}-performance.patch
19 Patch5:         %{name}-nozvt.patch
20 %{?with_glx:BuildRequires:      OpenGL-devel}
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  glib2-devel >= 2.2.0
24 BuildRequires:  gtk+2-devel >= 2:2.2.0
25 BuildRequires:  gtk-doc
26 BuildRequires:  libart_lgpl-devel >= 2.3.10
27 BuildRequires:  libtool
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  python-pygtk-devel >= 1.99.13
30 BuildRequires:  xft-devel >= 2.1.2
31 Requires(pre):  utempter
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The vte package contains a terminal widget for GTK+. It's used by
36 gnome-terminal among other programs.
37
38 %description -l pl
39 Ten pakiet zawiera kontrolkê terminala dla GTK+. Jest u¿ywany przez
40 gnome-terminal oraz inne programy.
41
42 %package devel
43 Summary:        Headers for VTE
44 Summary(pl):    Pliki nag³ówkowe VTE
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 2.2.0
48 Requires:       gtk+2-devel >= 2.2.0
49 Requires:       libart_lgpl-devel >= 2.3.10
50 Requires:       OpenGL-devel
51 Conflicts:      gnome-libs-devel < 1.4.1.2
52
53 %description devel
54 The vte package contains a terminal widget for GTK+. It's used by
55 gnome-terminal among other programs.
56
57 You should install the vte-devel package if you would like to
58 compile applications that use the vte terminal widget. You do not need
59 to install vte-devel if you just want to use precompiled
60 applications.
61
62 %description devel -l pl
63 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
64 vte.
65
66 %package static
67 Summary:        Static VTE library
68 Summary(pl):    Statyczna biblioteka VTE
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71 Conflicts:      gnome-libs-static < 1.4.1.2
72
73 %description static
74 Static version of VTE libraries.
75
76 %description static -l pl
77 Statyczna wersja bibliotek VTE.
78
79 %package -n python-vte
80 Summary:        Python VTE module
81 Summary(pl):    Modu³ VTE dla pythona
82 Group:          Libraries
83 %pyrequires_eq  python-libs
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       python-pygtk-gtk >= 1.99.13
86
87 %description -n python-vte
88 Python VTE library.
89
90 %description -n python-vte -l pl
91 Biblioteka VTE dla pythona.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98 %patch3 -p0
99 %patch4 -p0
100 %patch5 -p1
101
102 mv -f po/{no,nb}.po
103
104 %build
105 glib-gettextize --copy --force
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoheader}
109 %{__automake}
110 %{__autoconf}
111 CFLAGS="-I/usr/include/ncurses"
112 %configure \
113         --with-xft2 \
114         --with-pangox \
115         %{?with_glx:--with-glX} \
116         --with-default-emulation=xterm \
117         --enable-gtk-doc \
118         --with-html-dir=%{_gtkdocdir}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
128
129 %find_lang vte
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files -f vte.lang
138 %defattr(644,root,root,755)
139 %doc NEWS README AUTHORS
140 %attr(755,root,root) %{_bindir}/vte
141 %attr(755,root,root) %{_libdir}/lib*.so.*.*
142 %dir %{_libdir}/vte
143 %attr(755,root,root) %{_libdir}/vte/*
144 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
145 %{_datadir}/vte
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_libdir}/lib*.la
151 %{_includedir}/*
152 %{_pkgconfigdir}/*
153 %{_gtkdocdir}/*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
158
159 %files -n python-vte
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{py_sitedir}/gtk-2.0/*.so
This page took 0.073012 seconds and 4 git commands to generate.