]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- fixed home end sequence in keys.patch
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx # build for glX support
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl):    Biblioteka z kontrolk± terminala VTE
7 Name:           vte
8 Version:        0.11.11
9 Release:        5
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.11/%{name}-%{version}.tar.bz2
13 # Source0-md5:  4d7a3674df5b8be7f1adffa981c1fc3d
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-localenames.patch
16 Patch2:         %{name}-atktextselection.patch
17 Patch3:         %{name}-types-include.patch
18 Patch4:         %{name}-performance.patch
19 %{?with_glx:BuildRequires:      OpenGL-devel}
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  glib2-devel >= 2.2.0
23 BuildRequires:  gtk+2-devel >= 2.2.0
24 BuildRequires:  gtk-doc
25 BuildRequires:  libart_lgpl-devel >= 2.3.10
26 BuildRequires:  libtool
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  python-pygtk-devel >= 1.99.13
29 BuildRequires:  xft-devel >= 2.1.2
30 Requires(pre):  utempter
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The vte package contains a terminal widget for GTK+. It's used by
35 gnome-terminal among other programs.
36
37 %description -l pl
38 Ten pakiet zawiera kontrolkê terminala dla GTK+. Jest u¿ywany przez
39 gnome-terminal oraz inne programy.
40
41 %package devel
42 Summary:        Headers for VTE
43 Summary(pl):    Pliki nag³ówkowe VTE
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 2.2.0
47 Requires:       gtk+2-devel >= 2.2.0
48 Requires:       libart_lgpl-devel >= 2.3.10
49 Requires:       OpenGL-devel
50 Conflicts:      gnome-libs-devel < 1.4.1.2
51
52 %description devel
53 The vte package contains a terminal widget for GTK+. It's used by
54 gnome-terminal among other programs.
55
56 You should install the vte-devel package if you would like to
57 compile applications that use the vte terminal widget. You do not need
58 to install vte-devel if you just want to use precompiled
59 applications.
60
61 %description devel -l pl
62 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
63 vte.
64
65 %package static
66 Summary:        Static VTE library
67 Summary(pl):    Statyczna biblioteka VTE
68 Group:          X11/Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70 Conflicts:      gnome-libs-static < 1.4.1.2
71
72 %description static
73 Static version of VTE libraries.
74
75 %description static -l pl
76 Statyczna wersja bibliotek VTE.
77
78 %package -n python-vte
79 Summary:        Python VTE module
80 Summary(pl):    Modu³ VTE dla pythona
81 Group:          Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       python-pygtk-gtk >= 1.99.13
84
85 %description -n python-vte
86 Python VTE library.
87
88 %description -n python-vte -l pl
89 Biblioteka VTE dla pythona.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 %patch3 -p0
97 %patch4 -p0
98
99 mv -f po/{no,nb}.po
100
101 %build
102 glib-gettextize --copy --force
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoheader}
106 %{__automake}
107 %{__autoconf}
108 CFLAGS="-I/usr/include/ncurses"
109 %configure \
110         --with-xft2 \
111         --with-pangox \
112         %{?with_glx:--with-glX} \
113         --with-default-emulation=xterm \
114         --enable-gtk-doc \
115         --with-html-dir=%{_gtkdocdir}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
125
126 %find_lang vte
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f vte.lang
135 %defattr(644,root,root,755)
136 %doc NEWS README AUTHORS
137 %attr(755,root,root) %{_bindir}/vte
138 %attr(755,root,root) %{_libdir}/lib*.so.*.*
139 %dir %{_libdir}/vte
140 %attr(755,root,root) %{_libdir}/vte/*
141 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
142 %{_datadir}/vte
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %{_libdir}/lib*.la
148 %{_includedir}/*
149 %{_pkgconfigdir}/*
150 %{_gtkdocdir}/*
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/lib*.a
155
156 %files -n python-vte
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{py_sitedir}/gtk-2.0/*.so
This page took 0.136634 seconds and 4 git commands to generate.