]> git.pld-linux.org Git - packages/vpb-driver.git/commitdiff
- fix building with kernel 3.8+ auto/th/vpb-driver-4.2.56-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 5 Jun 2013 20:58:15 +0000 (22:58 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 5 Jun 2013 20:58:15 +0000 (22:58 +0200)
linux-3.8.patch [new file with mode: 0644]
vpb-driver.spec

diff --git a/linux-3.8.patch b/linux-3.8.patch
new file mode 100644 (file)
index 0000000..05453da
--- /dev/null
@@ -0,0 +1,75 @@
+--- vpb-driver-4.2.56/src/vtcore/vtopenpci.c~  2013-04-11 19:11:39.000000000 +0200
++++ vpb-driver-4.2.56/src/vtcore/vtopenpci.c   2013-06-05 22:56:18.849529470 +0200
+@@ -262,13 +262,13 @@
+       return (const char*)ent->driver_data;
+ }
+-static int __devinit openpci_probe_board(struct pci_dev *pdev, const struct pci_device_id *ent);
+-static void __devexit openpci_remove_board(struct pci_dev *pdev);
++static int openpci_probe_board(struct pci_dev *pdev, const struct pci_device_id *ent);
++static void openpci_remove_board(struct pci_dev *pdev);
+ static struct pci_driver vtopenpci_driver = {
+       .name     = NAME,
+       .probe    = openpci_probe_board,
+-      .remove   = __devexit_p(openpci_remove_board),
++      .remove   = openpci_remove_board,
+       .suspend  = NULL,
+       .resume   = NULL,
+       .id_table = openpci_idtable
+@@ -2327,7 +2327,7 @@
+       vt_board_unregister(board);
+ } //}}}
+-static int __devinit openpci_probe_board(struct pci_dev *pdev,
++static int openpci_probe_board(struct pci_dev *pdev,
+                                        const struct pci_device_id *ent)
+ { //{{{
+       struct openpci *card;
+@@ -2562,7 +2562,7 @@
+       }
+ } //}}}
+-static void __devexit openpci_remove_board(struct pci_dev *pdev)
++static void openpci_remove_board(struct pci_dev *pdev)
+ { //{{{
+       struct openpci *card = pci_get_drvdata(pdev);
+       unsigned long flags;
+--- vpb-driver-4.2.56/src/vtcore/vtopenswitch.c~       2013-04-11 19:11:39.000000000 +0200
++++ vpb-driver-4.2.56/src/vtcore/vtopenswitch.c        2013-06-05 22:56:45.936416073 +0200
+@@ -273,14 +273,14 @@
+ };
+ MODULE_DEVICE_TABLE(pci, openswitch_idtable);
+-static int  __devinit openswitch_probe_board(struct pci_dev *pdev,
++static int  openswitch_probe_board(struct pci_dev *pdev,
+                                            const struct pci_device_id *ent);
+-static void __devexit openswitch_remove_board(struct pci_dev *pdev);
++static void openswitch_remove_board(struct pci_dev *pdev);
+ static struct pci_driver vtopenswitch_driver = {
+       .name     = NAME,
+       .probe    = openswitch_probe_board,
+-      .remove   = __devexit_p(openswitch_remove_board),
++      .remove   = openswitch_remove_board,
+       .suspend  = NULL,
+       .resume   = NULL,
+       .id_table = openswitch_idtable
+@@ -1582,7 +1582,7 @@
+       return RET_OK;
+ } //}}}
+-static int __devinit openswitch_probe_board(struct pci_dev *pdev,
++static int openswitch_probe_board(struct pci_dev *pdev,
+                                           const struct pci_device_id *ent)
+ { //{{{
+       struct openswitch *card;
+@@ -1858,7 +1858,7 @@
+       set_audio_off( card, port );
+ } //}}}
+-static void __devexit openswitch_remove_board(struct pci_dev *pdev)
++static void openswitch_remove_board(struct pci_dev *pdev)
+ { //{{{
+       struct openswitch *card = pci_get_drvdata(pdev);
+       int    i = 0;
index 32c4b39d40b0c2f4e8d9341bfac0860396930a4f..a39b7644bd2eb31caa34f11fba3dab98e23a6015 100644 (file)
@@ -26,6 +26,7 @@ Source0:      http://www.voicetronix.com.au/Downloads/vpb-driver-4.x/%{pname}-%{versi
 # Source0-md5: aa7442b5b98a566fe67544115d83e20a
 Patch0:                %{pname}-make.patch
 Patch1:                %{pname}-kernel.patch
+Patch2:                linux-3.8.patch
 URL:           http://www.voicetronix.com.au/downloads.htm#linux
 %if %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build
@@ -106,6 +107,9 @@ Sterownik jądra Linuksa do kart VPB firmy Voicetronix.
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
 %patch1 -p1
+%if "%{_alt_kernel}" == "%{nil}"
+%patch2 -p1
+%endif
 
 %if %{without kernel}
 %{__sed} -i -e 's,subdirs += $(srcdir)/vtcore $(srcdir)/vpb,,' src/Makefile.in
This page took 0.084647 seconds and 4 git commands to generate.