]> git.pld-linux.org Git - packages/vpb-driver.git/commitdiff
- up to 4.2.57 auto/th/vpb-driver-4.2.57-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 25 Aug 2013 09:28:01 +0000 (11:28 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 25 Aug 2013 09:28:01 +0000 (11:28 +0200)
- removed obsolete patches

linux-3.8.patch [deleted file]
vpb-driver-kernel.patch [deleted file]
vpb-driver.spec

diff --git a/linux-3.8.patch b/linux-3.8.patch
deleted file mode 100644 (file)
index 05453da..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
---- vpb-driver-4.2.56/src/vtcore/vtopenpci.c~  2013-04-11 19:11:39.000000000 +0200
-+++ vpb-driver-4.2.56/src/vtcore/vtopenpci.c   2013-06-05 22:56:18.849529470 +0200
-@@ -262,13 +262,13 @@
-       return (const char*)ent->driver_data;
- }
--static int __devinit openpci_probe_board(struct pci_dev *pdev, const struct pci_device_id *ent);
--static void __devexit openpci_remove_board(struct pci_dev *pdev);
-+static int openpci_probe_board(struct pci_dev *pdev, const struct pci_device_id *ent);
-+static void openpci_remove_board(struct pci_dev *pdev);
- static struct pci_driver vtopenpci_driver = {
-       .name     = NAME,
-       .probe    = openpci_probe_board,
--      .remove   = __devexit_p(openpci_remove_board),
-+      .remove   = openpci_remove_board,
-       .suspend  = NULL,
-       .resume   = NULL,
-       .id_table = openpci_idtable
-@@ -2327,7 +2327,7 @@
-       vt_board_unregister(board);
- } //}}}
--static int __devinit openpci_probe_board(struct pci_dev *pdev,
-+static int openpci_probe_board(struct pci_dev *pdev,
-                                        const struct pci_device_id *ent)
- { //{{{
-       struct openpci *card;
-@@ -2562,7 +2562,7 @@
-       }
- } //}}}
--static void __devexit openpci_remove_board(struct pci_dev *pdev)
-+static void openpci_remove_board(struct pci_dev *pdev)
- { //{{{
-       struct openpci *card = pci_get_drvdata(pdev);
-       unsigned long flags;
---- vpb-driver-4.2.56/src/vtcore/vtopenswitch.c~       2013-04-11 19:11:39.000000000 +0200
-+++ vpb-driver-4.2.56/src/vtcore/vtopenswitch.c        2013-06-05 22:56:45.936416073 +0200
-@@ -273,14 +273,14 @@
- };
- MODULE_DEVICE_TABLE(pci, openswitch_idtable);
--static int  __devinit openswitch_probe_board(struct pci_dev *pdev,
-+static int  openswitch_probe_board(struct pci_dev *pdev,
-                                            const struct pci_device_id *ent);
--static void __devexit openswitch_remove_board(struct pci_dev *pdev);
-+static void openswitch_remove_board(struct pci_dev *pdev);
- static struct pci_driver vtopenswitch_driver = {
-       .name     = NAME,
-       .probe    = openswitch_probe_board,
--      .remove   = __devexit_p(openswitch_remove_board),
-+      .remove   = openswitch_remove_board,
-       .suspend  = NULL,
-       .resume   = NULL,
-       .id_table = openswitch_idtable
-@@ -1582,7 +1582,7 @@
-       return RET_OK;
- } //}}}
--static int __devinit openswitch_probe_board(struct pci_dev *pdev,
-+static int openswitch_probe_board(struct pci_dev *pdev,
-                                           const struct pci_device_id *ent)
- { //{{{
-       struct openswitch *card;
-@@ -1858,7 +1858,7 @@
-       set_audio_off( card, port );
- } //}}}
--static void __devexit openswitch_remove_board(struct pci_dev *pdev)
-+static void openswitch_remove_board(struct pci_dev *pdev)
- { //{{{
-       struct openswitch *card = pci_get_drvdata(pdev);
-       int    i = 0;
diff --git a/vpb-driver-kernel.patch b/vpb-driver-kernel.patch
deleted file mode 100644 (file)
index 8b7f973..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- vpb-driver-4.2.55/src/vpb/vpb.c.orig       2012-05-09 13:57:34.000000000 +0200
-+++ vpb-driver-4.2.55/src/vpb/vpb.c    2013-01-29 18:43:08.571270294 +0100
-@@ -117,7 +117,6 @@
- #include <linux/module.h>
- #include <linux/kernel.h>
- #include <asm/io.h>
--#include <asm/system.h>
- #include <linux/vmalloc.h>
- #include <linux/pci.h>
- #include <linux/delay.h>
index 89b99992e0eb85ccaf3d49d2e1c907a893f6711b..073bd621b17261fa3ef0e9824e9e73d94a35409f 100644 (file)
 %undefine      with_dist_kernel
 %endif
 
-%define        rel     9
+%define        rel     1
 %define                pname   vpb-driver
 Summary:       Voicetronix voice processing board (VPB) driver software
 Summary(pl.UTF-8):     Oprogramowanie sterowników dla kart przetwarzających głos (VPB) Voicetronix
 Name:          %{pname}%{_alt_kernel}
-Version:       4.2.56
+Version:       4.2.57
 Release:       %{rel}
 License:       LGPL v2.1+ (libraries), GPL v2+ (libpri library, kernel module)
 Group:         Libraries
 Source0:       http://www.voicetronix.com.au/Downloads/vpb-driver-4.x/%{pname}-%{version}.tar.gz
-# Source0-md5: aa7442b5b98a566fe67544115d83e20a
+# Source0-md5: 35d0ea8ab7a6bda267603ca7c9b78671
 Patch0:                %{pname}-make.patch
-Patch1:                %{pname}-kernel.patch
-Patch2:                linux-3.8.patch
 URL:           http://www.voicetronix.com.au/downloads.htm#linux
 %if %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build
@@ -106,10 +104,6 @@ Sterownik jądra Linuksa do kart VPB firmy Voicetronix.
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
-%patch1 -p1
-%if "%{_alt_kernel}" == "%{nil}"
-%patch2 -p1
-%endif
 
 %if %{without kernel}
 %{__sed} -i -e 's,subdirs += $(srcdir)/vtcore $(srcdir)/vpb,,' src/Makefile.in
This page took 0.034572 seconds and 4 git commands to generate.