]> git.pld-linux.org Git - packages/vpb-driver.git/commitdiff
- new
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 27 Jan 2013 18:34:14 +0000 (19:34 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 27 Jan 2013 18:34:14 +0000 (19:34 +0100)
vpb-driver-make.patch [new file with mode: 0644]
vpb-driver.spec [new file with mode: 0644]

diff --git a/vpb-driver-make.patch b/vpb-driver-make.patch
new file mode 100644 (file)
index 0000000..517e3de
--- /dev/null
@@ -0,0 +1,68 @@
+--- vpb-driver-4.2.55/src/vtcore/Makefile.orig 2012-05-09 13:57:34.000000000 +0200
++++ vpb-driver-4.2.55/src/vtcore/Makefile      2013-01-27 15:13:32.826786200 +0100
+@@ -50,8 +50,6 @@
+               echo "installing $$m --> $(MODULEDIR)"; \
+               install -m 644 $$m $(MODULEDIR);        \
+       done
+-      /sbin/depmod
+-      @modprobe -r netjet > /dev/null 2>&1 || true
+ clean distclean:
+       rm -f *.o *.ko *~ core *.mod.c .*.cmd
+--- vpb-driver-4.2.55/src/vpb/Makefile.orig    2012-05-09 13:57:34.000000000 +0200
++++ vpb-driver-4.2.55/src/vpb/Makefile 2013-01-27 15:30:43.120098058 +0100
+@@ -46,7 +46,6 @@
+               echo "installing $$m --> $(MODULEDIR)"; \
+               install -m 644 $$m $(MODULEDIR);        \
+       done
+-      /sbin/depmod
+ clean distclean:
+       $(RM) *.o *.ko *~ core *.mod.c .*.cmd
+--- vpb-driver-4.2.55/configure.ac.orig        2012-05-09 13:57:34.000000000 +0200
++++ vpb-driver-4.2.55/configure.ac     2013-01-27 17:02:41.733316367 +0100
+@@ -39,9 +39,6 @@
+ AC_SUBST(HOST_OS)
+-# Don't let these get set by AC_PROG_* below.
+-CFLAGS=
+-CXXFLAGS=
+ AC_PROG_CC
+@@ -73,9 +70,6 @@
+     cxx_flags="$cxx_flags -g"
+     cc_flags="$cc_flags -g"
+ else
+-    cxx_flags="$cxx_flags -O3"
+-    cc_flags="$cc_flags -O3"
+-
+     if test $ac_cv_enable_debug_syms = yes; then
+       cxx_flags="$cxx_flags -g"
+       cc_flags="$cc_flags -g"
+@@ -123,12 +117,8 @@
+     CASLOG=enable_caslog
+ fi
+ if test $ac_cv_with_pri = yes; then
+-    if test -d /etc/wanpipe; then
+       LIBVPB_PRI_CPPFLAGS="-D_OPENPRI -I\$(top_srcdir)/src"
+       LIBVPB_PRI_OBJ="\$(PRI_OBJ)"
+-    else
+-      AC_MSG_ERROR([/etc/wanpipe is not installed, cannot build --with-pri])
+-    fi
+ fi
+ AC_ARG_ENABLE(softbridge,
+--- vpb-driver-4.2.55/src/libvpb/Makefile.in.orig      2012-05-09 13:57:34.000000000 +0200
++++ vpb-driver-4.2.55/src/libvpb/Makefile.in   2013-01-27 18:06:04.083237114 +0100
+@@ -181,9 +181,6 @@
+           install -m 644 $(top_srcdir)/firmware/vpbmain_pci.out       \
+                          $(DESTDIR)$(datadir)/vpb-driver;             \
+       fi
+-ifeq ($(LIB_TYPE),shared)
+-      /sbin/ldconfig
+-endif
+ # Install the runtime library files.
+ install-lib:
diff --git a/vpb-driver.spec b/vpb-driver.spec
new file mode 100644 (file)
index 0000000..e70c463
--- /dev/null
@@ -0,0 +1,195 @@
+#
+# Conditional build:
+%bcond_without dist_kernel     # without distribution kernel
+%bcond_without  kernel         # don't build kernel modules
+%bcond_without userspace       # don't build userspace package
+%bcond_without static_libs     # don't build static libraries
+%bcond_with    pri             # ISDN devices support (modified libpri)
+#
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
+Summary:       Voicetronix voice processing board (VPB) driver software
+Summary(pl.UTF-8):     Oprogramowanie sterowników dla kart przetwarzających głos (VPB) Voicetronix
+Name:          vpb-driver
+Version:       4.2.55
+%define        rel     1
+Release:       %{rel}
+License:       LGPL v2.1+ (libraries), GPL v2+ (libpri library, kernel module)
+Group:         Libraries
+Source0:       http://www.voicetronix.com.au/Downloads/vpb-driver-4.x/%{name}-%{version}.tar.gz
+# Source0-md5: d014a29043334923e0976a9273627b63
+Patch0:                %{name}-make.patch
+URL:           http://www.voicetronix.com.au/downloads.htm#linux
+%if %{with dist_kernel}
+BuildRequires: kernel%{_alt_kernel}-module-build
+%endif
+BuildRequires: autoconf >= 2.59
+BuildRequires: libstdc++-devel
+BuildRequires: pciutils-devel
+BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: zlib-devel
+Requires:      vpb-libs = %{version}-%{rel}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This is the Voicetronix voice processing board (VPB) driver software.
+
+%description -l pl.UTF-8
+Ten pakiet zawiera oprogramowanie sterowników kart przetwarzających
+głos (VPB - voice processing board) firmy Voicetronix.
+
+%package -n vpb-libs
+Summary:       Shared VPD libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone VPD
+License:       LGPL v2.1+
+Group:         Libraries
+
+%description -n vpb-libs
+Shared VPD libraries.
+
+%description -n vpb-libs -l pl.UTF-8
+Biblioteki współdzielone VPD.
+
+%package -n vpb-devel
+Summary:       Header files for VPD libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek VPD
+License:       LGPL v2.1+
+Group:         Development/Libraries
+Requires:      vpb-libs = %{version}-%{rel}
+
+%description -n vpb-devel
+Header files for VPD libraries.
+
+%description -n vpb-devel -l pl.UTF-8
+Pliki nagłówkowe bibliotek VPD.
+
+%package -n vpb-static
+Summary:       Static VPD libraries
+Summary(pl.UTF-8):     Statyczne biblioteki VPD
+License:       LGPL v2.1+
+Group:         Development/Libraries
+Requires:      vpb-devel = %{version}-%{rel}
+
+%description -n vpb-static
+Static VPD libraries.
+
+%description -n vpb-static -l pl.UTF-8
+Statyczne biblioteki VPD.
+
+%package -n kernel%{_alt_kernel}-telephony-vpb
+Summary:       Linux kernel driver for Voicetronix Voice Processing Board (VPB)
+Summary(pl.UTF-8):     Sterownik jądra Linuksa do kart VPB firmy Voicetronix
+Release:       %{rel}@%{_kernel_ver_str}
+License:       GPL v2+
+Group:         Base/Kernel
+Requires(post,postun): /sbin/depmod
+%if %{with dist_kernel}
+%requires_releq_kernel
+Requires(postun):      %releq_kernel
+%endif
+
+%description -n kernel%{_alt_kernel}-telephony-vpb
+Linux kernel driver for Voicetronix Voice Processing Board (VPB).
+
+%description -n kernel%{_alt_kernel}-telephony-vpb -l pl.UTF-8
+Sterownik jądra Linuksa do kart VPB firmy Voicetronix.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+%{__aclocal}
+%{__autoconf}
+%if %{with userspace} && %{with static_libs}
+install -d build-static
+cd build-static
+../%configure \
+       %{?with_pri:--with-pri}
+%{__make}
+cd ..
+%endif
+%configure \
+       %{?with_pri:--with-pri} \
+       --enable-shared
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%if %{with userspace}
+# let rpm generate dependencies
+chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
+
+# install man pages only for packaged software
+install -d $RPM_BUILD_ROOT%{_mandir}/man1
+install doc/vpbconf.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install doc/vpbscan.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
+%if %{with static_libs}
+install build-static/src/{libtoneg/libtoneg.a,libvpb/libvpb.a} $RPM_BUILD_ROOT%{_libdir}
+%endif
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -n vpb-libs -p /sbin/ldconfig
+%postun        -n vpb-libs -p /sbin/ldconfig
+
+%post -n kernel%{_alt_kernel}-telephony-vpb
+%depmod %{_kernel_ver}
+
+%postun -n kernel%{_alt_kernel}-telephony-vpb
+%depmod %{_kernel_ver}
+
+%if %{with userspace}
+%files
+%defattr(644,root,root,755)
+%doc COPYING README README.{OpenPCI,OpenPRI,OpenSwitch12,VTCore,VpbConfig}
+%attr(755,root,root) %{_sbindir}/vpbconf
+%attr(755,root,root) %{_sbindir}/vpbscan
+%{_datadir}/vpb-driver
+%{_mandir}/man1/vpbconf.1*
+%{_mandir}/man1/vpbscan.1*
+
+%files -n vpb-libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libtoneg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtoneg.so.0
+%attr(755,root,root) %{_libdir}/libvpb.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libvpb.so.0
+
+%files -n vpb-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libtoneg.so
+%attr(755,root,root) %{_libdir}/libvpb.so
+%{_includedir}/vt
+%{_includedir}/vpbapi.h
+%{_includedir}/vt_deprecated.h
+%{_includedir}/vtcore_ioctl.h
+
+%if %{with static_libs}
+%files -n vpb-static
+%defattr(644,root,root,755)
+%{_libdir}/libtoneg.a
+%{_libdir}/libvpb.a
+%endif
+%endif
+
+%if %{with kernel}
+%files -n kernel-telephony-vpb
+%defattr(644,root,root,755)
+/lib/modules/%{_kernel_ver}/kernel/drivers/telephony/vpb.ko*
+/lib/modules/%{_kernel_ver}/kernel/drivers/telephony/vtcore.ko*
+/lib/modules/%{_kernel_ver}/kernel/drivers/telephony/vtopenpci.ko*
+/lib/modules/%{_kernel_ver}/kernel/drivers/telephony/vtopenswitch.ko*
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/blunt-axe.conf
+%endif
This page took 0.09827 seconds and 4 git commands to generate.