]> git.pld-linux.org Git - packages/vlc.git/commitdiff
add upstream patch to fix build with fribidi >= 1.0; rel 2 auto/th/vlc-3.0.3-2
authorJan Palus <atler@pld-linux.org>
Wed, 30 May 2018 18:58:57 +0000 (20:58 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 30 May 2018 18:58:57 +0000 (20:58 +0200)
vlc-fribidi-1.0.patch [new file with mode: 0644]
vlc.spec

diff --git a/vlc-fribidi-1.0.patch b/vlc-fribidi-1.0.patch
new file mode 100644 (file)
index 0000000..0a461e1
--- /dev/null
@@ -0,0 +1,80 @@
+From 26e2d3906658c30f2f88f4b1bc9630ec43bf5525 Mon Sep 17 00:00:00 2001
+From: Shaleen Jain <shaleen@jain.sh>
+Date: Sun, 25 Feb 2018 18:42:27 +0530
+Subject: [PATCH] fribidi: update for version 1.0
+
+Update functions deprecated in version 1.0 when building with release 1.0 and
+above.
+
+Signed-off-by: Thomas Guillem <thomas@gllm.fr>
+---
+ modules/text_renderer/freetype/text_layout.c | 24 ++++++++++++++++++++++++
+ 1 file changed, 24 insertions(+)
+
+diff --git a/modules/text_renderer/freetype/text_layout.c b/modules/text_renderer/freetype/text_layout.c
+index 13efd567b46..1a28786d097 100644
+--- a/modules/text_renderer/freetype/text_layout.c
++++ b/modules/text_renderer/freetype/text_layout.c
+@@ -153,6 +153,9 @@ typedef struct paragraph_t
+ #ifdef HAVE_FRIBIDI
+     FriBidiCharType     *p_types;
++#if FRIBIDI_MAJOR_VERSION >= 1
++    FriBidiBracketType  *p_btypes;
++#endif
+     FriBidiLevel        *p_levels;
+     FriBidiStrIndex     *pi_reordered_indices;
+     FriBidiParType       paragraph_type;
+@@ -361,6 +364,9 @@ static paragraph_t *NewParagraph( filter_t *p_filter,
+ #ifdef HAVE_FRIBIDI
+     p_paragraph->p_levels = vlc_alloc( i_size, sizeof( *p_paragraph->p_levels ) );
+     p_paragraph->p_types = vlc_alloc( i_size, sizeof( *p_paragraph->p_types ) );
++#if FRIBIDI_MAJOR_VERSION >= 1
++    p_paragraph->p_btypes = vlc_alloc( i_size, sizeof( *p_paragraph->p_btypes ) );
++#endif
+     p_paragraph->pi_reordered_indices =
+             vlc_alloc( i_size, sizeof( *p_paragraph->pi_reordered_indices ) );
+@@ -398,6 +404,9 @@ static paragraph_t *NewParagraph( filter_t *p_filter,
+ #ifdef HAVE_FRIBIDI
+     if( p_paragraph->p_levels ) free( p_paragraph->p_levels );
+     if( p_paragraph->p_types ) free( p_paragraph->p_types );
++#if FRIBIDI_MAJOR_VERSION >= 1
++    if( p_paragraph->p_btypes ) free( p_paragraph->p_btypes );
++#endif
+     if( p_paragraph->pi_reordered_indices )
+         free( p_paragraph->pi_reordered_indices );
+ #endif
+@@ -424,6 +433,9 @@ static void FreeParagraph( paragraph_t *p_paragraph )
+ #ifdef HAVE_FRIBIDI
+     free( p_paragraph->pi_reordered_indices );
+     free( p_paragraph->p_types );
++#if FRIBIDI_MAJOR_VERSION >= 1
++    free( p_paragraph->p_btypes );
++#endif
+     free( p_paragraph->p_levels );
+ #endif
+@@ -436,10 +448,22 @@ static int AnalyzeParagraph( paragraph_t *p_paragraph )
+     fribidi_get_bidi_types(  p_paragraph->p_code_points,
+                              p_paragraph->i_size,
+                              p_paragraph->p_types );
++#if FRIBIDI_MAJOR_VERSION >= 1
++    fribidi_get_bracket_types( p_paragraph->p_code_points,
++                               p_paragraph->i_size,
++                               p_paragraph->p_types,
++                               p_paragraph->p_btypes );
++    fribidi_get_par_embedding_levels_ex( p_paragraph->p_types,
++                                      p_paragraph->p_btypes,
++                                      p_paragraph->i_size,
++                                      &p_paragraph->paragraph_type,
++                                      p_paragraph->p_levels );
++#else
+     fribidi_get_par_embedding_levels( p_paragraph->p_types,
+                                       p_paragraph->i_size,
+                                       &p_paragraph->paragraph_type,
+                                       p_paragraph->p_levels );
++#endif
+ #ifdef HAVE_HARFBUZZ
+     hb_unicode_funcs_t *p_funcs = hb_unicode_funcs_get_default();
index f013e7d35d5757e1301793a8b555f782aca8a3fa..78a3c027f26e0fe4e4b7ecfc6f2d70f968d7de14 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -64,7 +64,7 @@ Summary:      VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
 Version:       3.0.3
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
@@ -74,6 +74,7 @@ Patch1:               %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
 Patch3:                xmas-sucks.patch
 Patch4:                no-cache.patch
+Patch5:                %{name}-fribidi-1.0.patch
 URL:           http://www.videolan.org/vlc/
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
 BuildRequires: EGL-devel >= %{?with_glesv2:1.1}%{!?with_glesv2:1.0}
@@ -346,6 +347,7 @@ Akcje klienta VLC dla Solid.
 %patch3 -p1
 %endif
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
This page took 0.245467 seconds and 4 git commands to generate.