]> git.pld-linux.org Git - packages/vlc.git/commitdiff
- updated to 3.0.17.3 auto/th/vlc-3.0.17.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 1 Apr 2022 20:15:45 +0000 (22:15 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 1 Apr 2022 20:15:45 +0000 (22:15 +0200)
- removed obsolete srt patch
- added dav1d patch (dav1d 1.0.0 support from PR)

vlc-dav1d.patch [new file with mode: 0644]
vlc-srt.patch [deleted file]
vlc.spec

diff --git a/vlc-dav1d.patch b/vlc-dav1d.patch
new file mode 100644 (file)
index 0000000..16808c9
--- /dev/null
@@ -0,0 +1,132 @@
+https://code.videolan.org/videolan/vlc/-/merge_requests/1618
+
+From 0efdfe8799b0100f41c5b8d6e1b43451001386cb Mon Sep 17 00:00:00 2001
+From: Steve Lhomme <robux4@ycbcr.xyz>
+Date: Fri, 18 Mar 2022 11:42:49 +0100
+Subject: [PATCH 1/2] dav1d: fix compilation with (upcoming) dav1d 1.0
+
+(cherry picked from commit dbf45cea2a8abdfbef897b8a71f3eb782bb1b712) (edited)
+edited:
+- 3.0 has the 128 pixels padding elsewhere
+- 3.0 has an extra parameter for add_integer_with_range()
+- 3.0 was setting i_extra_picture_buffers further down in the code
+- 3.0 uses 16 threads max
+
+Signed-off-by: Steve Lhomme <robux4@ycbcr.xyz>
+---
+ modules/codec/dav1d.c | 22 +++++++++++++++++++++-
+ 1 file changed, 21 insertions(+), 1 deletion(-)
+
+diff --git a/modules/codec/dav1d.c b/modules/codec/dav1d.c
+index 039165f52ec..cfabbc27cb3 100644
+--- a/modules/codec/dav1d.c
++++ b/modules/codec/dav1d.c
+@@ -63,10 +63,16 @@ vlc_module_begin ()
+     set_category(CAT_INPUT)
+     set_subcategory(SUBCAT_INPUT_VCODEC)
++#if DAV1D_API_VERSION_MAJOR >= 6
++    add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_THREADS,
++                THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
++    add_obsolete_string("dav1d-thread-tiles") // unused with dav1d 1.0
++#else
+     add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_FRAME_THREADS,
+                 THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
+     add_integer_with_range("dav1d-thread-tiles", 0, 0, DAV1D_MAX_TILE_THREADS,
+                 THREAD_TILES_TEXT, THREAD_TILES_LONGTEXT, false)
++#endif
+ vlc_module_end ()
+ /*****************************************************************************
+@@ -294,6 +300,11 @@ static int OpenDecoder(vlc_object_t *p_this)
+         return VLC_ENOMEM;
+     dav1d_default_settings(&p_sys->s);
++#if DAV1D_API_VERSION_MAJOR >= 6
++    p_sys->s.n_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
++    if (p_sys->s.n_threads == 0)
++        p_sys->s.n_threads = (i_core_count < 16) ? i_core_count : 16;
++#else
+     p_sys->s.n_tile_threads = var_InheritInteger(p_this, "dav1d-thread-tiles");
+     if (p_sys->s.n_tile_threads == 0)
+         p_sys->s.n_tile_threads =
+@@ -303,6 +314,7 @@ static int OpenDecoder(vlc_object_t *p_this)
+     p_sys->s.n_frame_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
+     if (p_sys->s.n_frame_threads == 0)
+         p_sys->s.n_frame_threads = (i_core_count < 16) ? i_core_count : 16;
++#endif
+     p_sys->s.allocator.cookie = dec;
+     p_sys->s.allocator.alloc_picture_callback = NewPicture;
+     p_sys->s.allocator.release_picture_callback = FreePicture;
+@@ -313,12 +325,20 @@ static int OpenDecoder(vlc_object_t *p_this)
+         return VLC_EGENERIC;
+     }
++#if DAV1D_API_VERSION_MAJOR >= 6
++    msg_Dbg(p_this, "Using dav1d version %s with %d threads",
++            dav1d_version(), p_sys->s.n_threads);
++
++    dec->i_extra_picture_buffers = (p_sys->s.n_threads - 1);
++#else
+     msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
+             dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
++    dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
++#endif
++
+     dec->pf_decode = Decode;
+     dec->pf_flush = FlushDecoder;
+-    dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
+     dec->fmt_out.video.i_width = dec->fmt_in.video.i_width;
+     dec->fmt_out.video.i_height = dec->fmt_in.video.i_height;
+-- 
+GitLab
+
+
+From b9d8c4079c6b0c4f8d8857a81dd3cfb9bdc67601 Mon Sep 17 00:00:00 2001
+From: Steve Lhomme <robux4@ycbcr.xyz>
+Date: Wed, 12 Aug 2020 06:19:06 +0200
+Subject: [PATCH 2/2] contrib: dav1d: update to 1.0.0
+
+(cherry picked from commit c857056738aec2e66d21b54d2d086c60255e6a91) (edited)
+edited:
+- 3.0 had a different way to comment the git URL line
+
+Signed-off-by: Steve Lhomme <robux4@ycbcr.xyz>
+---
+ contrib/src/dav1d/SHA512SUMS | 2 +-
+ contrib/src/dav1d/rules.mak  | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/contrib/src/dav1d/SHA512SUMS b/contrib/src/dav1d/SHA512SUMS
+index 5d7d593ae20..641f4f75698 100644
+--- a/contrib/src/dav1d/SHA512SUMS
++++ b/contrib/src/dav1d/SHA512SUMS
+@@ -1 +1 @@
+-87026f8b14e408ff50fc8f137ec2ede4b14c5f69687e615d2359d0f718ae5cb5176522490786d9ae1f7838182f82615c2674f7c2961b6dcec83f1ee587c3af7c  dav1d-0.9.2.tar.xz
++a3a7e162e45181449cd42af3a4d36669a850a4ee9ab17641dcd63d84406444566e8ebc7caa55b0620ab581039f36d19a90218a40f52ebbe525b37ed9493fb3f3  dav1d-1.0.0.tar.xz
+diff --git a/contrib/src/dav1d/rules.mak b/contrib/src/dav1d/rules.mak
+index 9b4a508309a..e4583228316 100644
+--- a/contrib/src/dav1d/rules.mak
++++ b/contrib/src/dav1d/rules.mak
+@@ -1,6 +1,6 @@
+ # libdav1d
+-DAV1D_VERSION := 0.9.2
++DAV1D_VERSION := 1.0.0
+ DAV1D_URL := $(VIDEOLAN)/dav1d/$(DAV1D_VERSION)/dav1d-$(DAV1D_VERSION).tar.xz
+ PKGS += dav1d
+@@ -12,7 +12,7 @@ DAV1D_CONF = -D enable_tests=false -D enable_tools=false
+ $(TARBALLS)/dav1d-$(DAV1D_VERSION).tar.xz:
+       $(call download_pkg,$(DAV1D_URL),dav1d)
+-      #~ $(call download_git,$(DAV1D_URL),,$(DAV1D_HASH))
++#     $(call download_git,$(DAV1D_GITURL),,$(DAV1D_HASH))
+ .sum-dav1d: dav1d-$(DAV1D_VERSION).tar.xz
+-- 
+GitLab
+
diff --git a/vlc-srt.patch b/vlc-srt.patch
deleted file mode 100644 (file)
index 3c8a245..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- vlc-3.0.11.1/modules/access/srt.c.orig     2018-04-23 10:03:39.000000000 +0200
-+++ vlc-3.0.11.1/modules/access/srt.c  2021-01-19 17:25:25.629393995 +0100
-@@ -165,7 +165,7 @@
-     /* Set latency */
-     i_latency = var_InheritInteger( p_stream, "latency" );
--    srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
-+    srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
-         &i_latency, sizeof( int ) );
-     psz_passphrase = var_InheritString( p_stream, "passphrase" );
---- vlc-3.0.11.1/modules/access_output/srt.c.orig      2018-04-06 11:22:51.000000000 +0200
-+++ vlc-3.0.11.1/modules/access_output/srt.c   2021-01-19 17:27:11.342154633 +0100
-@@ -162,7 +162,7 @@
-     /* Set latency */
-     i_latency = var_InheritInteger( p_access, "latency" );
--    srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
-+    srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
-         &i_latency, sizeof( int ) );
-     if ( psz_passphrase != NULL && psz_passphrase[0] != '\0')
---- vlc-3.0.13/configure.ac.orig       2021-04-30 06:58:19.309080610 +0200
-+++ vlc-3.0.13/configure.ac    2021-04-30 07:28:29.499273968 +0200
-@@ -4016,7 +4016,7 @@
- dnl
- dnl  SRT plugin
- dnl
--PKG_ENABLE_MODULES_VLC([SRT], [access_srt access_output_srt], [srt >= 1.2.2 srt < 1.3.0], [SRT input/output plugin], [auto], [], [], [-DENABLE_SRT])
-+PKG_ENABLE_MODULES_VLC([SRT], [access_srt access_output_srt], [srt >= 1.2.2], [SRT input/output plugin], [auto], [], [], [-DENABLE_SRT])
- EXTEND_HELP_STRING([Visualisations and Video filter plugins:])
- dnl
index c8d16b6a2be99e310077051e8d3e3d54e4c81d8b..959b39c58ce54a0f744219bc60253b71564eaba0 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
 Summary:       VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
-Version:       3.0.16
-Release:       4
+Version:       3.0.17.3
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       https://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: efc5f7331c033bf81536531c6eba5aa5
+# Source0-md5: 82907be60cea14e1423dacd51a23cf62
 Patch0:                %{name}-buildflags.patch
 Patch1:                %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
@@ -86,7 +86,7 @@ Patch6:               %{name}-extern.patch
 Patch7:                %{name}-vsxu.patch
 Patch8:                qt-5.15.patch
 Patch9:                %{name}-live.patch
-Patch10:       %{name}-srt.patch
+Patch10:       %{name}-dav1d.patch
 Patch11:       opencv4.patch
 Patch12:       %{name}-libcaca.patch
 URL:           http://www.videolan.org/vlc/
@@ -154,7 +154,7 @@ BuildRequires:      libdc1394-devel >= 2.1.0
 BuildRequires: libdsm-devel >= 0.2.0
 BuildRequires: libdts-devel >= 0.0.5
 BuildRequires: libdvbpsi-devel >= 1.2.0
-BuildRequires: libdvdnav-devel >= 4.9.1
+BuildRequires: libdvdnav-devel >= 5.0.4
 BuildRequires: libdvdread-devel >= 4.9.1
 BuildRequires: libebml-devel >= 1.3.6
 BuildRequires: libgcrypt-devel >= 1.6.0
@@ -226,7 +226,7 @@ BuildRequires:      soxr-devel >= 0.1.2
 BuildRequires: spatialaudio-devel
 %{?with_speex:BuildRequires:   speex-devel > 1:1.1.0}
 %{?with_speex:BuildRequires:   speexdsp-devel >= 1.2}
-BuildRequires: srt-devel >= 1.4.1
+BuildRequires: srt-devel >= 1.3.0
 BuildRequires: sysfsutils-devel
 BuildRequires: systemd-devel >= 1:209
 BuildRequires: taglib-devel >= 1.9
@@ -293,15 +293,16 @@ Requires: schroedinger >= 1.0.10
 Requires:      soxr >= 0.1.2
 %{?with_speex:Requires:        speex > 1:1.1.0}
 %{?with_speex:Requires:        speexdsp >= 1.2}
-Requires:      srt >= 1.4.1
+Requires:      srt >= 1.3.0
 Requires:      taglib >= 1.9
 Requires:      wayland >= 1.5.91
 Requires:      xcb-util-keysyms >= 0.3.4
 Requires:      xdg-utils
-Obsoletes:     browser-plugin-vlc
-Obsoletes:     vlc-GGI
-Obsoletes:     vlc-SDL
-Obsoletes:     vlc-esd
+Obsoletes:     browser-plugin-vlc < 2
+Obsoletes:     vlc-GGI < 2
+Obsoletes:     vlc-SDL < 2.2.6-3
+Obsoletes:     vlc-esd < 1
+Obsoletes:     vlc-iceweasel-plugin < 1.0.0-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -325,6 +326,7 @@ Summary(pl.UTF-8):  Pliki nagłówkowe VLC
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      dbus-devel >= 1.6.0
+Obsoletes:     vlc-static < 1.0.0-3
 
 %description devel
 VLC header files.
@@ -360,8 +362,9 @@ Requires:   desktop-file-utils
 Requires:      hicolor-icon-theme
 Suggests:      dbus-x11 >= 1.6.0
 %{?with_caca:Suggests: libcaca > 0.99-0.beta20}
-Obsoletes:     vlc-gnome
-Obsoletes:     vlc-gtk
+Obsoletes:     vlc-gnome < 0.8.1-2
+Obsoletes:     vlc-gnome1 < 0.8.1-2
+Obsoletes:     vlc-gtk < 0.8.1-2
 
 %description X11
 X11 output plugin for VLC. Contains GUI image/icon resources.
@@ -628,7 +631,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libaccess_oss_plugin.so
 %endif
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libaccess_realrtsp_plugin.so
-# R: srt >= 1.2.2
+# R: srt >= 1.3.0
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libaccess_srt_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/access/libattachment_plugin.so
 # R: ffmpeg-libs (libavformat >= 53.21.0 libavcodec libavutil)
@@ -714,7 +717,7 @@ rm -rf $RPM_BUILD_ROOT
 # R: shout >= 2.1
 %attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_shout_plugin.so
 %endif
-# R: srt >= 1.2.2
+# R: srt >= 1.3.0
 %attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_srt_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/plugins/access_output/libaccess_output_udp_plugin.so
 %dir %{_libdir}/vlc/plugins/audio_filter
This page took 0.090962 seconds and 4 git commands to generate.