]> git.pld-linux.org Git - packages/vlc.git/commitdiff
updated libplacebo patch to fix build with api >= 20; rel 6
authorJan Palus <atler@pld-linux.org>
Tue, 3 Dec 2019 21:43:08 +0000 (22:43 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 3 Dec 2019 21:43:08 +0000 (22:43 +0100)
vlc-libplacebo.patch [moved from vlc-libplacebo-0.18.patch with 80% similarity]
vlc.spec

similarity index 80%
rename from vlc-libplacebo-0.18.patch
rename to vlc-libplacebo.patch
index fc13a6e3430b58d510b38983c1f7d98dad4b752f..b1f144e2997a11ed2380f8e5d97dbb748cdb99a2 100644 (file)
@@ -93,3 +93,32 @@ index a13f66c1cc..332f63c79e 100644
 -- 
 2.22.0
 
+From 24dc03640d3cfd89aa87ce63929aba17911c4b85 Mon Sep 17 00:00:00 2001
+From: Niklas Haas <git@haasn.xyz>
+Date: Mon, 6 May 2019 09:56:38 +0200
+Subject: [PATCH] opengl: update libplacebo call for changed API
+
+This will be the last time a change to this signature is needed, since
+we just switched to using a params struct rather than updating the
+signature constantly.
+
+Signed-off-by: Thomas Guillem <thomas@gllm.fr>
+---
+ modules/video_output/opengl/vout_helper.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/modules/video_output/opengl/vout_helper.c b/modules/video_output/opengl/vout_helper.c
+index f1069ccb1f9..b59343f7b5f 100644
+--- a/modules/video_output/opengl/vout_helper.c
++++ b/modules/video_output/opengl/vout_helper.c
+@@ -551,7 +551,9 @@ opengl_init_program(vout_display_opengl_t *vgl, vlc_video_context *context,
+     {
+         tc->pl_ctx = vlc_placebo_Create(VLC_OBJECT(tc));
+         if (tc->pl_ctx) {
+-#   if PL_API_VER >= 6
++#   if PL_API_VER >= 20
++            tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL);
++#   elif PL_API_VER >= 6
+             tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0);
+ #   else
+             tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);
index 53ac972778cd65ff9d0bc4193be45a59f063b47e..99610ee38b3bcaf1234679f1a04a56cecf1297ad 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -69,7 +69,7 @@ Summary:      VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
 Version:       3.0.8
-Release:       5
+Release:       6
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
@@ -80,7 +80,7 @@ Patch2:               %{name}-mpc.patch
 Patch3:                xmas-sucks.patch
 Patch4:                no-cache.patch
 Patch5:                %{name}-fdk_aac.patch
-Patch6:                %{name}-libplacebo-0.18.patch
+Patch6:                %{name}-libplacebo.patch
 URL:           http://www.videolan.org/vlc/
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
 BuildRequires: EGL-devel >= %{?with_glesv2:1.1}%{!?with_glesv2:1.0}
This page took 0.201201 seconds and 4 git commands to generate.