]> git.pld-linux.org Git - packages/vlc.git/commitdiff
- updated to 3.0.11.1 auto/th/vlc-3.0.11.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 Jan 2021 16:50:07 +0000 (17:50 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 Jan 2021 16:50:07 +0000 (17:50 +0100)
- added live patch (fixes build with live 2020.12+)
- added srt patch (fixes build with srt 1.4.1+)

vlc-live.patch [new file with mode: 0644]
vlc-srt.patch [new file with mode: 0644]
vlc.spec

diff --git a/vlc-live.patch b/vlc-live.patch
new file mode 100644 (file)
index 0000000..fc98d24
--- /dev/null
@@ -0,0 +1,13 @@
+--- vlc-3.0.11.1/modules/access/live555.cpp.orig       2019-03-29 20:01:15.000000000 +0100
++++ vlc-3.0.11.1/modules/access/live555.cpp    2021-01-19 06:23:21.598574547 +0100
+@@ -852,7 +852,9 @@
+             if( !p_sys->b_multicast )
+             {
+                 /* We need different rollover behaviour for multicast */
+-                p_sys->b_multicast = IsMulticastAddress( sub->connectionEndpointAddress() );
++                struct sockaddr_storage sa;
++                sub->getConnectionEndpointAddress( sa );
++                p_sys->b_multicast = IsMulticastAddress( sa );
+             }
+             tk = (live_track_t*)malloc( sizeof( live_track_t ) );
diff --git a/vlc-srt.patch b/vlc-srt.patch
new file mode 100644 (file)
index 0000000..c18beff
--- /dev/null
@@ -0,0 +1,22 @@
+--- vlc-3.0.11.1/modules/access/srt.c.orig     2018-04-23 10:03:39.000000000 +0200
++++ vlc-3.0.11.1/modules/access/srt.c  2021-01-19 17:25:25.629393995 +0100
+@@ -165,7 +165,7 @@
+     /* Set latency */
+     i_latency = var_InheritInteger( p_stream, "latency" );
+-    srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
++    srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
+         &i_latency, sizeof( int ) );
+     psz_passphrase = var_InheritString( p_stream, "passphrase" );
+--- vlc-3.0.11.1/modules/access_output/srt.c.orig      2018-04-06 11:22:51.000000000 +0200
++++ vlc-3.0.11.1/modules/access_output/srt.c   2021-01-19 17:27:11.342154633 +0100
+@@ -162,7 +162,7 @@
+     /* Set latency */
+     i_latency = var_InheritInteger( p_access, "latency" );
+-    srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
++    srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
+         &i_latency, sizeof( int ) );
+     if ( psz_passphrase != NULL && psz_passphrase[0] != '\0')
index 84a0f927d5042a64b2cb5e6226bd6813d3af3e5f..11c1448ac33cd06e3efc6e043fa3960e3902e81a 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
 Summary:       VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
-Version:       3.0.11
-Release:       4
+Version:       3.0.11.1
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
-Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 7e68f9e2d307eb7cc16e7345cda9e978
+Source0:       https://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: f797dc97305639f6270df619fe1c5962
 Patch0:                %{name}-buildflags.patch
 Patch1:                %{name}-tremor.patch
 Patch2:                %{name}-mpc.patch
@@ -84,7 +84,10 @@ Patch5:              %{name}-fdk_aac.patch
 Patch6:                %{name}-extern.patch
 Patch7:                %{name}-vsxu.patch
 Patch8:                qt-5.15.patch
+Patch9:                %{name}-live.patch
+Patch10:       %{name}-srt.patch
 URL:           http://www.videolan.org/vlc/
+%{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
 BuildRequires: EGL-devel >= %{?with_glesv2:1.1}%{!?with_glesv2:1.0}
 BuildRequires: OpenGL-devel
@@ -110,7 +113,6 @@ BuildRequires:      automake
 %{?with_daala:BuildRequires:   daala-devel}
 BuildRequires: dav1d-devel
 BuildRequires: dbus-devel >= 1.6.0
-%{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 BuildRequires: desktop-file-utils
 BuildRequires: faad2-devel >= 2.5
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
@@ -201,7 +203,7 @@ BuildRequires:      libvpx-devel >= 1.5.0
 BuildRequires: libxcb-devel >= 1.6
 BuildRequires: libxml2-devel >= 1:2.5
 %{?with_lirc:BuildRequires:    lirc-devel}
-%{?with_live:BuildRequires:    live-devel >= 2014.07.04}
+%{?with_live:BuildRequires:    live-devel >= 2020.12.23}
 BuildRequires: lua52 >= 5.2
 BuildRequires: lua52-devel >= 5.2
 %{?with_mfx:BuildRequires:     mfx_dispatch-devel}
@@ -221,7 +223,7 @@ BuildRequires:      soxr-devel >= 0.1.2
 BuildRequires: spatialaudio-devel
 %{?with_speex:BuildRequires:   speex-devel > 1:1.1.0}
 %{?with_speex:BuildRequires:   speexdsp-devel >= 1.2}
-BuildRequires: srt-devel >= 1.2.2
+BuildRequires: srt-devel >= 1.4.1
 BuildRequires: sysfsutils-devel
 BuildRequires: systemd-devel >= 1:209
 BuildRequires: taglib-devel >= 1.9
@@ -285,7 +287,7 @@ Requires:   schroedinger >= 1.0.10
 Requires:      soxr >= 0.1.2
 %{?with_speex:Requires:        speex > 1:1.1.0}
 %{?with_speex:Requires:        speexdsp >= 1.2}
-Requires:      srt >= 1.2.2
+Requires:      srt >= 1.4.1
 Requires:      taglib >= 1.9
 Requires:      wayland >= 1.5.91
 Requires:      xcb-util-keysyms >= 0.3.4
@@ -424,6 +426,8 @@ Akcje klienta VLC dla Solid.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
+%patch10 -p1
 
 %build
 %{__libtoolize}
This page took 0.307348 seconds and 4 git commands to generate.