]> git.pld-linux.org Git - packages/vlc.git/commitdiff
- fix atomic ops on gcc6 auto/th/vlc-2.2.4-5
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 11 Mar 2017 20:27:33 +0000 (21:27 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 11 Mar 2017 20:28:07 +0000 (21:28 +0100)
- disable projectM (broken headers on gcc6)
- rel 5

atomic.patch [new file with mode: 0644]
vlc.spec

diff --git a/atomic.patch b/atomic.patch
new file mode 100644 (file)
index 0000000..2b500bb
--- /dev/null
@@ -0,0 +1,49 @@
+From: Steve Lhomme <robux4@videolabs.io>
+Date: Thu, 9 Jun 2016 16:53:20 +0000 (+0200)
+Subject: vlc_atomic: atomic_compare_exchange_weak_explicit takes 5 parameters
+X-Git-Url: http://git.videolan.org/?p=vlc.git;a=commitdiff_plain;h=ea4edfb6aec493a8268b55d843729e5f0be52e04
+
+vlc_atomic: atomic_compare_exchange_weak_explicit takes 5 parameters
+
+Signed-off-by: Rémi Denis-Courmont <remi@remlab.net>
+---
+
+diff --git a/include/vlc_atomic.h b/include/vlc_atomic.h
+index ef0a1ee..e003f6d 100644
+--- a/include/vlc_atomic.h
++++ b/include/vlc_atomic.h
+@@ -144,7 +144,7 @@ typedef         uintmax_t atomic_uintmax_t;
+ #  define atomic_compare_exchange_weak(object,expected,desired) \
+     atomic_compare_exchange(object, expected, desired)
+-#  define atomic_compare_exchange_weak_explicit(object,expected,desired,order) \
++#  define atomic_compare_exchange_weak_explicit(object,expected,desired,order_equal,order_different) \
+     atomic_compare_exchange_weak(object, expected, desired)
+ #  define atomic_fetch_add(object,operand) \
+From 54bda02c8340298b0d6956cf4ad0423c09fc046e Mon Sep 17 00:00:00 2001
+From: Francois Cartegnie <fcvlcdev@free.fr>
+Date: Fri, 22 Jul 2016 13:03:10 +0200
+Subject: [PATCH] vlc_atomic: atomic_compare_exchange_strong_explicit takes 5
+ parameters
+
+---
+ include/vlc_atomic.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/vlc_atomic.h b/include/vlc_atomic.h
+index e003f6d..39e3347 100644
+--- a/include/vlc_atomic.h
++++ b/include/vlc_atomic.h
+@@ -138,7 +138,7 @@ typedef         uintmax_t atomic_uintmax_t;
+ #  define atomic_compare_exchange_strong(object,expected,desired) \
+     atomic_compare_exchange(object, expected, desired)
+-#  define atomic_compare_exchange_strong_explicit(object,expected,desired,order) \
++#  define atomic_compare_exchange_strong_explicit(object,expected,desired,order,order_different) \
+     atomic_compare_exchange_strong(object, expected, desired)
+ #  define atomic_compare_exchange_weak(object,expected,desired) \
+-- 
+2.1.4
+
index cab31fe1fb1b46ff8524898b4d013d44ea53364e..85c06077daab36912d5853b165ebe3a6e3b56eea 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -37,7 +37,7 @@
 %bcond_without notify          # libnotify notification plugin
 %bcond_without opencv          # OpenCV video filter [needs vlc API update]
 %bcond_with    oss4            # OSSv4
-%bcond_without projectM        # projectm visualization plugin
+%bcond_with    projectM        # projectm visualization plugin
 %bcond_without sftp            # SFTP file transfer via libssh2
 %bcond_without shout           # shout access output plugin
 %bcond_without smb             # SMB access plugin
@@ -65,7 +65,7 @@ Summary:      VLC - a multimedia player and stream server
 Summary(pl.UTF-8):     VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
 Version:       2.2.4
-Release:       4
+Release:       5
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.xz
@@ -76,6 +76,7 @@ Patch2:               %{name}-system-minizip.patch
 Patch3:                xmas-sucks.patch
 Patch4:                ffmpeg3.patch
 Patch5:                no-cache.patch
+Patch6:                atomic.patch
 URL:           http://www.videolan.org/vlc/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 # 1.0 for X11 or GLESv1, 1.1 for GLESv2
@@ -344,6 +345,7 @@ Akcje klienta VLC dla Solid.
 %endif
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 sed -i -e 's#Qt5#WANT_QT4#g' configure.ac
 
This page took 0.173723 seconds and 4 git commands to generate.