]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- disable macosx support (I've no idea why builders try to build it)
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 # - flac plugin doesn't work with mono files
9 #
10 # Conditional build:
11 %bcond_without  aa      # build without aalib support
12 %bcond_without  caca    # build without caca support
13 %bcond_without  dv      # build without dv support
14 %bcond_without  lirc    # build without lirc support
15 %bcond_without  x264    # build without x264 support
16 %bcond_without  alsa    # don't build alsa plugin
17 %bcond_without  arts    # don't build arts plugin
18 %bcond_without  ggi     # don't build ggi plugin
19 %bcond_without  live    # build without live.com support
20 %bcond_without  speex   # don't build speex plugin
21 %bcond_with     mozilla # build mozilla plugin
22 %bcond_with     slp     # build with slp, broken
23 %bcond_with     svgalib # build with svgalib video_output
24 %bcond_with     hal     # build with hal support
25 #
26 Summary:        VLC - a multimedia player and stream server
27 Summary(pl.UTF-8):      VLC - odtwarzacz multimedialny oraz serwer strumieni
28 Name:           vlc
29 Version:        0.8.6c
30 Release:        2
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 # use the bz2 src, its a 4mb difference
34 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
35 # Source0-md5:  c207f931f768e4dcde4bfaffdbf378cd
36 Source1:        %{name}.desktop
37 Patch0:         %{name}-altivec.patch
38 Patch1:         %{name}-buildflags.patch
39 Patch2:         %{name}-defaultfont.patch
40 Patch3:         %{name}-live.patch
41 Patch4:         %{name}-pic-mmx.patch
42 Patch5:         %{name}-real_codecs_path.patch
43 Patch6:         %{name}-osdmenu_path.patch
44 Patch7:         %{name}-wx.patch
45 URL:            http://www.videolan.org/vlc/
46 BuildRequires:  OpenGL-devel
47 BuildRequires:  SDL_image-devel >= 1.2
48 BuildRequires:  a52dec-libs-devel
49 %{?with_aa:BuildRequires:       aalib-devel}
50 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
51 %{?with_arts:BuildRequires:     artsc-devel}
52 BuildRequires:  autoconf
53 BuildRequires:  automake
54 BuildRequires:  esound-devel
55 BuildRequires:  faad2-devel >= 2.5
56 BuildRequires:  ffmpeg-devel >= 0.4.9
57 BuildRequires:  flac-devel >= 1.1.3
58 BuildRequires:  fribidi-devel
59 BuildRequires:  gettext-devel
60 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
61 %{?with_dv:BuildRequires:       libavc1394-devel}
62 %{?with_caca:BuildRequires:     libcaca-devel}
63 BuildRequires:  libcddb-devel
64 BuildRequires:  libcdio-devel
65 BuildRequires:  libdts-devel
66 %{?with_dv:BuildRequires:       libdv-devel}
67 BuildRequires:  libdvbpsi-devel
68 BuildRequires:  libdvdcss-devel
69 BuildRequires:  libdvdnav-devel
70 BuildRequires:  libdvdread-devel
71 BuildRequires:  libebml-devel >= 0.7.6
72 %{?with_ggi:BuildRequires:      libggi-devel}
73 BuildRequires:  libid3tag-devel
74 BuildRequires:  libmad-devel
75 BuildRequires:  libmatroska-devel >= 0.7.5
76 BuildRequires:  libmodplug-devel
77 BuildRequires:  libmpcdec-devel >= 1.2.1
78 BuildRequires:  libogg-devel
79 BuildRequires:  libpng-devel
80 %{?with_dv:BuildRequires:       libraw1394-devel}
81 BuildRequires:  libsmbclient-devel
82 BuildRequires:  libtheora-devel
83 BuildRequires:  libtool
84 BuildRequires:  libvorbis-devel
85 %{?with_x264:BuildRequires:     libx264-devel}
86 BuildRequires:  libxml2-devel
87 %{?with_lirc:BuildRequires:     lirc-devel}
88 %{?with_live:BuildRequires:     live >= 2005.03.11}
89 %{?with_mozilla:BuildRequires:  mozilla-devel}
90 BuildRequires:  mpeg2dec-devel >= 0.3.2
91 BuildRequires:  ncurses-devel
92 %{?with_slp:BuildRequires:      openslp-devel}
93 BuildRequires:  pkgconfig
94 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
95 %{?with_svgalib:BuildRequires:  svgalib-devel}
96 BuildRequires:  vcdimager-devel
97 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
98 BuildRequires:  xosd-devel
99 BuildRequires:  xvid-devel
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %description
103 VLC (initially VideoLAN Client) is a multimedia player for various
104 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
105 as well as DVDs, VCDs, and various streaming protocols. It can also be
106 used as a server to stream in unicast or multicast in IPv4 or IPv6 on
107 a high-bandwidth network.
108
109 %description -l pl.UTF-8
110 VLC (wcześniej znany pod nazwą VideoLAN Client) jest odtwarzaczem
111 multimedialnym dla wielu formatów wideo i dźwięku (MPEG-1, MPEG-2,
112 MPEG-4, DivX, MP3, Ogg, ...), płyt DVD, VCD oraz różnych protokołów
113 strumieniowych. Może być wykorzystany jako serwer do wysyłania
114 strumieni unicast lub multicast w protokołach IPv4 lub IPv6 w
115 wysokoprzepustowych sieciach.
116
117 %package devel
118 Summary:        VLC header files
119 Summary(pl.UTF-8):      Pliki nagłówkowe VLC
120 Group:          X11/Development/Libraries
121 Requires:       %{name} = %{version}-%{release}
122
123 %description devel
124 VLC header files.
125
126 %description devel -l pl.UTF-8
127 Pliki nagłówkowe VLC.
128
129 %package static
130 Summary:        VLC static libraries
131 Summary(pl.UTF-8):      Biblioteki statyczne VLC
132 Group:          X11/Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134
135 %description static
136 VLC static libraries.
137
138 %description static -l pl.UTF-8
139 Biblioteki statyczne VLC.
140
141 %package X11
142 Summary:        VLC - X11 output plugin
143 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia X11
144 Group:          X11/Applications/Multimedia
145 Requires:       %{name} = %{version}-%{release}
146 Obsoletes:      vlc-gnome
147 Obsoletes:      vlc-gtk
148
149 %description X11
150 X11 output plugin for VLC. Contains GUI image/icon resources.
151
152 %description X11 -l pl.UTF-8
153 Wtyczka wyjścia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
154 (obrazy/ikony).
155
156 %package GGI
157 Summary:        VLC - GGI output plugin
158 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia GGI
159 Group:          X11/Applications/Multimedia
160 Requires:       %{name} = %{version}-%{release}
161
162 %description GGI
163 GGI output plugin for VLC.
164
165 %description GGI -l pl.UTF-8
166 Wtyczka wyjścia GGI dla klienta VLC.
167
168 %package fb
169 Summary:        VLC - fb output plugin
170 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia fb
171 Group:          X11/Applications/Multimedia
172 Requires:       %{name} = %{version}-%{release}
173
174 %description fb
175 fb output plugin for VLC.
176
177 %description fb -l pl.UTF-8
178 Wtyczka wyjścia fb dla klienta VLC.
179
180 %package SDL
181 Summary:        VLC - SDL output plugin
182 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia SDL
183 Group:          X11/Applications/Multimedia
184 Requires:       %{name} = %{version}-%{release}
185
186 %description SDL
187 SDL output plugin for VLC.
188
189 %description SDL -l pl.UTF-8
190 Wtyczka wyjścia SDL dla klienta VLC.
191
192 %package esd
193 Summary:        VLC - EsounD audio output plugin
194 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia dźwięku EsounD
195 Group:          X11/Applications/Multimedia
196 Requires:       %{name} = %{version}-%{release}
197
198 %description esd
199 EsounD audio output plugin for VLC.
200
201 %description esd -l pl.UTF-8
202 Wtyczka wyjścia dźwięku EsounD dla klienta VLC.
203
204 %package alsa
205 Summary:        VLC - ALSA audio output plugin
206 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia dźwięku ALSA
207 Group:          X11/Applications/Multimedia
208 Requires:       %{name} = %{version}-%{release}
209
210 %description alsa
211 ALSA audio output plugin for VLC.
212
213 %description alsa -l pl.UTF-8
214 Wtyczka wyjścia dźwięku ALSA dla klienta VLC.
215
216 %prep
217 %setup -q
218 ## %patch0 -p1
219 %patch1 -p0
220 %patch2 -p1
221 %patch3 -p1
222 %patch4 -p1
223 %patch5 -p1
224 %patch6 -p1
225 %patch7 -p1
226
227 %build
228 cp -f /usr/share/automake/config.* .
229 %{__gettextize}
230 %{__aclocal} -I m4
231 %{__autoconf}
232 %configure \
233 %ifarch ppc
234         --disable-altivec \
235 %endif
236         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
237         %{?with_alsa:--enable-alsa} \
238         %{?with_arts:--enable-arts} \
239         %{!?with_arts:--disable-arts} \
240         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
241         --enable-dsp \
242         --enable-dummy \
243         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
244         --enable-dvb \
245         --enable-dvbpsi \
246         --with-dvdcss \
247         --enable-dvdnav \
248         --enable-dvdread \
249         --enable-esd \
250         --enable-faad \
251         --enable-fb \
252         --enable-freetype \
253         --enable-fribidi \
254         --enable-ffmpeg \
255         --enable-flac \
256         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
257         %{!?with_speex:--disable-speex} \
258         --disable-glide \
259         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
260         --enable-mad \
261         --enable-mga \
262         %{?with_mozilla:--enable-mozilla } \
263         %{?with_live:--enable-live555 } \
264         %{!?with_live:--disable-live555 } \
265         --with-live555-tree=%{_libdir}/liveMedia \
266         --enable-ncurses \
267         --enable-pvr \
268         --enable-real \
269         --enable-realrtsp \
270         --enable-sdl \
271         --with-sdl=/usr \
272         --enable-skins2 \
273         %{?with_slp:--enable-slp} \
274         %{!?with_slp:--disable-slp} \
275         --enable-smb \
276         %{?with_svgalib:--enable-svgalib} \
277         --enable-tarkin \
278         --enable-theora \
279         --enable-tremor \
280         --enable-v4l\
281         --enable-x11 \
282         %{!?with_x264:--disable-x264} \
283         --enable-xosd \
284         --enable-xvid \
285         --enable-oss \
286         --disable-testsuite \
287         --disable-macosx \
288         --with-wx-config=wx-gtk2-unicode-config \
289         %{!?with_hal:--disable-hal} \
290         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
291
292 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
293 %{__make}
294
295 %install
296 rm -rf $RPM_BUILD_ROOT
297 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
298
299 %{__make} install \
300         DESTDIR=$RPM_BUILD_ROOT
301
302 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
303 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
304
305 %if "%{_lib}" != "lib"
306 install -d $RPM_BUILD_ROOT%{_prefix}/lib
307 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
308 %endif
309
310 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/co
311
312 %find_lang %{name}
313
314 %clean
315 rm -rf $RPM_BUILD_ROOT
316
317 %files -f %{name}.lang
318 %defattr(644,root,root,755)
319 %doc AUTHORS MAINTAINERS NEWS README THANKS
320 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
321 %doc doc/intf-vcd.txt doc/translations.txt
322 %attr(755,root,root) %{_bindir}/vlc
323 %if "%{_lib}" != "lib"
324 %{_prefix}/lib/vlc
325 %endif
326 %dir %{_libdir}/vlc
327 %dir %{_libdir}/vlc/gui
328 %dir %{_libdir}/vlc/visualization
329 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
330 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
331 %attr(755,root,root) %{_libdir}/vlc/mux
332 %attr(755,root,root) %{_libdir}/vlc/misc
333 %attr(755,root,root) %{_libdir}/vlc/control
334 %attr(755,root,root) %{_libdir}/vlc/access_output
335 %attr(755,root,root) %{_libdir}/vlc/codec
336 %attr(755,root,root) %{_libdir}/vlc/demux
337 %attr(755,root,root) %{_libdir}/vlc/access
338 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
339 %attr(755,root,root) %{_libdir}/vlc/video_chroma
340 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
341 %attr(755,root,root) %{_libdir}/vlc/video_filter
342 %dir %{_libdir}/vlc/video_output
343 %attr(755,root,root) %{_libdir}/vlc/stream_out
344 %attr(755,root,root) %{_libdir}/vlc/audio_filter
345 %attr(755,root,root) %{_libdir}/vlc/packetizer
346 %attr(755,root,root) %{_libdir}/vlc/access_filter
347 %attr(755,root,root) %{_libdir}/vlc/services_discovery
348 %dir %{_libdir}/vlc/audio_output
349 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
350 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
351 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
352 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
353 %dir %{_datadir}/%{name}
354 %{_datadir}/%{name}/http
355 %{_datadir}/%{name}/osdmenu
356 %{_mandir}/man1/vlc.1*
357
358 %files devel
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_bindir}/vlc-config
361 %dir %{_includedir}/%{name}
362 %{_includedir}/%{name}/*
363
364 %files static
365 %defattr(644,root,root,755)
366 %{_libdir}/libvlc.a
367 %{_libdir}/%{name}/*.a
368
369 %files X11
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_bindir}/svlc
372 %attr(755,root,root) %{_bindir}/wxvlc
373 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
374 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
375 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
376 %attr(755,root,root) %{_libdir}/vlc/video_output
377 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
378 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
379 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
380 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
381 %{_datadir}/%{name}/skins2
382 %{_datadir}/%{name}/vlc*.xpm
383 %{_datadir}/%{name}/pda*.xpm
384 %{_datadir}/%{name}/vlc*.png
385 %{_datadir}/%{name}/vlc*.ico
386 %{_desktopdir}/*.desktop
387
388 %if %{with ggi}
389 %files GGI
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
392 %endif
393
394 %files SDL
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
397 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
398
399 %files fb
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
402
403 %files esd
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
406
407 %if %{with alsa}
408 %files alsa
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
411 %endif
This page took 0.096278 seconds and 3 git commands to generate.