]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
- updated to 0.6.0
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk2    # use GTK+ 2.x instead of GTK+ 3.x
4 %bcond_without  spice   # SPICE support
5 %bcond_with     ovirt   # oVirt support [requiring libgovirt, depending on rest >= 1.7.13]
6 #
7 Summary:        Virtual Machine Viewer
8 Summary(pl.UTF-8):      Przeglądarka maszyny wirtualnej
9 Name:           virt-viewer
10 Version:        0.6.0
11 Release:        1
12 License:        GPL v2+
13 Group:          X11/Applications/Networking
14 Source0:        https://fedorahosted.org/released/virt-viewer/%{name}-%{version}.tar.gz
15 # Source0-md5:  a3d7dd877105117e36185378ee1849ee
16 URL:            http://virt-manager.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel >= 0.14.1
20 BuildRequires:  glib2-devel >= 1:2.22.0
21 BuildRequires:  intltool >= 0.35.0
22 %{?with_ovirt:BuildRequires:    libgovirt-devel >= 0.3.0}
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  libvirt-devel >= 0.10.0
25 BuildRequires:  libxml2-devel >= 1:2.6.0
26 BuildRequires:  perl-tools-pod
27 BuildRequires:  rpmbuild(macros) >= 1.596
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  spice-protocol >= 0.10.1
30 %if %{with gtk2}
31 BuildRequires:  gtk+2-devel >= 2:2.18.0
32 BuildRequires:  gtk-vnc-devel >= 0.4.3
33 %{?with_spice:BuildRequires: spice-gtk2-devel >= 0.22}
34 %else
35 BuildRequires:  gtk+3-devel >= 3.0.0
36 BuildRequires:  gtk3-vnc-devel >= 0.4.3
37 %{?with_spice:BuildRequires: spice-gtk-devel >= 0.22}
38 %endif
39 Requires(post,postun):  gtk-update-icon-cache
40 Requires(post,postun):  shared-mime-info
41 Requires:       glib2 >= 1:2.22.0
42 Requires:       hicolor-icon-theme
43 Requires:       libvirt >= 0.10.0
44 Requires:       libxml2 >= 1:2.6.0
45 %if %{with gtk2}
46 Requires:       gtk+2 >= 2:2.18.0
47 Requires:       gtk-vnc >= 0.4.3
48 %{?with_spice:Requires: spice-gtk2 >= 0.22}
49 %else
50 Requires:       gtk+3 >= 3.0.0
51 Requires:       gtk3-vnc >= 0.4.3
52 %{?with_spice:Requires: spice-gtk >= 0.22}
53 %endif
54 %{?with_ovirt:Requires: libgovirt >= 0.3.0}
55 Suggests:       openssh-clients
56 Suggests:       gnome-keyring >= 0.4.9
57 Obsoletes:      virt-viewer-plugin
58 ExclusiveArch:  %{ix86} %{x8664} ia64
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Virtual Machine Viewer provides a graphical console client for
63 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
64 widgets to provide the display, and libvirt for looking up VNC/SPICE
65 server details.
66
67 %description -l pl.UTF-8
68 Virtual Machine Viewer udostępnia klienta graficznej konsoli do
69 łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
70 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
71 serwera VNC/SPICE.
72
73 %prep
74 %setup -q
75
76 %{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --disable-silent-rules \
86         --disable-update-mimedb \
87         %{__with_without spice spice-gtk} \
88         --with-gtk=%{?with_gtk2:2.0}%{!?with_gtk2:3.0} \
89         %{!?with_ovirt:--without-ovirt}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %find_lang %{name}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 %update_icon_cache hicolor
106 %update_mime_database
107
108 %postun
109 %update_icon_cache hicolor
110 %update_mime_database
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README
115 %attr(755,root,root) %{_bindir}/virt-viewer
116 %attr(755,root,root) %{_bindir}/remote-viewer
117 %dir %{_datadir}/%{name}
118 %dir %{_datadir}/%{name}/ui
119 %{_datadir}/%{name}/ui/*.xml
120 %{_datadir}/mime/packages/virt-viewer-mime.xml
121 %{_desktopdir}/remote-viewer.desktop
122 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
123 %{_mandir}/man1/virt-viewer.1*
124 %{_mandir}/man1/remote-viewer.1*
This page took 0.075331 seconds and 3 git commands to generate.