]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
- new
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk2
4 %bcond_without  gtk3
5 %bcond_without  spice
6 %bcond_with     plugin
7 #
8 Summary:        Virtual Machine Viewer
9 Name:           virt-viewer
10 Version:        0.4.2
11 Release:        1
12 License:        GPL v2+
13 Group:          X11/Applications/Networking
14 Source0:        http://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.gz
15 # Source0-md5:  4fc003cb655aa45b77c9f2ee45ba6d4f
16 URL:            http://virt-manager.org/
17 %if %{with gtk3}
18 BuildRequires:  gtk+3-devel >= 3.0.0
19 BuildRequires:  gtk3-vnc-devel >= 0.4.3
20 %{?with_spice:BuildRequires: spice-gtk-devel >= 0.6}
21 %else
22 BuildRequires:  gtk+2-devel >= 2.12.0
23 BuildRequires:  gtk-vnc-devel >= 0.4.3
24 %{?with_spice:BuildRequires: spice-gtk2-devel >= 0.6}
25 %endif
26 BuildRequires:  libvirt-devel >= 0.6.0
27 BuildRequires:  libxml2-devel
28 %{?with_plugin:BuildRequires: xulrunner-devel}
29 BuildRequires:  gettext-devel >= 0.14.1
30 BuildRequires:  glib2-devel
31 BuildRequires:  intltool >= 0.35.0
32 BuildRequires:  perl-tools-pod
33 Suggests:       openssh-clients
34 Suggests:       gnome-keyring >= 0.4.9
35 ExclusiveArch:  %{ix86} x86_64 ia64
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Virtual Machine Viewer provides a graphical console client for
40 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
41 widgets to provide the display, and libvirt for looking up VNC/SPICE
42 server details.
43
44 Virtual Machine Viewer provides a graphical console client for
45 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
46 widgets to provide the display, and libvirt for looking up VNC/SPICE
47 server details.
48
49 %package plugin
50 Summary:        Mozilla plugin for the gtk-vnc library
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description plugin
55 Virtual Machine Viewer provides a graphical
56 console client for connecting to virtual machines. It uses the GTK-VNC
57 or SPICE-GTK widgets to provide the display, and libvirt for looking
58 up VNC/SPICE server details.
59
60 This package provides a web browser plugin for Mozilla compatible
61 browsers.
62
63 %prep
64 %setup -q
65
66 %build
67 %configure \
68         %{__enable_disable plugin} \
69         %{__with_without spice spice-gtk} \
70         %{__with_without gtk2 gtk 2.0} \
71         %{__with_without gtk3 gtk 3.0}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %find_lang %{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files -f %{name}.lang
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog NEWS README
89 %attr(755,root,root) %{_bindir}/%{name}
90 %dir %{_datadir}/%{name}
91 %dir %{_datadir}/%{name}/ui
92 %{_datadir}/%{name}/ui/*.xml
93 %{_mandir}/man1/%{name}.1*
94
95 %if %{with plugin}
96 %files plugin
97 %defattr(644,root,root,755)
98 %endif
This page took 0.234464 seconds and 3 git commands to generate.