]> git.pld-linux.org Git - packages/vim.git/commitdiff
up to 7.4.861, linking fails
authorElan Ruusamäe <glen@delfi.ee>
Wed, 9 Sep 2015 09:36:14 +0000 (12:36 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 9 Sep 2015 10:15:07 +0000 (13:15 +0300)
7.4.813  it is not possible to save and restore character search state
7.4.814  illegal memory access with "sy match a fold"
7.4.815  invalid memory access when doing ":call g:"
7.4.816  invalid memory access when doing ":fun X("
7.4.817  invalid memory access in file_pat_to_reg_pat()
7.4.818  'linebreak' breaks c% if the last Visual selection was block
7.4.819  beeping when running the tests
7.4.820  invalid memory access in file_pat_to_reg_pat
7.4.821  coverity reports a few problem.
7.4.822  more problems reported by coverity
7.4.823  cursor moves after CTRL-A on alphabetic character
7.4.824  (after 7.4.813) can't compile without the multi-byte feature
7.4.825  invalid memory access for ":syn keyword x a["
7.4.826  compiler warnings and errors
7.4.827  not all test targets are in the Makefile
7.4.828  crash when using "syn keyword x c"
7.4.829  crash when clicking in beval balloon
7.4.830  resetting 'encoding' when doing ":set all&" causes problems
7.4.831  when error in expanding `=expr` the command is still executed
7.4.832  $HOME in `=$HOME . '/.vimrc'` is expanded too early
7.4.833  more side effects of ":set all&" are missing
7.4.834  gettabvar() doesn't work after Vim start
7.4.835  comparing utf-8 does not handle different byte sizes correctly
7.4.836  accessing unitinialized memory
7.4.837  compiler warning with MSVC compiler when using +sniff
7.4.838  (after 7.4.833) can't compile without the crypt feature
7.4.839  compiler warning on 64-bit system
7.4.840  (after 7.4.829) tooltip window stays open
7.4.841  can't compile without the multi-byte feature
7.4.842  sending too many messages to close the balloon
7.4.843  (after 7.4.835) still possible to go beyond end of a string
7.4.844  when '#' is in 'isident' the is# comparator doesn't work
7.4.845  compiler warning for possible loss of data
7.4.846  some GitHub users don't know how to use issues
7.4.847  "vi)d" may leave a character behind
7.4.848  CTRL-A on hex number in Visual block mode is incorrect
7.4.849  moving the cursor in Insert mode starts new undo sequence
7.4.850  <Esc> does not show up
7.4.851  saving and restoring console buffer does not work properly
7.4.852  MS-Windows console cannot input/output Unicode characters
7.4.853  "zt" in diff mode does not always work properly
7.4.854  missing information about runtime files
7.4.855  GTK: font glitches for combining characters
7.4.856  "zt" still doesn't work well with filler lines
7.4.857  dragging the current tab with the mouse doesn't work properly
7.4.858  it's a bit clumsy to execute a command on a list of matches
7.4.859  Vim doesn't recognize all htmldjango files
7.4.860  filetype detection is outdated
7.4.861  (after 7.4.855) pango_shape_full() is not always available

024_all_vim-6.3-bash-83565.patch [deleted file]
sources
vim-ft-bash.patch [deleted file]
vim.spec

diff --git a/024_all_vim-6.3-bash-83565.patch b/024_all_vim-6.3-bash-83565.patch
deleted file mode 100644 (file)
index 99f511e..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- runtime/filetype.vim       2005-03-25 01:47:52.000000000 +0000
-+++ runtime/filetype.vim       2005-03-25 01:48:53.000000000 +0000
-@@ -1302,6 +1302,7 @@
- " Shell scripts (sh, ksh, bash, bash2, csh); Allow .profile_foo etc.
- " Gentoo ebuilds are actually bash scripts
- au BufNewFile,BufRead .bashrc*,bashrc,bash.bashrc,.bash_profile*,.bash_logout*,*.bash,*.ebuild call SetFileTypeSH("bash")
-+au BufNewFile,BufRead /*/bash*completion*/* call SetFileTypeSH("bash")
- au BufNewFile,BufRead .kshrc*,*.ksh call SetFileTypeSH("ksh")
- au BufNewFile,BufRead /etc/profile,.profile*,*.sh,*.env call SetFileTypeSH(getline(1))
diff --git a/sources b/sources
index 0476760fa986a611243ec75e15d35ba480640733..3b4661d4675e7bee1090890a9437b4fdccdac16c 100644 (file)
--- a/sources
+++ b/sources
@@ -810,3 +810,52 @@ b002966fe760a381596f9b44b5002c23  7.4.809
 679755b0f194f26951f6be6b03e7762d  7.4.810
 192933f5e30a481683be115d63b876fb  7.4.811
 abcbee938367033022c30fbf2322c59d  7.4.812
+60d7b0c062b697ba7291c94408b607cd  7.4.813
+3d9ca0cf7f72bc00d0cf56e35335f355  7.4.814
+762fc93d3de5f8cf27c9454127c11c1f  7.4.815
+0ffb114f6dc21345adbc5ce8a56786db  7.4.816
+e25d14a870ad6fa188fcf0a30743268c  7.4.817
+10a1b21eb9d724c93fbfb94af951b178  7.4.818
+ac1374ebe424907456d027a6c986dcd1  7.4.819
+52e3edac1152843c456fd0786d851c00  7.4.820
+d8bbe78f2a33a5310fe5d3089f4ce2a3  7.4.821
+299862c27d864650292a2e04dabffc1f  7.4.822
+ba06df359b8204eaa6a422737888e1ed  7.4.823
+1e38d9f88bb2e015f6877330e2cf4bf8  7.4.824
+cc128cf9a2ed75406b3f3dfd5939151b  7.4.825
+4d9e58ca4e860de4c7b3e3083c0f53c9  7.4.826
+07faf34994ae686bdef2908613435840  7.4.827
+0b5177a19cd2af520c3bb3171dcaf447  7.4.828
+59050a89becda978b2841cd4dff2cde4  7.4.829
+d1867b764b0116baba62624a0d4c21bd  7.4.830
+47d221d6989aa844b054a09ff3f6597d  7.4.831
+6e193f35c3233b90843ed1242c8f6a7f  7.4.832
+bab2c8c7562a1eda798eadbd325c4018  7.4.833
+f10b9c702c1063fd0f653556509bee97  7.4.834
+ac4b91e1011d17e008c2d12f7e4475b6  7.4.835
+2c732a8679941e78edc97a925e3dc84d  7.4.836
+021a96a00a5be96b57024fc32aaf8017  7.4.837
+50a695a3edd59564d7583aaef6384df3  7.4.838
+455ab3edf8b8b0d2ae0f3ec3a30d5256  7.4.839
+e393c5b9b4d9a698c71c5d1259d3b80d  7.4.840
+b946fce1faa978755ca78dae7a5afafe  7.4.841
+c3a190c32f4ac0d1b95b2a6216bc69b0  7.4.842
+57199392def02fd0771a7fb73f5971d6  7.4.843
+f6f158c39afa4d262b9bc79b467bea1d  7.4.844
+ca8d5db99affd4ca6073421ab9f93990  7.4.845
+6103096bf0c737e731b2e35879d2849e  7.4.846
+0834356ddda5de3291983ac898eb808d  7.4.847
+1a3bd0e65f7d2ac8f15ef557f1083a8f  7.4.848
+9f76e1250d416bd0987182569b241de2  7.4.849
+7b20cb13f45ac24420a62fc01170256b  7.4.850
+84927ff09dbccb300aad6f19e3e0013c  7.4.851
+19aba79373e93167987468b2772c5d19  7.4.852
+48e1ab598300337e3d8d2ccbf672ed8d  7.4.853
+bb506f079b5c358122139ea192518f6b  7.4.854
+56e65525e9a3fdd5708c221c46080776  7.4.855
+275e12fafa3b23d439de3dab5b004e45  7.4.856
+aae493be7cfca3dcb1308e74e22fbea8  7.4.857
+2ad02585a9e53b0f1ab25d3ed4b039a7  7.4.858
+d1a4364611f41ce7ad209d79d9a296d8  7.4.859
+ef6df92896e4910984c881a28fe2ca2e  7.4.860
+b0fd7308ef340610974de5a08e19cb99  7.4.861
diff --git a/vim-ft-bash.patch b/vim-ft-bash.patch
deleted file mode 100644 (file)
index ef56108..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- vim72/runtime/filetype.vim~        2008-12-27 04:25:56.000000000 +0200
-+++ vim72/runtime/filetype.vim 2009-04-02 19:14:10.972877140 +0300
-@@ -1682,7 +1682,7 @@
- " Shell scripts (sh, ksh, bash, bash2, csh); Allow .profile_foo etc.
- " Gentoo ebuilds are actually bash scripts
- au BufNewFile,BufRead .bashrc*,bashrc,bash.bashrc,.bash_profile*,.bash_logout*,*.bash,*.ebuild call SetFileTypeSH("bash")
--au BufNewFile,BufRead /*/bash*completion*/* call SetFileTypeSH("bash")
-+au BufNewFile,BufRead /*/bash*completion,/*/bash*completion*/* call SetFileTypeSH("bash")
- au BufNewFile,BufRead .kshrc*,*.ksh call SetFileTypeSH("ksh")
- au BufNewFile,BufRead /etc/profile,.profile*,*.sh,*.env call SetFileTypeSH(getline(1))
index 303011fbd4926d22c60e838c69f7d28a92e7ad2d..8712f31c96ba9a1d2b24cb39e410c79680514ea5 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -28,8 +28,8 @@
 # VCS Commits: https://code.google.com/p/vim/source/browse/
 
 %define                ver             7.4
-%define                patchlevel      812
-%define                rel             1
+%define                patchlevel      861
+%define                rel             0.1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -89,7 +89,6 @@ Patch12:      010_all_%{name}-6.3-vixie.patch
 Patch13:       013_all_%{name}-7.0-cron-vars-79981.patch
 Patch14:       020_all_%{name}-7.0-fstab-tmpfs-size.patch
 Patch15:       021_all_%{name}-7.0-fstab-bogus-errors.patch
-Patch16:       024_all_%{name}-6.3-bash-83565.patch
 Patch17:       027_all_%{name}-7.0-automake-substitutions-93378.patch
 Patch18:       %{name}-smarty.patch
 Patch19:       %{name}-tutor-lessdeps.patch
@@ -104,7 +103,6 @@ Patch27:    %{name}-autopaste.patch
 Patch28:       %{name}-ft-cron.patch
 Patch29:       %{name}-phpscript.patch
 Patch30:       %{name}-pam.patch
-Patch31:       %{name}-ft-bash.patch
 Patch32:       %{name}-localedir.patch
 Patch33:       %{name}-locales.patch
 Patch34:       %{name}-rtdir.patch
@@ -762,7 +760,6 @@ jak również GUI GTK+2.
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
-%patch16 -p0
 %patch17 -p0
 %patch18 -p1
 %patch19 -p1
@@ -780,7 +777,6 @@ jak również GUI GTK+2.
 %patch28 -p1
 %patch29 -p1
 %patch30 -p1
-%patch31 -p1
 %patch32 -p1
 %patch33 -p1
 %patch34 -p1
This page took 0.266754 seconds and 4 git commands to generate.