]> git.pld-linux.org Git - packages/vim.git/commitdiff
use github tarball to contain runtime files changes
authorElan Ruusamäe <glen@delfi.ee>
Tue, 22 Dec 2015 09:04:50 +0000 (11:04 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 22 Dec 2015 09:05:37 +0000 (11:05 +0200)
see https://github.com/vim/vim/issues/512

vim-po-syntax.patch
vim.spec

index a5b378273c9c8a358f01431d3b2f26432bba86a7..a8577fc85d387209da5899b91a5355dcba50cc48 100644 (file)
@@ -1,18 +1,18 @@
---- vim-7.0/runtime/syntax/po.vim~     2005-06-22 13:57:45.000000000 +0200
-+++ vim-7.0/runtime/syntax/po.vim      2006-05-01 00:19:51.041176750 +0200
-@@ -43,6 +43,7 @@
- syn match     poCommentAutomatic "^#\..*$" 
- syn match     poCommentSources        "^#:.*$"
- syn match     poCommentFlags "^#,.*$" contains=poFlagFuzzy
+--- vim-7.4.979/runtime/syntax/po.vim~ 2015-12-19 16:28:18.000000000 +0200
++++ vim-7.4.979/runtime/syntax/po.vim  2015-12-22 10:39:56.522234440 +0200
+@@ -55,6 +55,7 @@
+ syn match     poDiffOld '\(^#| "[^{]*+}\|{+[^}]*+}\|{+[^}]*\|"$\)' contained
+ syn match     poDiffNew '\(^#| "[^{]*-}\|{-[^}]*-}\|{-[^}]*\|"$\)' contained
+ syn match     poCommentDiff "^#|.*$" contains=poDiffOld,poDiffNew
 +syn match     poUntranslated /^msgstr\s\+""\n\n/
  
  " Translations (also includes header fields as they appear in a translation msgstr)
  syn region poCommentKDE         start=+"_: +ms=s+1 end="\\n" end="\"\n^msgstr"me=s-1 contained
-@@ -86,6 +87,7 @@
-   HiLink poCommentFlags      Special
-   HiLink poCopyrightUnset    Todo
-   HiLink poFlagFuzzy         Todo
-+  HiLink poUntranslated      Todo
+@@ -103,6 +104,7 @@
+   HiLink poDiffOld           Todo
+   HiLink poDiffNew          Special
    HiLink poObsolete         Comment
++  HiLink poUntranslated      Todo
  
    HiLink poStatementMsgid   Statement
+   HiLink poStatementMsgstr  Statement
index d131200d54c673979bd02a32ffb2313e1be60917..c8eb39e936ddc550c337937c6c5c0866cc329300 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -31,7 +31,8 @@
 # VCS Commits: https://github.com/vim/vim/commits/master
 
 %define                ver             7.4
-%define                patchlevel      979
+%define                basever         %{ver}.979
+%define                patchlevel      %{nil}
 %define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
@@ -49,8 +50,9 @@ Release:      %{rel}
 Epoch:         4
 License:       Charityware
 Group:         Applications/Editors/Vim
-Source0:       ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
-# Source0-md5: 607e135c559be642f210094ad023dc65
+#Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
+Source0:       https://github.com/vim/vim/archive/v%{basever}.tar.gz
+# Source0-md5: dc289e3d5dd1b25e1e976ce7e704b47c
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -75,7 +77,9 @@ Source31:     borland.vim
 Source32:      oceandeep.vim
 # http://www.vim.org/scripts/script.php?script_id=1464 (2.6.3)
 Source33:      moria.vim
+%if 0
 %patchset_source -f ftp://ftp.vim.org/pub/editors/vim/patches/%{ver}/%{ver}.%03g 1 %{patchlevel}
+%endif
 Patch0:                %{name}-sysconfdir.patch
 Patch1:                %{name}-visual.patch
 Patch2:                %{name}-paths.patch
@@ -738,14 +742,16 @@ zawierającą obsługę skryptów w językach Perl, Python, Ruby oraz Tcl
 jak również GUI GTK+2.
 
 %prep
-%setup -q -n %{name}74
+%setup -q -n vim-%{basever}
 
+%if 0
 # official patches
 # patches 7.4.802, 7.4.809 do not apply
 # 7.4.802 does not apply and 7.4.809 attempts to revert 7.4.802
 %patchset_patch 1 801
 %patchset_patch 803 808
 %patchset_patch 810 %{patchlevel}
+%endif
 
 %patch0 -p1
 %patch1 -p1
This page took 0.142883 seconds and 4 git commands to generate.