]> git.pld-linux.org Git - packages/vim.git/commitdiff
sudoers: recognize #include and #includedir directives
authorElan Ruusamäe <glen@delfi.ee>
Fri, 27 Dec 2013 18:01:54 +0000 (20:01 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 27 Dec 2013 18:01:54 +0000 (20:01 +0200)
sudoers-include.patch [new file with mode: 0644]
vim.spec

diff --git a/sudoers-include.patch b/sudoers-include.patch
new file mode 100644 (file)
index 0000000..804287f
--- /dev/null
@@ -0,0 +1,28 @@
+--- vim74/runtime/syntax/sudoers.vim   2011-02-25 15:05:44.000000000 +0200
++++ vim74/runtime/syntax/sudoers.vim   2013-12-27 20:00:19.631344071 +0200
+@@ -23,7 +23,7 @@
+ syn keyword sudoersTodo               contained TODO FIXME XXX NOTE
+-syn region  sudoersComment            display oneline start='#' end='$' contains=sudoersTodo
++syn region  sudoersComment            display oneline start='#' end='$' contains=sudoersTodo,sudoersIncludeDirective
+ syn keyword sudoersAlias              User_Alias Runas_Alias nextgroup=sudoersUserAlias skipwhite skipnl
+ syn keyword sudoersAlias              Host_Alias nextgroup=sudoersHostAlias skipwhite skipnl
+@@ -142,6 +142,8 @@
+ syn match   sudoersCommandArgsInSpec contained '[^[:space:],:=\\]\+\%(\\[[:space:],:=\\][^[:space:],:=\\]*\)*' nextgroup=sudoersCommandArgsInSpec,@sudoersCmndSpec skipwhite
+ syn match   sudoersCommandEmptyInSpec contained '""' nextgroup=@sudoersCmndSpec skipwhite skipnl
++syn match   sudoersIncludeDirective '^#include\%(dir\)\=' nextgroup=sudoersStringParameter,sudoersListParameter
++
+ syn keyword sudoersDefaultEntry Defaults nextgroup=sudoersDefaultTypeAt,sudoersDefaultTypeColon,sudoersDefaultTypeGreaterThan,@sudoersParameter skipwhite skipnl
+ syn match   sudoersDefaultTypeAt          contained '@' nextgroup=@sudoersHost skipwhite skipnl
+ syn match   sudoersDefaultTypeColon       contained ':' nextgroup=@sudoersUser skipwhite skipnl
+@@ -320,6 +322,7 @@
+ hi def link sudoersCommandArgs              String
+ hi def link sudoersCommandEmpty             Special
+ hi def link sudoersDefaultEntry             Keyword
++hi def link sudoersIncludeDirective         Special
+ hi def link sudoersDefaultTypeAt            Special
+ hi def link sudoersDefaultTypeColon         Special
+ hi def link sudoersDefaultTypeGreaterThan   Special
index 5e46e0a30b6f36c9a9c75ae4963f23721c91911d..92987d215bdb5121d55ce6671331d805850ee0e5 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -97,6 +97,7 @@ Patch21:      %{name}-filetypes.patch
 Patch22:       %{name}-man_installation.patch
 Patch23:       %{name}-vimrc.patch
 Patch24:       %{name}-syntax-exports.patch
+Patch25:       sudoers-include.patch
 
 Patch102:      %{name}-gtkfilechooser.patch
 Patch104:      %{name}-home_etc.patch
@@ -129,8 +130,8 @@ BuildRequires:      gtk+2-devel >= 2:2.6.0
 %if %{with selinux} || %{with heavy}
 BuildRequires: libselinux-devel
 %endif
-BuildRequires: ncurses-devel
 %{?with_motif:BuildRequires:   motif-devel}
+BuildRequires: ncurses-devel
 BuildRequires: pkgconfig
 %if %{with perl} || %{with heavy}
 BuildRequires: perl-devel
@@ -749,6 +750,7 @@ jak również GUI GTK+2.
 %patch22 -p1
 %patch23 -p1
 %patch24 -p1
+%patch25 -p1
 
 # home etc
 %{?with_home_etc:%patch104 -p1}
This page took 0.189309 seconds and 4 git commands to generate.