]> git.pld-linux.org Git - packages/vim-plugin-coc.git/commitdiff
up to 0.0.81 auto/th/vim-plugin-coc-0.0.81-1
authorJan Palus <atler@pld-linux.org>
Wed, 25 May 2022 22:06:45 +0000 (00:06 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 25 May 2022 22:06:45 +0000 (00:06 +0200)
3211.patch [deleted file]
vim-plugin-coc.spec

diff --git a/3211.patch b/3211.patch
deleted file mode 100644 (file)
index b46af85..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-From ed1e2cb3fc69ca028993a75fe68c3f237961ed2b Mon Sep 17 00:00:00 2001
-From: Julian Grinblat <julian@dotcore.co.il>
-Date: Mon, 12 Jul 2021 18:47:08 +0900
-Subject: [PATCH 1/3] Fix command with complete but no nargs
-
----
- plugin/coc.vim | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugin/coc.vim b/plugin/coc.vim
-index 010406096d..7541d3f84d 100644
---- a/plugin/coc.vim
-+++ b/plugin/coc.vim
-@@ -481,7 +481,7 @@ command! -nargs=+ -complete=custom,s:ExtensionList  CocUninstall :call CocAction
- command! -nargs=* -complete=custom,s:CommandList -range CocCommand :call coc#rpc#notify('runCommand', [<f-args>])
- command! -nargs=* -complete=custom,coc#list#options CocList      :call coc#rpc#notify('openList',  [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocListResume   :call coc#rpc#notify('listResume', [<f-args>])
--command! -nargs=0 -complete=custom,coc#list#names CocListCancel   :call coc#rpc#notify('listCancel', [])
-+command! -nargs=0 CocListCancel   :call coc#rpc#notify('listCancel', [])
- command! -nargs=? -complete=custom,coc#list#names CocPrev         :call coc#rpc#notify('listPrev', [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocNext         :call coc#rpc#notify('listNext', [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocFirst        :call coc#rpc#notify('listFirst', [<f-args>])
-
-From 7ebea9e4f33f9d40347ef2e3440a2b1e25f9b3a3 Mon Sep 17 00:00:00 2001
-From: Julian Grinblat <julian@dotcore.co.il>
-Date: Mon, 12 Jul 2021 20:29:15 +0900
-Subject: [PATCH 2/3] Fix
-
----
- plugin/coc.vim | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugin/coc.vim b/plugin/coc.vim
-index 7541d3f84d..e817f945b1 100644
---- a/plugin/coc.vim
-+++ b/plugin/coc.vim
-@@ -481,7 +481,7 @@ command! -nargs=+ -complete=custom,s:ExtensionList  CocUninstall :call CocAction
- command! -nargs=* -complete=custom,s:CommandList -range CocCommand :call coc#rpc#notify('runCommand', [<f-args>])
- command! -nargs=* -complete=custom,coc#list#options CocList      :call coc#rpc#notify('openList',  [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocListResume   :call coc#rpc#notify('listResume', [<f-args>])
--command! -nargs=0 CocListCancel   :call coc#rpc#notify('listCancel', [])
-+command! -nargs=? CocListCancel   :call coc#rpc#notify('listCancel', [])
- command! -nargs=? -complete=custom,coc#list#names CocPrev         :call coc#rpc#notify('listPrev', [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocNext         :call coc#rpc#notify('listNext', [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocFirst        :call coc#rpc#notify('listFirst', [<f-args>])
-
-From c1040a75e5f6feffb48904da416e5ba077d2e8b7 Mon Sep 17 00:00:00 2001
-From: Julian Grinblat <julian@dotcore.co.il>
-Date: Mon, 12 Jul 2021 21:09:18 +0900
-Subject: [PATCH 3/3] Final fix
-
----
- plugin/coc.vim | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugin/coc.vim b/plugin/coc.vim
-index e817f945b1..80c2a8d6b8 100644
---- a/plugin/coc.vim
-+++ b/plugin/coc.vim
-@@ -481,7 +481,7 @@ command! -nargs=+ -complete=custom,s:ExtensionList  CocUninstall :call CocAction
- command! -nargs=* -complete=custom,s:CommandList -range CocCommand :call coc#rpc#notify('runCommand', [<f-args>])
- command! -nargs=* -complete=custom,coc#list#options CocList      :call coc#rpc#notify('openList',  [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocListResume   :call coc#rpc#notify('listResume', [<f-args>])
--command! -nargs=? CocListCancel   :call coc#rpc#notify('listCancel', [])
-+command! -nargs=? -complete=custom,coc#list#names CocListCancel   :call coc#rpc#notify('listCancel', [])
- command! -nargs=? -complete=custom,coc#list#names CocPrev         :call coc#rpc#notify('listPrev', [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocNext         :call coc#rpc#notify('listNext', [<f-args>])
- command! -nargs=? -complete=custom,coc#list#names CocFirst        :call coc#rpc#notify('listFirst', [<f-args>])
index 8d67cff83e6dc5716303c7c3e8ddc4611541180d..e7e966e6730add140785354edb29408c2c134360 100644 (file)
@@ -1,13 +1,12 @@
 %define                plugin coc
 Summary:       Vim plugin: Intellisense engine, full language server protocol support as VSCode
 Name:          vim-plugin-%{plugin}
-Version:       0.0.80
-Release:       2
+Version:       0.0.81
+Release:       1
 License:       MIT
 Group:         Applications/Editors/Vim
 Source0:       https://github.com/neoclide/coc.nvim/archive/v%{version}/coc.nvim-%{version}.tar.gz
-# Source0-md5: f95c0a917d46d8c0ffa85dd6f5a93a98
-Patch0:                3211.patch
+# Source0-md5: 9a3920855adf7970c5eb644bd46c669b
 URL:           https://github.com/neoclide/coc.nvim/
 Requires:      nodejs >= 10.12
 Requires:      vim-rt >= 4:8
@@ -40,7 +39,6 @@ Documentation for coc Vim plugin.
 
 %prep
 %setup -qn coc.nvim-%{version}
-%patch0 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.109375 seconds and 4 git commands to generate.