]> git.pld-linux.org Git - packages/vigra.git/commitdiff
- rel 5; lib64 build fix auto/th/vigra-1_8_0-5 auto/ti/vigra-1_8_0-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 18 Jan 2012 09:22:58 +0000 (09:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    vigra-1.8.0.lib_suffix.patch -> 1.1
    vigra.spec -> 1.24

vigra-1.8.0.lib_suffix.patch [new file with mode: 0644]
vigra.spec

diff --git a/vigra-1.8.0.lib_suffix.patch b/vigra-1.8.0.lib_suffix.patch
new file mode 100644 (file)
index 0000000..d813ca0
--- /dev/null
@@ -0,0 +1,78 @@
+Note: for some reason vigra uses a non-standard LIBDIR_SUFFIX definition
+whereas usually this is LIB_SUFFIX.  This patch fixes this since fedora expects
+to use the standard.
+
+diff -baur vigra-1.8.0/CMakeLists.txt vigra-1.8.0.new/CMakeLists.txt
+--- vigra-1.8.0/CMakeLists.txt 2011-09-20 19:38:36.000000000 +0100
++++ vigra-1.8.0.new/CMakeLists.txt     2011-09-24 21:20:55.000000000 +0100
+@@ -128,6 +128,8 @@
+ ENDIF()
++set(LIB_SUFFIX "" CACHE STRING "Define suffix of lib directory name (32/64)" )
++
+ ##################################################
+ #
+ #     global installation commands
+@@ -213,10 +215,10 @@
+ # export targets:
+ INSTALL(EXPORT vigra-targets
+-        DESTINATION lib${LIBDIR_SUFFIX}/vigra)
++        DESTINATION lib${LIB_SUFFIX}/vigra)
+ INSTALL(FILES ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfig.cmake
+             ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfigVersion.cmake
+-        DESTINATION lib${LIBDIR_SUFFIX}/vigra)
++        DESTINATION lib${LIB_SUFFIX}/vigra)
+ EXPORT(TARGETS vigraimpex FILE vigra-targets.cmake)
+ ##################################################
+@@ -289,7 +291,7 @@
+ MESSAGE( STATUS "---------------------------------------------------------" )
+ MESSAGE( STATUS "  includes will be installed at: ${CMAKE_INSTALL_PREFIX}/include")
+-MESSAGE( STATUS "  libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIBDIR_SUFFIX}")
++MESSAGE( STATUS "  libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
+ IF (MSVC)
+   MESSAGE( STATUS "  binaries and DLLs will be installed at: ${CMAKE_INSTALL_PREFIX}/bin")
+diff -baur vigra-1.8.0/doc/vigra/Installation.html vigra-1.8.0.new/doc/vigra/Installation.html
+--- vigra-1.8.0/doc/vigra/Installation.html    2011-09-20 19:43:37.000000000 +0100
++++ vigra-1.8.0.new/doc/vigra/Installation.html        2011-09-24 21:21:39.000000000 +0100
+@@ -58,8 +58,8 @@
+ <dd>build VIGRA Python bindings (default: 1). Pass -DWITH_VIGRANUMPY=0 to suppress vigranumpy. </dd>
+ <dt>-DWITH_HDF5=1 </dt>
+ <dd>build VIGRA with HDF5 support (default: 1). Pass -DDWITH_HDF5=0 to compile without HDF5. </dd>
+-<dt>-DLIBDIR_SUFFIX=64 </dt>
+-<dd>define suffix of lib directory name (default: empty string, i.e. no suffix). Use -DLIBDIR_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64. </dd>
++<dt>-DLIB_SUFFIX=64 </dt>
++<dd>define suffix of lib directory name (default: empty string, i.e. no suffix). Use -DLIB_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64. </dd>
+ </dl>
+ <p>More fine-grained customization (e.g. specification of explicit paths for all dependencies, customization of compiler flags) is possible by editing the file &lt;vigra_build_path&gt;/CMakeCache.txt. This is best done by means of the interactive programs <b>ccmake</b> or <b>cmake-gui</b>. Consult the <a href="http://www.cmake.org/cmake/help/documentation.html">cmake documentation</a> for more detailed help.</p>
+ <p>For using VIGRA in another CMake-built project, you can use the CMake command FIND_PACKAGE(Vigra), which will set the CMake variables ${Vigra_INCLUDE_DIRS} with the correct include path, and import the binary targets (currently vigraimpex) to link against (e.g., TARGET_LINK_LIBRARIES(targetname vigraimpex)). For this mechanism to work, CMake reads a config file VigraConfig.cmake, which is installed along with the library in CMAKE_INSTALL_PREFIX/lib/vigra. Alternatively, you can point CMake (cache entry Vigra_DIR) to VIGRA's build directory, where a corresponding VigraConfig.cmake resides for using the build version directly without installation. </p>
+diff -baur vigra-1.8.0/docsrc/installation.dxx vigra-1.8.0.new/docsrc/installation.dxx
+--- vigra-1.8.0/docsrc/installation.dxx        2011-09-20 19:38:36.000000000 +0100
++++ vigra-1.8.0.new/docsrc/installation.dxx    2011-09-24 21:19:52.000000000 +0100
+@@ -53,9 +53,9 @@
+          vigranumpy.
+     <DT> -DWITH_HDF5=1
+          <DD> build VIGRA with HDF5 support (default: 1). Pass -DDWITH_HDF5=0 to compile without HDF5.
+-    <DT> -DLIBDIR_SUFFIX=64
++    <DT> -DLIB_SUFFIX=64
+          <DD> define suffix of lib directory name (default: empty string, i.e. no suffix). Use 
+-         -DLIBDIR_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64.
++         -DLIB_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64.
+     </DL>
+     More fine-grained customization (e.g. specification of explicit paths for all dependencies, customization of compiler flags) is possible by editing the file &lt;vigra_build_path&gt;/CMakeCache.txt. This is best done by means of the interactive programs <b>ccmake</b> or <b>cmake-gui</b>. Consult the <a href="http://www.cmake.org/cmake/help/documentation.html">cmake documentation</a> for more detailed help.
+diff -baur vigra-1.8.0/src/impex/CMakeLists.txt vigra-1.8.0.new/src/impex/CMakeLists.txt
+--- vigra-1.8.0/src/impex/CMakeLists.txt       2011-09-20 19:38:36.000000000 +0100
++++ vigra-1.8.0.new/src/impex/CMakeLists.txt   2011-09-24 21:19:52.000000000 +0100
+@@ -80,5 +80,5 @@
+ INSTALL(TARGETS vigraimpex
+         EXPORT vigra-targets
+         RUNTIME DESTINATION bin 
+-        LIBRARY DESTINATION lib${LIBDIR_SUFFIX} 
+-        ARCHIVE DESTINATION lib${LIBDIR_SUFFIX})
++        LIBRARY DESTINATION lib${LIB_SUFFIX} 
++        ARCHIVE DESTINATION lib${LIB_SUFFIX})
index f0f0e73df3ea619128e30f8e84ad32d5b24cf929..10f5bf597110e25f9ddd33e228fb805e27bec2c4 100644 (file)
@@ -2,12 +2,13 @@ Summary:      Generic Programming for Computer Vision
 Summary(pl.UTF-8):     Ogólne programowanie obrazu komputerowego
 Name:          vigra
 Version:       1.8.0
-Release:       4
+Release:       5
 License:       MIT
 Group:         Libraries
 Source0:       http://hci.iwr.uni-heidelberg.de/vigra/%{name}-%{version}-src.tar.gz
 # Source0-md5: 15c5544448e529ee60020758ab6be264
 URL:           http://hci.iwr.uni-heidelberg.de/vigra/
+Patch0:                vigra-1.8.0.lib_suffix.patch
 BuildRequires: boost-python-devel >= 1.40.0
 BuildRequires: cmake >= 2.6.0
 BuildRequires: doxygen
@@ -90,6 +91,7 @@ Dokumentacja programisty do biblioteki vigra.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %cmake . \
This page took 0.040261 seconds and 4 git commands to generate.