]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- BR libtool with C++ support
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Summary(pl):    Ogólne programowanie obrazu komputerowego
3 Name:           vigra
4 Version:        1.2.0
5 Release:        1
6 License:        The VIGRA Artistic License
7 Group:          Libraries
8 Source0:        http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/%{name}%{version}.tar.gz
9 # Source0-md5:  fbb385e93d4b40469b04af4bc7079734
10 Patch0:         %{name}-ac.patch
11 URL:            http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  fftw-devel
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  libpng-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  libtool >= 2:1.4d
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 VIGRA stands for "Vision with Generic Algorithms". It's a novel
25 computer vision library that puts its main emphasize on customizable
26 algorithms and data structures. By using template techniques similar
27 to those in the C++ Standard Template Library, you can easily adapt
28 any VIGRA component to the needs of your application, without thereby
29 giving up execution speed.
30
31 %description -l pl
32 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
33 algorytmami). Jest to nowa biblioteka do obrazu komputerowego k³ad±ca
34 g³ówny nacisk na algorytmy i struktury danych z mo¿liwo¶ci±
35 dostosowania do w³asnych potrzeb. Poprzez u¿ycie technik szablonów
36 podobnych do tych w standardowej bibliotece szablonów C++ (STL) mo¿na
37 ³atwo zaadaptowaæ dowolny komponent VIGRA do potrzeb w³asnej aplikacji
38 bez po¶wiêcania szybko¶ci wykonywania.
39
40 %package devel
41 Summary:        Header files for vigra library
42 Summary(pl):    Pliki nag³ówkowe biblioteki vigra
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libjpeg-devel
46 Requires:       libpng-devel
47 Requires:       libstdc++-devel
48 Requires:       libtiff-devel
49
50 %description devel
51 Header files needed to compile programs with vigra.
52
53 %description devel -l pl
54 Pliki nag³ówkowe potrzebne do budowania programów u¿ywaj±cych
55 biblioteki vigra.
56
57 %package static
58 Summary:        vigra - static library
59 Summary(pl):    Statyczna biblioteka vigra
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static version of vigra library.
65
66 %description static -l pl
67 Statyczna wersja biblioteki vigra.
68
69 %package doc
70 Summary:        Development documentation for vigra library
71 Summary(pl):    Dokumentacja programisty do biblioteki vigra
72 Group:          Documentation
73
74 %description doc
75 Development documentation for vigra library.
76
77 %description doc -l pl
78 Dokumentacja programisty do biblioteki vigra.
79
80 %prep
81 %setup -q -n %{name}%{version}
82 %patch0 -p1
83
84 tail -n +510 config/acinclude.m4 > acinclude.m4
85 ln -sf config/configure.in .
86
87 %build
88 cp -f /usr/share/automake/config.* config
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %configure \
93         --with-fftw \
94         --with-jpeg \
95         --with-png \
96         --with-tiff \
97         --with-zlib
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         prefix=$RPM_BUILD_ROOT%{_prefix} \
106         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
107         bindir=$RPM_BUILD_ROOT%{_bindir} \
108         includedir=$RPM_BUILD_ROOT%{_includedir} \
109         libdir=$RPM_BUILD_ROOT%{_libdir}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc LICENSE README
120 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_bindir}/vigra-config
125 %attr(755,root,root) %{_libdir}/lib*.so
126 %{_libdir}/lib*.la
127 %{_includedir}/vigra
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
132
133 %files doc
134 %defattr(644,root,root,755)
135 %doc @docdir@/[!L]*
This page took 0.11069 seconds and 4 git commands to generate.