]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
boost rebuild
[packages/vigra.git] / vigra.spec
1 # TODO: lemon support, WITH_LEMON
2 Summary:        Generic Programming for Computer Vision
3 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
4 Name:           vigra
5 Version:        1.11.1
6 Release:        7
7 License:        MIT
8 Group:          Libraries
9 #Source0Download: http://ukoethe.github.io/vigra/#download
10 Source0:        https://github.com/ukoethe/vigra/releases/download/Version-1-11-1/%{name}-%{version}-src.tar.gz
11 # Source0-md5:  e72faf9fb82fa71fa63ba064bb63b703
12 Patch0:         python-install.patch
13 Patch1:         boost-python.patch
14 # https://src.fedoraproject.org/rpms/vigra/raw/master/f/81958d302494e137f98a8b1d7869841532f90388.patch
15 Patch2:         %{name}-multi_convolution.patch
16 URL:            http://ukoethe.github.io/vigra/
17 BuildRequires:  OpenEXR-devel
18 BuildRequires:  boost-python-devel >= 1.40.0
19 BuildRequires:  cmake >= 2.6.0
20 BuildRequires:  doxygen
21 BuildRequires:  fftw3-single-devel
22 BuildRequires:  hdf5-devel >= 1.8
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel >= 2:1.4.0
25 BuildRequires:  libstdc++-devel >= 6:4.4
26 BuildRequires:  libtiff-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python >= 1:2.7
29 BuildRequires:  python-devel >= 1:2.7
30 BuildRequires:  python-numpy-devel
31 BuildRequires:  rpmbuild(macros) >= 1.586
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  sphinx-pdg
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 VIGRA stands for "Vision with Generic Algorithms". It's a novel
39 computer vision library that puts its main emphasize on customizable
40 algorithms and data structures. By using template techniques similar
41 to those in the C++ Standard Template Library, you can easily adapt
42 any VIGRA component to the needs of your application, without thereby
43 giving up execution speed.
44
45 %description -l pl.UTF-8
46 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
47 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
48 główny nacisk na algorytmy i struktury danych z możliwością
49 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
50 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
51 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
52 bez poświęcania szybkości wykonywania.
53
54 %package devel
55 Summary:        Header files for vigra library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       fftw3-single-devel
60 Requires:       hdf5-devel >= 1.8
61 Requires:       libjpeg-devel
62 Requires:       libpng-devel >= 2:1.4.0
63 Requires:       libstdc++-devel
64 Requires:       libtiff-devel
65 Obsoletes:      vigra-static
66
67 %description devel
68 Header files needed to compile programs with vigra.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe potrzebne do budowania programów używających
72 biblioteki vigra.
73
74 %package -n python-vigra
75 Summary:        VIGRA Python bindings
76 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
77 Group:          Libraries/Python
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       python-numpy
80 Suggests:       python-PyQt4
81
82 %description -n python-vigra
83 VIGRA Python bindings.
84
85 %description -n python-vigra -l pl.UTF-8
86 Wiązania Pythona do biblioteki VIGRA.
87
88 %package -n python-vigra-devel
89 Summary:        Development file for VIGRA Python bindings
90 Summary(pl.UTF-8):      Plik programistyczny wiązań Pythona do biblioteki VIGRA
91 Group:          Development/Libraries
92 Requires:       cmake
93 Requires:       python-vigra = %{version}-%{release}
94
95 %description -n python-vigra-devel
96 Development (cmake config) file for VIGRA Python bindings.
97
98 %description -n python-vigra-devel -l pl.UTF-8
99 Plik programistyczny (konfiguracja cmake'a) dla wiązań Pythona do
100 biblioteki VIGRA.
101
102 %package doc
103 Summary:        Development documentation for vigra library
104 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
105 Group:          Documentation
106
107 %description doc
108 Development documentation for vigra library.
109
110 %description doc -l pl.UTF-8
111 Dokumentacja programisty do biblioteki vigra.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %patch1 -p1
117 %patch2 -p1
118
119 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' config/vigra-config.in
120
121 %build
122 %cmake . \
123         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
124         -DWITH_BOOST_GRAPH=ON \
125         -DWITH_OPENEXR=ON
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
136 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
137 %py_postclean
138
139 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc LICENSE.txt README.md
150 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.11
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/vigra-config
156 %attr(755,root,root) %{_libdir}/libvigraimpex.so
157 %{_includedir}/vigra
158 %dir %{_libdir}/vigra
159 %{_libdir}/vigra/VigraConfig*.cmake
160 %{_libdir}/vigra/vigra-targets*.cmake
161
162 %files -n python-vigra
163 %defattr(644,root,root,755)
164 %dir %{py_sitedir}/vigra
165 %attr(755,root,root) %{py_sitedir}/vigra/*.so
166 %{py_sitedir}/vigra/*.py[co]
167 %dir %{py_sitedir}/vigra/pyqt
168 %{py_sitedir}/vigra/pyqt/*.py[co]
169
170 %files -n python-vigra-devel
171 %defattr(644,root,root,755)
172 %dir %{_libdir}/vigranumpy
173 %{_libdir}/vigranumpy/VigranumpyConfig.cmake
174
175 %files doc
176 %defattr(644,root,root,755)
177 %doc doc/{vigra,vigranumpy}
This page took 0.053212 seconds and 3 git commands to generate.