]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- release 9 (by relup.sh)
[packages/vigra.git] / vigra.spec
1 # TODO: [lib]lemon, WITH_LEMON
2 Summary:        Generic Programming for Computer Vision
3 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
4 Name:           vigra
5 Version:        1.10.0
6 Release:        9
7 License:        MIT
8 Group:          Libraries
9 #Source0Download: http://ukoethe.github.io/vigra/#download
10 Source0:        https://github.com/ukoethe/vigra/releases/download/Version-1-10-0/%{name}-%{version}-src-with-docu.tar.gz
11 # Source0-md5:  85e2968e4ee5f9541b5dd8b3fb9cc433
12 URL:            http://hci.iwr.uni-heidelberg.de/vigra/
13 BuildRequires:  OpenEXR-devel
14 BuildRequires:  boost-python-devel >= 1.40.0
15 BuildRequires:  cmake >= 2.6.0
16 BuildRequires:  doxygen
17 BuildRequires:  fftw3-single-devel
18 BuildRequires:  hdf5-devel >= 1.8
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libpng-devel >= 2:1.4.0
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtiff-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  python
25 BuildRequires:  python-devel
26 BuildRequires:  python-numpy-devel
27 BuildRequires:  rpmbuild(macros) >= 1.586
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 VIGRA stands for "Vision with Generic Algorithms". It's a novel
34 computer vision library that puts its main emphasize on customizable
35 algorithms and data structures. By using template techniques similar
36 to those in the C++ Standard Template Library, you can easily adapt
37 any VIGRA component to the needs of your application, without thereby
38 giving up execution speed.
39
40 %description -l pl.UTF-8
41 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
42 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
43 główny nacisk na algorytmy i struktury danych z możliwością
44 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
45 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
46 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
47 bez poświęcania szybkości wykonywania.
48
49 %package devel
50 Summary:        Header files for vigra library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       fftw3-single-devel
55 Requires:       hdf5-devel >= 1.8
56 Requires:       libjpeg-devel
57 Requires:       libpng-devel >= 2:1.4.0
58 Requires:       libstdc++-devel
59 Requires:       libtiff-devel
60 Obsoletes:      vigra-static
61
62 %description devel
63 Header files needed to compile programs with vigra.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe potrzebne do budowania programów używających
67 biblioteki vigra.
68
69 %package -n python-vigra
70 Summary:        VIGRA Python bindings
71 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
72 Group:          Libraries/Python
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       python-numpy
75 Suggests:       python-PyQt4
76
77 %description -n python-vigra
78 VIGRA Python bindings.
79
80 %description -n python-vigra -l pl.UTF-8
81 Wiązania Pythona do biblioteki VIGRA.
82
83 %package -n python-vigra-devel
84 Summary:        Development file for VIGRA Python bindings
85 Summary(pl.UTF-8):      Plik programistyczny wiązań Pythona do biblioteki VIGRA
86 Group:          Development/Libraries
87 Requires:       cmake
88 Requires:       python-vigra = %{version}-%{release}
89
90 %description -n python-vigra-devel
91 Development (cmake config) file for VIGRA Python bindings.
92
93 %description -n python-vigra-devel -l pl.UTF-8
94 Plik programistyczny (konfiguracja cmake'a) dla wiązań Pythona do
95 biblioteki VIGRA.
96
97 %package doc
98 Summary:        Development documentation for vigra library
99 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
100 Group:          Documentation
101
102 %description doc
103 Development documentation for vigra library.
104
105 %description doc -l pl.UTF-8
106 Dokumentacja programisty do biblioteki vigra.
107
108 %prep
109 %setup -q
110
111 %build
112 %cmake . \
113         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
114         -DWITH_BOOST_GRAPH=ON \
115         -DWITH_OPENEXR=ON
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
126 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
127 %py_postclean
128
129 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc LICENSE.txt README.md
140 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.5
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/vigra-config
146 %attr(755,root,root) %{_libdir}/libvigraimpex.so
147 %{_includedir}/vigra
148 %dir %{_libdir}/vigra
149 %{_libdir}/vigra/VigraConfig*.cmake
150 %{_libdir}/vigra/vigra-targets*.cmake
151
152 %files -n python-vigra
153 %defattr(644,root,root,755)
154 %dir %{py_sitedir}/vigra
155 %attr(755,root,root) %{py_sitedir}/vigra/*.so
156 %{py_sitedir}/vigra/*.py[co]
157 %dir %{py_sitedir}/vigra/pyqt
158 %{py_sitedir}/vigra/pyqt/*.py[co]
159
160 %files -n python-vigra-devel
161 %defattr(644,root,root,755)
162 %dir %{_libdir}/vigranumpy
163 %{_libdir}/vigranumpy/VigranumpyConfig.cmake
164
165 %files doc
166 %defattr(644,root,root,755)
167 %doc doc/{vigra,vigranumpy}
This page took 0.090306 seconds and 3 git commands to generate.