]> git.pld-linux.org Git - packages/vcmi.git/commitdiff
- up to 0.97 auto/th/vcmi-0.97-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 6 Nov 2014 22:25:10 +0000 (23:25 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 6 Nov 2014 22:25:25 +0000 (23:25 +0100)
ax_boost_iostreams.m4 [deleted file]
boost-build.patch [deleted file]
vcmi.spec

diff --git a/ax_boost_iostreams.m4 b/ax_boost_iostreams.m4
deleted file mode 100644 (file)
index 9d73626..0000000
+++ /dev/null
@@ -1,116 +0,0 @@
-# ===========================================================================
-#    http://www.gnu.org/software/autoconf-archive/ax_boost_iostreams.html
-# ===========================================================================
-#
-# SYNOPSIS
-#
-#   AX_BOOST_IOSTREAMS
-#
-# DESCRIPTION
-#
-#   Test for IOStreams library from the Boost C++ libraries. The macro
-#   requires a preceding call to AX_BOOST_BASE. Further documentation is
-#   available at <http://randspringer.de/boost/index.html>.
-#
-#   This macro calls:
-#
-#     AC_SUBST(BOOST_IOSTREAMS_LIB)
-#
-#   And sets:
-#
-#     HAVE_BOOST_IOSTREAMS
-#
-# LICENSE
-#
-#   Copyright (c) 2008 Thomas Porschberg <thomas@randspringer.de>
-#
-#   Copying and distribution of this file, with or without modification, are
-#   permitted in any medium without royalty provided the copyright notice
-#   and this notice are preserved. This file is offered as-is, without any
-#   warranty.
-
-#serial 20
-
-AC_DEFUN([AX_BOOST_IOSTREAMS],
-[
-       AC_ARG_WITH([boost-iostreams],
-       AS_HELP_STRING([--with-boost-iostreams@<:@=special-lib@:>@],
-                   [use the IOStreams library from boost - it is possible to specify a certain library for the linker
-                        e.g. --with-boost-iostreams=boost_iostreams-gcc-mt-d-1_33_1 ]),
-        [
-        if test "$withval" = "no"; then
-                       want_boost="no"
-        elif test "$withval" = "yes"; then
-            want_boost="yes"
-            ax_boost_user_iostreams_lib=""
-        else
-                   want_boost="yes"
-               ax_boost_user_iostreams_lib="$withval"
-               fi
-        ],
-        [want_boost="yes"]
-       )
-
-       if test "x$want_boost" = "xyes"; then
-        AC_REQUIRE([AC_PROG_CC])
-               CPPFLAGS_SAVED="$CPPFLAGS"
-               CPPFLAGS="$CPPFLAGS $BOOST_CPPFLAGS"
-               export CPPFLAGS
-
-               LDFLAGS_SAVED="$LDFLAGS"
-               LDFLAGS="$LDFLAGS $BOOST_LDFLAGS"
-               export LDFLAGS
-
-        AC_CACHE_CHECK(whether the Boost::IOStreams library is available,
-                                          ax_cv_boost_iostreams,
-        [AC_LANG_PUSH([C++])
-                AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[@%:@include <boost/iostreams/filtering_stream.hpp>
-                                                                                        @%:@include <boost/range/iterator_range.hpp>
-                                                                                       ]],
-                                  [[std::string  input = "Hello World!";
-                                                                namespace io = boost::iostreams;
-                                                                        io::filtering_istream  in(boost::make_iterator_range(input));
-                                                                        return 0;
-                                   ]])],
-                             ax_cv_boost_iostreams=yes, ax_cv_boost_iostreams=no)
-         AC_LANG_POP([C++])
-               ])
-               if test "x$ax_cv_boost_iostreams" = "xyes"; then
-                       AC_DEFINE(HAVE_BOOST_IOSTREAMS,,[define if the Boost::IOStreams library is available])
-            BOOSTLIBDIR=`echo $BOOST_LDFLAGS | sed -e 's/@<:@^\/@:>@*//'`
-            if test "x$ax_boost_user_iostreams_lib" = "x"; then
-                for libextension in `ls $BOOSTLIBDIR/libboost_iostreams*.so* $BOOSTLIBDIR/libboost_iostream*.dylib* $BOOSTLIBDIR/libboost_iostreams*.a* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_iostreams.*\)\.so.*$;\1;' -e 's;^lib\(boost_iostream.*\)\.dylib.*$;\1;' -e 's;^lib\(boost_iostreams.*\)\.a.*$;\1;'` ; do
-                     ax_lib=${libextension}
-                                   AC_CHECK_LIB($ax_lib, exit,
-                                 [BOOST_IOSTREAMS_LIB="-l$ax_lib"; AC_SUBST(BOOST_IOSTREAMS_LIB) link_iostreams="yes"; break],
-                                 [link_iostreams="no"])
-                               done
-                if test "x$link_iostreams" != "xyes"; then
-                for libextension in `ls $BOOSTLIBDIR/boost_iostreams*.dll* $BOOSTLIBDIR/boost_iostreams*.a* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_iostreams.*\)\.dll.*$;\1;' -e 's;^\(boost_iostreams.*\)\.a.*$;\1;'` ; do
-                     ax_lib=${libextension}
-                                   AC_CHECK_LIB($ax_lib, exit,
-                                 [BOOST_IOSTREAMS_LIB="-l$ax_lib"; AC_SUBST(BOOST_IOSTREAMS_LIB) link_iostreams="yes"; break],
-                                 [link_iostreams="no"])
-                               done
-                fi
-
-            else
-               for ax_lib in $ax_boost_user_iostreams_lib boost_iostreams-$ax_boost_user_iostreams_lib; do
-                                     AC_CHECK_LIB($ax_lib, main,
-                                   [BOOST_IOSTREAMS_LIB="-l$ax_lib"; AC_SUBST(BOOST_IOSTREAMS_LIB) link_iostreams="yes"; break],
-                                   [link_iostreams="no"])
-                  done
-
-            fi
-            if test "x$ax_lib" = "x"; then
-                AC_MSG_ERROR(Could not find a version of the library!)
-            fi
-                       if test "x$link_iostreams" != "xyes"; then
-                               AC_MSG_ERROR(Could not link against $ax_lib !)
-                       fi
-               fi
-
-               CPPFLAGS="$CPPFLAGS_SAVED"
-       LDFLAGS="$LDFLAGS_SAVED"
-       fi
-])
diff --git a/boost-build.patch b/boost-build.patch
deleted file mode 100644 (file)
index 282a6f7..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- vcmi-0.90/configure.ac~    2012-10-05 20:04:31.000000000 +0200
-+++ vcmi-0.90/configure.ac     2012-11-13 21:14:33.852942118 +0100
-@@ -50,6 +50,7 @@
- AX_BOOST_BASE([1.36])
- AX_BOOST_SYSTEM
- AX_BOOST_FILESYSTEM
-+AX_BOOST_IOSTREAMS
- AX_BOOST_THREAD
- AX_BOOST_PROGRAM_OPTIONS
index f7e65c29daae556a358ccbd855a3afabbe0d4863..3c48fe92768a6427b21ca53af35420d745aab8b8 100644 (file)
--- a/vcmi.spec
+++ b/vcmi.spec
@@ -1,22 +1,21 @@
 Summary:       Heroes 3: WoG recreated
 Name:          vcmi
-Version:       0.90
-Release:       9
+Version:       0.97
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Games
-Source0:       http://download.vcmi.eu/%{name}_%{version}.tar.gz
-# Source0-md5: ab6772d9b8010925e6c00847b7c63c0d
+Source0:       https://github.com/vcmi/vcmi/archive/%{version}.tar.gz
+# Source0-md5: 11f2000244622706773ce37ca2366ebb
 Source1:       http://download.vcmi.eu/core.zip
 # Source1-md5: 5cf75d588cc53b93aceb809a6068ae37
-Source2:       ax_boost_iostreams.m4
-Patch0:                boost-build.patch
 URL:           http://www.vcmi.eu/
-BuildRequires: SDL-devel
-BuildRequires: SDL_image-devel
-BuildRequires: SDL_mixer-devel
-BuildRequires: SDL_ttf-devel
-BuildRequires: autoconf >= 2.68
-BuildRequires: automake >= 1.11
+BuildRequires: Qt5Network-devel
+BuildRequires: qt5-build
+BuildRequires: Qt5Widgets-devel
+BuildRequires: SDL2-devel
+BuildRequires: SDL2_image-devel
+BuildRequires: SDL2_mixer-devel
+BuildRequires: SDL2_ttf-devel
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.8.5
 BuildRequires: ffmpeg-devel
@@ -35,15 +34,12 @@ H3 engine rewrie (not another mod) with new possibilities.
 
 %prep
 %setup -q
-%patch0 -p1
-cp %{SOURCE2} aclocal/m4
 
 %build
-%{__aclocal} -I aclocal/m4
-%{__autoconf}
-%{__automake}
-export CXXFLAGS="%{rpmcflags}"
-%configure
+install -d build
+cd build
+%cmake \
+       ..
 %{__make}
 
 %install
@@ -52,7 +48,7 @@ install -d $RPM_BUILD_ROOT%{_datadir}/%{name} \
        $RPM_BUILD_ROOT%{_pixmapsdir} \
        $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{64x64,48x48,32x32}/apps
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install client/icons/vcmiclient.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/vcmiclient.xpm
@@ -60,27 +56,21 @@ install client/icons/vcmiclient.64x64.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/64
 install client/icons/vcmiclient.48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/vcmiclient.png
 install client/icons/vcmiclient.32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/vcmiclient.png
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/AI/*.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}{/Scripting,}/*.{la,so}
-
-%{__unzip} %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}
+echo A | %{__unzip} %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README
+%doc AUTHORS ChangeLog README.md
 %attr(755,root,root) %{_bindir}/%{name}*
-%attr(755,root,root) %{_libdir}/%{name}/lib%{name}*.so.?.*.*
-%attr(755,root,root) %ghost %{_libdir}/%{name}/lib%{name}*.so.?
+%attr(755,root,root) %{_libdir}/%{name}/lib%{name}*.so
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/AI
 %attr(755,root,root) %{_libdir}/%{name}/AI/lib*.so
-%dir %{_libdir}/%{name}/Scripting
-%attr(755,root,root) %{_libdir}/%{name}/Scripting/lib*.so.?.*.*
-%attr(755,root,root) %ghost %{_libdir}/%{name}/Scripting/lib*.so.?
 %{_datadir}/%{name}
 %{_desktopdir}/%{name}client.desktop
+%{_desktopdir}/vcmilauncher.desktop
 %{_pixmapsdir}/%{name}client.xpm
 %{_iconsdir}/hicolor/*x*/apps/%{name}client.png
This page took 0.087837 seconds and 4 git commands to generate.