]> git.pld-linux.org Git - packages/valgrind.git/commitdiff
- fix: vex amd64->IR: unhandled instruction bytes: 0x66 0xF 0x3A 0x61 0x7 0x0 auto/th/valgrind-3_6_0-3
authorPaweł Sikora <pluto@pld-linux.org>
Mon, 17 Jan 2011 17:23:54 +0000 (17:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
       https://bugs.kde.org/show_bug.cgi?id=262995
- release 3.

Changed files:
    valgrind-pr262995.patch -> 1.1
    valgrind.spec -> 1.79

valgrind-pr262995.patch [new file with mode: 0644]
valgrind.spec

diff --git a/valgrind-pr262995.patch b/valgrind-pr262995.patch
new file mode 100644 (file)
index 0000000..6c14c90
--- /dev/null
@@ -0,0 +1,24 @@
+FIX: vex amd64->IR: unhandled instruction bytes: 0x66 0xF 0x3A 0x61 0x7 0x0
+
+https://bugs.kde.org/show_bug.cgi?id=262995
+
+--- valgrind-3.6.0/VEX/priv/guest_amd64_toIR.c.orig    2010-10-20 22:19:51.000000000 +0200
++++ valgrind-3.6.0/VEX/priv/guest_amd64_toIR.c 2011-01-17 19:03:14.517469329 +0100
+@@ -15354,6 +15354,7 @@ DisResult disInstr_AMD64_WRK (
+          any cases for which the helper function has not been
+          verified. */
+       switch (imm) {
++         case 0x00:
+          case 0x02: case 0x08: case 0x0A: case 0x0C: case 0x12:
+          case 0x1A: case 0x3A: case 0x44: case 0x4A:
+             break;
+--- valgrind-3.6.0/VEX/priv/guest_generic_x87.c.orig   2010-10-20 22:19:51.000000000 +0200
++++ valgrind-3.6.0/VEX/priv/guest_generic_x87.c        2011-01-17 19:03:59.611838375 +0100
+@@ -715,6 +715,7 @@ Bool compute_PCMPxSTRx ( /*OUT*/V128* re
+       even if they would probably work.  Life is too short to have
+       unvalidated cases in the code base. */
+    switch (imm8) {
++      case 0x00:
+       case 0x02: case 0x08: case 0x0A: case 0x0C: case 0x12:
+       case 0x1A: case 0x3A: case 0x44: case 0x4A:
+          break;
index dd37e1b26fe0223dcc9059da40c9733bb621afd9..86c6682db3079a1582a95fd2e39aa174543c2758 100644 (file)
@@ -2,12 +2,13 @@ Summary:      An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
 Version:       3.6.0
-Release:       2
+Release:       3
 License:       GPL
 Group:         Development/Tools
 Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
 # Source0-md5: b289c5f4ab8e39741602445f1dd09b34
 Patch0:                %{name}-debuginfo.patch
+Patch1:                %{name}-pr262995.patch
 URL:           http://valgrind.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -42,6 +43,7 @@ pracować.
 %prep
 %setup -q
 %patch0
+%patch1 -p1
 
 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
 
This page took 0.123509 seconds and 4 git commands to generate.