- glibc 6.22 is fine now (handled by generic condition in configure) auto/th/valgrind-3.11.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 16 Nov 2015 18:52:22 +0000 (19:52 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 16 Nov 2015 18:52:22 +0000 (19:52 +0100)
- x32 ABI is still not supported; x32 package contains 64-bit valgrind supporting x86_64 and i386 ABIs

valgrind.spec

index a800fffe8dfe51469b85b71f013e161ad5c54731..523b504ed6e55f475a6bd97df5a78cee4dfbcc4b 100644 (file)
@@ -19,9 +19,11 @@ URL:         http://valgrind.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.10
 BuildRequires: gcc >= 5:3.0
+%ifarch x32
+BuildRequires: gcc-multilib-64 >= 5:3.0
+%endif
 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
 BuildRequires: glibc-devel >= 6:2.2
-BuildRequires: glibc-devel < 6:2.22
 BuildRequires: libgomp-devel
 BuildRequires: libstdc++-devel
 %{?with_mpi:BuildRequires:     mpi-devel}
This page took 0.267052 seconds and 4 git commands to generate.