]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
#Source0-md5:
[packages/valgrind.git] / valgrind.spec
1 %define         snap    20030517
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        1.9.6
6 Release:        1.%{snap}.1
7 License:        GPL
8 ExclusiveArch:  %{ix86}
9 Group:          Networking/Utilities
10 #Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
11 #Source0-md5:   fc986c28be6a5f4aa0a52a958d3620c3
12 Source0:        %{name}-%{snap}.tar.bz2
13 URL:            http://developer.kde.org/~sewardj/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # Valgrind binaries should _never_ be stripped
19 %define         no_install_post_strip   1
20
21 # Same name as libpthread
22 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
23
24 %description
25 Valgrind is a flexible tool for debugging and profiling Linux-x86
26 executables. The tool consists of a core, which provides a synthetic
27 x86 CPU in software, and a series of "skins", each of which is a
28 debugging or profiling tool. The architecture is modular, so that new
29 skins can be created easily and without disturbing the existing
30 structure.
31
32 A number of useful skins are supplied as standard. In summary, these
33 are:
34 - The memcheck skin detects memory-management problems in your
35   programs,
36 - cachegrind performs detailed simulation of the I1, D1 and L2 caches
37   in your CPU and so can accurately pinpoint the sources of cache misses
38   in your code,
39 - addrcheck skin is a lightweight version of memcheck,
40 - helgrind is designed to find data races in multithreaded programs.
41
42 %description -l pl
43 Valgrind jest elastycznym narzêdziem s³u¿±cym do odpluskwiania i
44 profilowania programów pod Linuksem. Sk³ada siê z rdzenia
45 dostarczaj±cego syntetyczny emulowany procesor zgodny z x86 i ze
46 "skórek" bêd±cych narzêdziami o ró¿nych zastosowaniach. Architektura
47 programu jest modularna, wobec czego ³atwo mo¿na stworzyæ nowe skórki
48 nie ryzykuj±c popsucia reszty.
49
50 Standardowo dostarczone jest kilka u¿ytecznych skórek:
51 - memcheck wykrywa problemy z zarz±dzaniem pamiêci± w programach,
52 - cachegrind przeprowadza symulacjê pamiêci cache procesora w celu
53   znalezienia miejsc, w których cache zawodzi,
54 - addrcheck jest lekk± wersj± memchecka,
55 - helgrind wykrywa konflikty dostêpu w wielow±tkowych programach.
56
57 %prep
58 %setup -q -n %{name}
59
60 %build
61 rm -f missing
62 %{__aclocal}
63 %{__autoheader}
64 %{__autoconf}
65 %{__automake}
66 %configure \
67         LDFLAGS="" # no strip!
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS PATCHES_APPLIED
81 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
82 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
83 %attr(755,root,root) %{_bindir}/*
84 %{_includedir}/*
85 %{_libdir}/%{name}
This page took 0.036248 seconds and 4 git commands to generate.