]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- updated to 3.11.0
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 #
4 # Conditional build:
5 %bcond_with     mpi     # MPI wrapper module
6 #
7 Summary:        An open-source memory debugger
8 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
9 Name:           valgrind
10 Version:        3.11.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Development/Tools
14 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
15 # Source0-md5:  4ea62074da73ae82e0162d6550d3f129
16 Patch0:         %{name}-native-cpuid.patch
17 Patch1:         %{name}-ld_linux_strlen.patch
18 URL:            http://valgrind.org/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake >= 1:1.10
21 BuildRequires:  gcc >= 5:3.0
22 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
23 BuildRequires:  glibc-devel >= 6:2.2
24 BuildRequires:  glibc-devel < 6:2.22
25 BuildRequires:  libgomp-devel
26 BuildRequires:  libstdc++-devel
27 %{?with_mpi:BuildRequires:      mpi-devel}
28 Obsoletes:      valgrind-callgrind
29 Obsoletes:      valgrind-calltree
30 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x x32
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautostrip    .*/vgpreload.*\\.so
34 %define         filterout_c     -fstack-protector-strong
35 # ld portion broken
36 %undefine       with_ccache
37
38 %description
39 Valgrind is a GPL'd system for debugging and profiling Linux programs.
40 With the tools that come with Valgrind, you can automatically detect
41 many memory management and threading bugs, avoiding hours of
42 frustrating bug-hunting, making your programs more stable. You can
43 also perform detailed profiling to help speed up your programs.
44
45 %description -l pl.UTF-8
46 Valgrind jest systemem służącym do odpluskwiania i profilowania
47 programów na Linuksie. Używając dostarczanych z nim narzędzi można
48 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
49 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
50 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
51 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
52 pracować.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58
59 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
60
61 %build
62 %{__aclocal}
63 %{__autoconf}
64 %{__autoheader}
65 %{__automake}
66
67 ac_cv_path_GDB=/usr/bin/gdb \
68 %configure \
69         CC=gcc \
70         --enable-tls \
71 %if %{_lib} != "lib"
72         --enable-only64bit \
73 %endif
74         LDFLAGS="" # no strip!
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
85 cp -p docs/index.pdf docs/valgrind_manual.pdf
86 cp -p docs/index.ps docs/valgrind_manual.ps
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
94 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
95 %attr(755,root,root) %{_bindir}/callgrind_annotate
96 %attr(755,root,root) %{_bindir}/callgrind_control
97 %attr(755,root,root) %{_bindir}/cg_annotate
98 %attr(755,root,root) %{_bindir}/cg_diff
99 %attr(755,root,root) %{_bindir}/cg_merge
100 %attr(755,root,root) %{_bindir}/ms_print
101 %attr(755,root,root) %{_bindir}/valgrind
102 %attr(755,root,root) %{_bindir}/valgrind-di-server
103 %attr(755,root,root) %{_bindir}/valgrind-listener
104 %attr(755,root,root) %{_bindir}/vgdb
105 %dir %{_libdir}/%{name}
106 %attr(755,root,root) %{_libdir}/%{name}/*-linux
107 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
108 %if %{with mpi}
109 # TODO: subpackage?
110 %attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
111 %endif
112 %{_libdir}/%{name}/*.xml
113 %{_libdir}/%{name}/default.supp
114 %{_libdir}/%{name}/lib*-linux.a
115 %{_includedir}/valgrind
116 %{_mandir}/man1/callgrind_annotate.1*
117 %{_mandir}/man1/callgrind_control.1*
118 %{_mandir}/man1/cg_annotate.1*
119 %{_mandir}/man1/cg_diff.1*
120 %{_mandir}/man1/cg_merge.1*
121 %{_mandir}/man1/ms_print.1*
122 %{_mandir}/man1/valgrind.1*
123 %{_mandir}/man1/valgrind-listener.1*
124 %{_mandir}/man1/vgdb.1*
125 %{_pkgconfigdir}/valgrind.pc
This page took 0.040799 seconds and 4 git commands to generate.